The forum of the forums
Welcome to the Official Support Forum of Forumotion!

To take full advantage of everything offered by our forum, please log in if you are already a member, or join our community if you've not yet.



Create a free forum like this one.

Background image not repeat vertically in forum !

View previous topic View next topic Go down

In progress Background image not repeat vertically in forum !

Post by Sunborn on February 7th 2012, 5:34 pm

Hello!

I have a problem with a background image that it is not repeat vertically in forum !
The weird thing is that it is fine in the portal !!

See how it looks in the portal...



...and how it looks in the forum !




I can't understand how is this possible!
I change the code many times, but nothing changed...

This is the code...

Code:
div.newslink{
background-color: transparent;
}
#outer-wrapper{
background-image: url('http://i42.servimg.com/u/f42/17/22/76/14/sans-t10.png');
background-repeat: repeat-y;
width: 980px;
padding: 0px;
margin: 0px;
}

#wrapper{
margin: 0px 64px;
}

I also use the next code, but the solution is ugly
Code:
min-height: 3200px;

The default value was..
Code:
min-height: 25px;

This is the background image



If any one knows a solution please help...

Thank you!

Sunborn
New Member

Male Posts : 18
Reputation : 1
Language : Greek, English, Quenya
Location : Thessaloniki, Greece

http://utopicdemocracy.forumgreek.com

Back to top Go down

In progress Re: Background image not repeat vertically in forum !

Post by Base on February 7th 2012, 5:51 pm

Hi, your best bet is to use this CSS code:

Code:
#ipbwrapper {
    background-image: url("http://i42.servimg.com/u/f42/17/22/76/14/sans-t11.png");
    margin: 0 auto;
    min-width: 951px;
    padding: 0;
    text-align: left;
    width: 838px;
}

With some edits to the image, it is possible to fix it completely. Smile

Base
Forumaster

Male Posts : 10386
Reputation : 1687
Language : English and French
Location : United Kingdom, England

http://forumotionhub.net

Back to top Go down

In progress Re: Background image not repeat vertically in forum !

Post by Sunborn on February 7th 2012, 11:20 pm

It is working but not exactly as i expect...
You see, my header and footer are transparent png images, and the other background image (the one in the code), starts from the top 'till the bottom of the page, and the solution its a bit ugly...

Check by yourself to see...
http://utopicdemocracy.forumgreek.com

But generally it is much better than before. Thank you for this code, Base !
It's a good start. Smile

So what i want now, is a way to make this background image to start from the bottom of the header and stop at the top of the footer !
Is this possible??? (...yes, everything is possible if you know the way!)

I play with the code values, but nothing important happened...
Any idea scratch ?

Sunborn
New Member

Male Posts : 18
Reputation : 1
Language : Greek, English, Quenya
Location : Thessaloniki, Greece

http://utopicdemocracy.forumgreek.com

Back to top Go down

In progress Re: Background image not repeat vertically in forum !

Post by Base on February 8th 2012, 5:41 pm

Hmm... you could try this although it would only fix the footer problem:

Code:
#ipbwrapper {
    background-image: url("http://i42.servimg.com/u/f42/17/22/76/14/sans-t11.png");
    background-position: center center;
    height: 2810px;
    min-width: 980px;
    padding: 0;
    text-align: left;
    width: 980px;
}

Base
Forumaster

Male Posts : 10386
Reputation : 1687
Language : English and French
Location : United Kingdom, England

http://forumotionhub.net

Back to top Go down

In progress Re: Background image not repeat vertically in forum !

Post by Sunborn on February 8th 2012, 11:03 pm

No it is not working, not even the footer...
Can you look at the whole code please, is it possible that some settings are mismatched ?

Code:
#ipbwrapper{
background-image: url("http://i42.servimg.com/u/f42/17/22/76/14/sans-t11.png");
background-position: center center;
height: 2810px
min-width: 980px;
margin: 0 auto;
padding: 0;
text-align: left;
width: 980px;
margin-top: 15px;
margin-bottom: 15px;
}

Also I've notice, that when i don't use these values

Code:
margin: 0 auto;
margin-top: 15px;
margin-bottom: 15px;


the image goes a long way below the footer, in the portal, and stops much before the footer, in the forum (in long posts)

...and actually the problem is in the forum only!
The portal looks quiet nice, without any of these codes...
The codes you gave me, fix a part of the problem in the forum, but also they destroy the aesthetic harmony in the portal...


Last edited by Sunborn on February 8th 2012, 11:43 pm; edited 1 time in total (Reason for editing : add more info)

Sunborn
New Member

Male Posts : 18
Reputation : 1
Language : Greek, English, Quenya
Location : Thessaloniki, Greece

http://utopicdemocracy.forumgreek.com

Back to top Go down

In progress Re: Background image not repeat vertically in forum !

Post by Sunborn on February 10th 2012, 8:16 pm

Nothing yet...

2 days i was going through a lot of codes.
I did a lot of work in my forum, insert a lot of codes, from paypal to mp3 player, web radio, a lot...!!!

...but no solution for this little stupid thing, which looks something very simple???

I am ready to smash my head on the wall, please save me ! lol!

Sunborn
New Member

Male Posts : 18
Reputation : 1
Language : Greek, English, Quenya
Location : Thessaloniki, Greece

http://utopicdemocracy.forumgreek.com

Back to top Go down

In progress Re: Background image not repeat vertically in forum !

Post by Sunborn on February 14th 2012, 7:18 pm

Still no answer ?
It must be really a difficult problem! scratch

Sunborn
New Member

Male Posts : 18
Reputation : 1
Language : Greek, English, Quenya
Location : Thessaloniki, Greece

http://utopicdemocracy.forumgreek.com

Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum