The forum of the forums
Welcome to the Official Support Forum of Forumotion!

To take full advantage of everything offered by our forum, please log in if you are already a member, or join our community if you've not yet.



Create a free forum like this one.

WYSIWYG editor missing when editing a post

View previous topic View next topic Go down

WYSIWYG editor missing when editing a post

Post by Joshy195 on May 22nd 2012, 1:46 pm

Hi

During the last couple of days the WYSIWYG Editor has disappeared when editing posts. It still appears for quick reply but not for editing posts. When editing posts it only shows one of the icons of the WYSIWYG Editor instead of all of them. Could someone help me regarding this matter?

Forum site: gridmastergt5.forumfreek.com

Edit: I've also deleted the cache for my browser but still ddiesnt display. It's happening with all users. Maybe it's the CSS Stylesheet but I've checked and it all looks good.

Joshy195
New Member

Male Posts : 4
Reputation : 1
Language : English(UK)

http://www.gridmastergt5.forumfreek.com

Back to top Go down

Re: WYSIWYG editor missing when editing a post

Post by dman on May 22nd 2012, 6:03 pm

I've fixed the WYSIWYG Joshy
General-> messages and emails->config-> allow html-on-> enable WYSIWYG

dman
New Member

Posts : 1
Reputation : 1
Language : English

Back to top Go down

Re: WYSIWYG editor missing when editing a post

Post by Joshy195 on May 22nd 2012, 6:07 pm

Nahh, I've tried that aswell but when you go to edit a post or create a new topic the bar(WYSIWYG or Advanced Editor) at the top to add images and links etc. doesn't show.

Joshy195
New Member

Male Posts : 4
Reputation : 1
Language : English(UK)

http://www.gridmastergt5.forumfreek.com

Back to top Go down

Re: WYSIWYG editor missing when editing a post

Post by APE on May 22nd 2012, 6:24 pm

I some times get this problem also not all the time thou i was thinking it was to do with a java code i have or some thing along that line but was not sure next time it comes up i will grab a screen shot of it Wink
Now i know its not just me getting the problem i Must say i have also had it on here 2 or 3 times even in pm





APE
Manager
Manager

Male Posts : 8631
Reputation : 756
Language : fluent in dork / mumbojumbo & English haha
Location : STUCK IN FORUMOTIONS SERVERS HELP ME !!!!!!

http://chatworld.forumotion.co.uk/

Back to top Go down

Re: WYSIWYG editor missing when editing a post

Post by Joshy195 on May 22nd 2012, 6:26 pm

I've also just run the debug console for my browser and it comes up with this error: JavaScript: Error
Undefined
ReferenceError: can't find variable :messages

Any ideas anyone? Is it something to do with my CSS StyleSheet

Joshy195
New Member

Male Posts : 4
Reputation : 1
Language : English(UK)

http://www.gridmastergt5.forumfreek.com

Back to top Go down

Re: WYSIWYG editor missing when editing a post

Post by Joshy195 on May 22nd 2012, 6:57 pm

Sorted it and it was something to do with JavaScript and that error. Modules>HTML and JavaScript>JavaScript codes management> Turn off JavaScript Code Management.

All fixed now. If this topic has no posts in 24hrs then lock it

Joshy195
New Member

Male Posts : 4
Reputation : 1
Language : English(UK)

http://www.gridmastergt5.forumfreek.com

Back to top Go down

Re: WYSIWYG editor missing when editing a post

Post by SLGray on May 22nd 2012, 8:18 pm

@Joshy195 wrote:I've also just run the debug console for my browser and it comes up with this error: JavaScript: Error
Undefined
ReferenceError: can't find variable :messages

Any ideas anyone? Is it something to do with my CSS StyleSheet

@Joshy195 wrote:Sorted it and it was something to do with JavaScript and that error. Modules>HTML and JavaScript>JavaScript codes management> Turn off JavaScript Code Management.

All fixed now. If this topic has no posts in 24hrs then lock it

Please don't double/triple post. Your post need to be separated by 24 hours before bumping, replying or adding more information. Please use the edit button instead!


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 36697
Reputation : 2445
Language : English
Location : United States

http://ztwds.forumotion.com/

Back to top Go down

Re: WYSIWYG editor missing when editing a post

Post by LGforum on May 22nd 2012, 9:50 pm

Yes I believe I've mentioned this before.

Those buttons for your editors are inserted via Javascript. Because of that, if you have an error in any of the javascripts you add to your forum, if they hit an error, then those buttons will not shows... since the Javascript engine has hit an error.

[quote="Joshy195"]
I've also just run the debug console for my browser and it comes up with this error: JavaScript: Error
Undefined
ReferenceError: can't find variable :messages

Any ideas anyone? Is it something to do with my CSS StyleSheet
[/code]
No, a Javascript error is not the CSS, its the Javascript Razz

Just so you know, disabling Javascript does not fully solve your issue. As soon as you turn it back on whatever invalid Javascript you have on your board will be present again in the pages and will cause those buttons not to show.

LGforum
Hyperactive

Male Posts : 2260
Reputation : 258
Language : English
Location : UK

http://www.avacweb.com/

Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum