The forum of the forums
Welcome to the Official Support Forum of Forumotion!

To take full advantage of everything offered by our forum, please log in if you are already a member, or join our community if you've not yet.



Create a free forum like this one.

Edit field value icon not appearing.

View previous topic View next topic Go down

Solved Edit field value icon not appearing.

Post by ℋunni on June 10th 2012, 6:38 am

As of today, it hasn't appeared when I, or my Staff members hover over the field we want to edit.
Any ideas?

ℋunni
Forumember

Female Posts : 150
Reputation : 4
Language : English

Back to top Go down

Solved Re: Edit field value icon not appearing.

Post by Sanket on June 10th 2012, 9:14 am

Display>Pics management
Advanced mode
Check if the image is there?

Sanket
ForumGuru

Male Posts : 48766
Reputation : 2819
Language : English
Location : Mumbai

http://webartzforum.com

Back to top Go down

Solved Re: Edit field value icon not appearing.

Post by ℋunni on June 10th 2012, 10:22 am

Yup. All of the images are where they should be.

ℋunni
Forumember

Female Posts : 150
Reputation : 4
Language : English

Back to top Go down

Solved Re: Edit field value icon not appearing.

Post by Sanket on June 10th 2012, 10:25 am

Did you lately add any code or anything after this problem started? If yes, then remove it & check.

If thats not the case, do you have forum widgets installed? Then remove the custom widgets one by one & check if any of them was causing the problem.

Sanket
ForumGuru

Male Posts : 48766
Reputation : 2819
Language : English
Location : Mumbai

http://webartzforum.com

Back to top Go down

Solved Re: Edit field value icon not appearing.

Post by ℋunni on June 10th 2012, 10:09 pm

I saw others are having the same problem. So I did install JS lately with LGForum.
I'll see if it's the widgets or scripts causing this.

So, after a few minutes, it's the JavaScript, seeing as how when I turned all of them off, the icons started reappearing.

The JavaScript that seems to be breaking this is below:
Seeing as it's a code by LGForum, I've brought it to his attention through his site, but maybe this has already been recently resolved on here.

Code:
$(function() {
var x=$('#right .module')[0].getElementsByTagName('img'); var uav;
if (x.length>0){ uav='<img src="'+x[0].src+'" />'; } else { uav='<img src="http://i.imgur.com/yCijq.png" />'; }
$('.AVATAR').html(uav);
$('#right .module')[0].style.display="none";
});


EDIT: So, it was that JavaScript and LGForum fixed it up perfectly. Solved <3.


Last edited by ℋunni on June 10th 2012, 10:29 pm; edited 1 time in total

ℋunni
Forumember

Female Posts : 150
Reputation : 4
Language : English

Back to top Go down

Solved Re: Edit field value icon not appearing.

Post by LGforum on June 10th 2012, 10:27 pm

To anyone else who may experience this issue with this script, a fix is provided here and the tutorial will be updated: http://www.avacweb.com/t271-profile-fields-edit#2682

Sorry for the issue. Sometimes I forget something.
To those interested in learning, this situation was caused by the fact that the sidebars are not in the page on the userprofile pages.
So this bit: '$('#right .module')[0].getElementsByTagName('img');'
Was causing the error, because the element does not exist. And so when it hit that error, other javascript errored and the eventListener for the profile fields was not set.

LGforum
Hyperactive

Male Posts : 2254
Reputation : 254
Language : English
Location : UK

http://www.avacweb.com/

Back to top Go down

Solved Re: Edit field value icon not appearing.

Post by Sanket on June 11th 2012, 1:31 pm

Topic Solved & Locked

Sanket
ForumGuru

Male Posts : 48766
Reputation : 2819
Language : English
Location : Mumbai

http://webartzforum.com

Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum