The forum of the forums
Welcome to the Official Support Forum of Forumotion!

To take full advantage of everything offered by our forum, please log in if you are already a member, or join our community if you've not yet.



Create a free forum like this one.

CSS destroys my forum (on firefox)

View previous topic View next topic Go down

Solved CSS destroys my forum (on firefox)

Post by Guest on July 12th 2012, 10:34 am

Opera: http://i236.photobucket.com/albums/ff40/iathen/opera.jpg
Firefox: http://i236.photobucket.com/albums/ff40/iathen/mozilla-1.jpg


Hello,

I'm trying to find a way to put my customised buckground in the forum. I wainted to first find that way and then design the image that I'm gonna use, so I created this image: http://i236.photobucket.com/albums/ff40/iathen/test2-1.png .

It seemed like working in firefox, then (1) I changed something in the CSS code and pressed "send". Then my forum became a mess. (2)I reseted the CSS at the previous form but the problem did not get fixed. (3)I deleted all my CSS code but nothing changed (forum was still a mess).

(1)So I reinstalled the forum version(default values). The forum seemed nice. (2)I added the same code and nothing changed (the picture did not get in the background this time). So (3) I edited something again, and my forum was again a mess. That was when I opened opera and I saw that my forum looks as I wanted.

I reinstalled invision(default) for the third time and still had the same behavour. I start thinking that my forum is bugged but before I go to technicians, I'd like to hear your opinion because it may be something that I can fix by my own.

Please check how my forum looks to your computers too. And please help me if you can.

PS:Code used in css:
Code:
BODY {
  background-image:url(http://i236.photobucket.com/albums/ff40/iathen/test2-1.png);
  background-color:#000000;
  -moz-background-size:100% 50px;        /* Gecko 1.9.2 (Firefox 3.6) */
  -o-background-size:100% 50px;          /* Opera 9.5 */
  -webkit-background-size:100% 50px;      /* Safari 3.0 */
  background-size:100% 50px;
  background-repeat:y-repeat;
}
(my forum: http://grotoshop.forumgreek.com/ )

Guest
Guest


Back to top Go down

Solved Re: CSS destroys my forum (on firefox)

Post by SLGray on July 12th 2012, 10:41 am

Have you tried installing your background image here:
Administration Panel > Display > Colors & Pictures > Pics Management
Advanced Mode
Index/Forum
Background Image:


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 36735
Reputation : 2446
Language : English
Location : United States

http://ztwds.forumotion.com/

Back to top Go down

Solved Re: CSS destroys my forum (on firefox)

Post by Guest on July 12th 2012, 10:51 am

If I do so, then I won't be able to make it fit for any screen resolution. :/
I will also have problem because I want the white and black parts be one image (so I can design a cool effect).

And I still have problem because even if I delete all my css, the forum will remain a mess. So I have to reinstall default version. And lets say that this is ok now that I have no members... but what if this happens in the future? Shouldn't I know a way to fix it without having to link again all the skin's images?

Sad

Guest
Guest


Back to top Go down

Solved Re: CSS destroys my forum (on firefox)

Post by SLGray on July 12th 2012, 10:53 am

Does it do it every time you refresh the page or load another page? It looks fine when I visit using Firefox.


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 36735
Reputation : 2446
Language : English
Location : United States

http://ztwds.forumotion.com/

Back to top Go down

Solved Re: CSS destroys my forum (on firefox)

Post by Guest on July 12th 2012, 11:04 am

the forum's appearance randomly changed every time I click "submit" on css sheet (never changes with just reflesh).
See what I mean:
http://i236.photobucket.com/albums/ff40/iathen/1-3.jpg
http://i236.photobucket.com/albums/ff40/iathen/2-3.jpg


http://i236.photobucket.com/albums/ff40/iathen/3-2.jpg

O.O
On the last 5 clicks it didn't change... I'll mark this as solved though I' not sure what happened. Thanks very much though!!!


PS: I would really estimate it if you explain me what was the problem so I won't make it again. But if you don't know, it's really ok. (It was a display bug just for me maybe)

Guest
Guest


Back to top Go down

Solved Re: CSS destroys my forum (on firefox)

Post by LGforum on July 12th 2012, 1:05 pm

It just sounded like Firefox cached the CSS at a coincidentally inconvenient time.

LGforum
Hyperactive

Male Posts : 2260
Reputation : 258
Language : English
Location : UK

http://www.avacweb.com/

Back to top Go down

Solved Re: CSS destroys my forum (on firefox)

Post by Guest on July 12th 2012, 5:58 pm

That shounds like a good explanation. Thanks very much.


Topic is solved! I'm sorry but I can't edit the topic's icon :/.

Guest
Guest


Back to top Go down

Solved Re: CSS destroys my forum (on firefox)

Post by SLGray on July 12th 2012, 6:01 pm

Topic Solved & Locked


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 36735
Reputation : 2446
Language : English
Location : United States

http://ztwds.forumotion.com/

Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum