The forum of the forums
Welcome to the Official Support Forum of Forumotion!

To take full advantage of everything offered by our forum, please log in if you are already a member, or join our community if you've not yet.



Create a free forum like this one.

Generated Nav issue Punbb

View previous topic View next topic Go down

Generated Nav issue Punbb

Post by nextlevelgaming on September 24th 2012, 7:59 pm

So I started a test site, since Ive been working with phpbb2 for years, and Rideem recommended punbb so yeah i did that. I have a nice nav on left side. Though when in css text-align:right does not work fully with the link "You have no new messages" So I figured what I could do is generate my own custom nav, and have that "You have no new messages" and "You have %N new messages" some where else.

Question:

Does anyone know the code to have this done and switch correctly? or maybe is it possible to kill all other {generated_nav} links and have the messages alone and place it some where with the css??? I wanted to place it anywhere i wanted really. Since in my CSS the text-align:right does not work for that specific link...

basically I'll wait for Rideem or LG for the answer unless someone know for sure. Thanks guys.

nextlevelgaming
Forumember

Male Posts : 989
Reputation : 38
Language : English|CSS|HTML5|javascript|
Location : New York

http://www.easybbtutorials.forumotion.com

Back to top Go down

Re: Generated Nav issue Punbb

Post by nextlevelgaming on September 25th 2012, 6:01 am

Yeah it aligns the text fine, besides the "you have no messages" the s is farther off to the right than the rest. and thats the css that i used as well Smile

Hey Rideem, have a question for ya if ya know jQuery. I have the pun-navlinks set as relative, and the pun-navlinks ul set as fixed. Theres a code to make it so it doesn't move horizontally when resizing the window.

Code:
$(window).scroll(function(event) {
  $("#pun-navlinks").css("margin-left", $("#pun-navlinks").css("margin-left")-$(document).scrollLeft());
});

Though it does not seem to be working for me.

Javascript is on,
file is set to all pages.


Last edited by nextlevelgaming on September 25th 2012, 7:10 am; edited 1 time in total (Reason for editing : need help with this discussion.)

nextlevelgaming
Forumember

Male Posts : 989
Reputation : 38
Language : English|CSS|HTML5|javascript|
Location : New York

http://www.easybbtutorials.forumotion.com

Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum