The forum of the forums
Welcome to the Official Support Forum of Forumotion!

To take full advantage of everything offered by our forum, please log in if you are already a member, or join our community if you've not yet.



Create a free forum like this one.

Problem with spam bots..

View previous topic View next topic Go down

Solved Problem with spam bots..

Post by ~2K~ on February 10th 2013, 5:37 pm

So I signed into my forum this morning to find that several spam bots had hit my forum, spamming with several hundred posts. This is the first time this is happened since I started up the forum back in September.
I have the "block common spam bot names" thing on in the admin panel, and have had it on since the start, so why are they able to slip past?
Also, after managing to delete all the main topics, I continued on to deleting their posts from the normal member made topics, but their posts are so big that it is wanting to freeze up our computers. So I thought "I'll just set back the forum 24 hours and it will take off all of the spam bots and their posts" but after using the http://www.forumotion.com/en/utils/ , it didn't work.
Anyway, we're still working on cleaning up all the spam bots, but I was wondering, I know that there is an easier way to delete topics through the moderater panel, but is there an easier way to delete posts from regular topics?
Is there anything else I can do to try and prevent future attacks?
Is there a way to maybe set it up so a new members first post has to be approved and then they can post freely?
Is there a way to delete all of a members posts without deleting them individualy?

And sorry if this is in the wrong spot, I wasn't sure if I should put this here or in the admin
Thanks for any help you all can give. Smile

*Also, I had made another member Admin months ago and they could sign into the admin panel with no problem, not today his Admin panel link isn't showing up.

*Also, I have all the permissions set to were guests can't post in any of the forums, yet they're still posting. Is forumotion having a bunch of bugs or are they hacking in somehow?


Last edited by ~2K~ on February 10th 2013, 6:29 pm; edited 2 times in total

~2K~
New Member

Posts : 13
Reputation : 1
Language : english

Back to top Go down

Solved Re: Problem with spam bots..

Post by ~2K~ on February 10th 2013, 5:42 pm

Oops, forgot the link to my forum. Smile
http://mylittleponyfans.forumotion.com/forum

~2K~
New Member

Posts : 13
Reputation : 1
Language : english

Back to top Go down

Solved Re: Problem with spam bots..

Post by Sanket on February 10th 2013, 7:00 pm

Please don't double/triple post. Your post need to be separated by 24 hours before bumping, replying or adding more information. Please use the edit button instead!

Firstly, spammers are after all humans. You cannot completely avoid them, but you can slow down their spamming rate.
General>Forum>Security
Unauthorize unofficial forms to post messages and private messages on the forum : Yes

Flood control. Delay between 2 messages, topics or private messages by a user. : Choose a longer period
IP address accounts creation limit, for each 24 hours : 1

Also, about the admin panel link gone. Check if the user is still in the administrators group or not.

Sanket
ForumGuru

Male Posts : 48766
Reputation : 2819
Language : English
Location : Mumbai

http://webartzforum.com

Back to top Go down

Solved Re: Problem with spam bots..

Post by ~2K~ on February 10th 2013, 7:12 pm

I have all of those things on and set like that.
And the Admin was able to go to the panel before with no problem and I haven't edited his account or anything to change that. I also double checked everything, and everything checks out for him to be able to go to the admin panel.

Also, I have it disabled so guests can not post, yet they are still posting. Even though I can't even post as a guest (I checked).

I'm going use the "forum in construction" thing to put the forum under a temp lock down, hopefully the bugs will have run through the system by the time the forum comes back up.

~2K~
New Member

Posts : 13
Reputation : 1
Language : english

Back to top Go down

Solved Re: Problem with spam bots..

Post by Sanket on February 10th 2013, 7:15 pm

When was the guest post made? Any possibility that the user deleted himself from the forum after posting.

Can you login into his account & check if the admin panel link is gone or not?

Sanket
ForumGuru

Male Posts : 48766
Reputation : 2819
Language : English
Location : Mumbai

http://webartzforum.com

Back to top Go down

Solved Re: Problem with spam bots..

Post by ~2K~ on February 10th 2013, 7:21 pm

No, because after I deleted all the spam accounts and then the spammers were posting as guests (though it appeared really only be one that had an account, and it seems to speak korian). Plus, after the spam attack I set the forum to were all new accounts have to be approved by me, and I also have it to were no one can delete their accounts.

He's my brother, so I was able to just look over his should and see that there was no link. I also had him see if he could edit someone's profile by using the Profile button in the admin tools on a members page, but the link didn't show up like it does on my account. And I also had him try the /admin and it said he didn't have permission.

~2K~
New Member

Posts : 13
Reputation : 1
Language : english

Back to top Go down

Solved Re: Problem with spam bots..

Post by Sanket on February 10th 2013, 7:25 pm

Users & groups>Group administration
Click on modify corresponding to the administrator group.
Check if that user is there?

Sanket
ForumGuru

Male Posts : 48766
Reputation : 2819
Language : English
Location : Mumbai

http://webartzforum.com

Back to top Go down

Solved Re: Problem with spam bots..

Post by ~2K~ on February 10th 2013, 7:26 pm

He's there, and his username is red, which is the admin color.

~2K~
New Member

Posts : 13
Reputation : 1
Language : english

Back to top Go down

Solved Re: Problem with spam bots..

Post by Sanket on February 10th 2013, 7:27 pm

Is the admin panel link visible to you?

Sanket
ForumGuru

Male Posts : 48766
Reputation : 2819
Language : English
Location : Mumbai

http://webartzforum.com

Back to top Go down

Solved Re: Problem with spam bots..

Post by ~2K~ on February 10th 2013, 7:31 pm

Yes, and I can enter the /admin and also go to it through the profile link..

~2K~
New Member

Posts : 13
Reputation : 1
Language : english

Back to top Go down

Solved Re: Problem with spam bots..

Post by Sanket on February 10th 2013, 7:35 pm

Can you provide me with your brothers account details via PM?

Sanket
ForumGuru

Male Posts : 48766
Reputation : 2819
Language : English
Location : Mumbai

http://webartzforum.com

Back to top Go down

Solved Re: Problem with spam bots..

Post by ~2K~ on February 10th 2013, 7:36 pm

That's his name and password right?

~2K~
New Member

Posts : 13
Reputation : 1
Language : english

Back to top Go down

Solved Re: Problem with spam bots..

Post by Sanket on February 10th 2013, 7:38 pm

Yes, thats correct.

Sanket
ForumGuru

Male Posts : 48766
Reputation : 2819
Language : English
Location : Mumbai

http://webartzforum.com

Back to top Go down

Solved Re: Problem with spam bots..

Post by Sanket on February 10th 2013, 7:44 pm

As I see, he doesn't have access to the admin panel at all.
Please re-add him to the administrator group. I am 100% sure, he is not there inside the administrator group.

Sanket
ForumGuru

Male Posts : 48766
Reputation : 2819
Language : English
Location : Mumbai

http://webartzforum.com

Back to top Go down

Solved Re: Problem with spam bots..

Post by ~2K~ on February 10th 2013, 7:52 pm

I took him out of the group (though it still showed he was there?) and re-added him. I logged into his account and checked and it's working now. Smile Thanks!

Now, hopefully whatever bugs were going through the system with the spammers will clear up. I guess I'll know once the lock down is over if they've fixed themselves or not. I'm guessing there's nothing you can really do about those problems? I'll let you know if those problems continue. Though now that I've locked the forum down then all posts have stopped, so atleast they're not getting past the forum construction thing.

~2K~
New Member

Posts : 13
Reputation : 1
Language : english

Back to top Go down

Solved Re: Problem with spam bots..

Post by Sanket on February 10th 2013, 7:54 pm

Well, yes you are right about the spammers. Just try to keep them in control, thats all you can do.

Sanket
ForumGuru

Male Posts : 48766
Reputation : 2819
Language : English
Location : Mumbai

http://webartzforum.com

Back to top Go down

Solved Re: Problem with spam bots..

Post by ~2K~ on February 10th 2013, 8:12 pm

Ok, Thanks for the help! Smile

~2K~
New Member

Posts : 13
Reputation : 1
Language : english

Back to top Go down

Solved Re: Problem with spam bots..

Post by Sanket on February 11th 2013, 1:22 pm

Topic Solved & Locked

Sanket
ForumGuru

Male Posts : 48766
Reputation : 2819
Language : English
Location : Mumbai

http://webartzforum.com

Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum