The forum of the forums
Welcome to the Official Support Forum of Forumotion!

To take full advantage of everything offered by our forum, please log in if you are already a member, or join our community if you've not yet.



Create a free forum like this one.

Error using font for title Forum, sub forum and topic title.

View previous topic View next topic Go down

Error using font for title Forum, sub forum and topic title.

Post by sasukekun on May 11th 2013, 10:22 am

hello all Smile
I want to ask Sad

why my font doesnt work in my forum? (Error using font for title Forum, sub forum and topic title.)
before im using font type "spy agency" in my forum.

that font work only if in my computer/notebook. because before im install in my computer.

but in another computer/notebook, doesn't work. Sad

why about this?? i need my font work in another computer,
although another computer not install my font. Sad

more details about my problem you can see this picture:


my forum:
http://astajim.indonesianforum.net/

please help me, please Sad

thanks before bye

sasukekun
Forumember

Posts : 253
Reputation : 6
Language : English

Back to top Go down

Re: Error using font for title Forum, sub forum and topic title.

Post by E-Mark on May 11th 2013, 5:49 pm

This will not work without installing the font on your website. You need to have the .ttf file of the font. Btw, is the font free?

E-Mark
Active Poster

Male Posts : 1389
Reputation : 164
Language : English, Tagalog
Location : Republic of the Philippines

http://coding-spot.darkbb.com/

Back to top Go down

Re: Error using font for title Forum, sub forum and topic title.

Post by sasukekun on May 11th 2013, 6:04 pm

@E-Mark wrote:This will not work without installing the font on your website. You need to have the .ttf file of the font. Btw, is the font free?

yeah, this font (spy agency) for free,
you can visit this link for see or download: http://www.dafont.com/search.php?q=agency

ttf file?
ok im search in google mr.mark, and i found this file for font spy agency Very Happy
i need type: spyagency3condital.ttf
http://www.dafont.com/spy-agency.font?text=KICK+STARTER+SWAMI

continue what should I do mr.mark???

i dont know about this code, please help me Sad

thanks before mr.mark Very Happy



sasukekun
Forumember

Posts : 253
Reputation : 6
Language : English

Back to top Go down

Re: Error using font for title Forum, sub forum and topic title.

Post by sasukekun on May 12th 2013, 7:46 pm

BUMP!!

please some one help me Sad:

before i find this code,
but i dont know this code work or not, because i dont know how to use this code (explore this code so that font can work) for title forum, title sub forum, topic title.

this code
Code:
            @font-face {
              font-family: cool_font;
              src: url('cool_font.ttf');
            }

and this
Code:
            p.custom_font{
              font-family: cool_font; /* no .ttf */
            }

source this code:
http://www.howtoplaza.com/how-to-use-custom-fonts-on-your-website-with-css

this ttf link:
http://www.dafont.com/spy-agency.font?text=KICK+STARTER+SWAMI

-------------------------------------------------------------------------------

and i found about that code (use javascript)
and but i dont know about use this Sad

he say:
Like I told you, you need to use google fonts script for this... like so"
Code:
        WebFontConfig = {
                google: { families: [ 'Tangerine', 'Cantarell' ] }
              };
        (function() {
        var link_font = document.createElement('script');
        link_font.src=('https:' == document.location.protocol ? 'https' : 'http') +"://ajax.googleapis.com/ajax/libs/webfont/1/webfont.js";
        link_font.type="text/javascript";
        link_font.async="true";
        link_font.id="google_fonts";
        var get_script= document.getElementById('google_fonts')[0];
        get_script.parentNode.insertBefore(link_font,get_script);
        }();

CSS
Code:
        .element{font-family:'tangerine',sans-serif}
This way will be easier as it won't be such a long cache request.

-------------------------------------------

please explain again Sad:

i need use font spy agency for my forum and and can be seen for everything. T_T

please help me Sad

thanks before Smile:

sasukekun
Forumember

Posts : 253
Reputation : 6
Language : English

Back to top Go down

Re: Error using font for title Forum, sub forum and topic title.

Post by E-Mark on May 12th 2013, 11:03 pm

Add this to your CSS:
Code:
@font-face {
    font-family: SpyAgency;
    src: url('http://www.fontsaddict.com/download/spy-agency-condensed.ttf');
}
.secondarytitle, .secondarytitle h2 {
font-family: SpyAgency !important;
}

E-Mark
Active Poster

Male Posts : 1389
Reputation : 164
Language : English, Tagalog
Location : Republic of the Philippines

http://coding-spot.darkbb.com/

Back to top Go down

Re: Error using font for title Forum, sub forum and topic title.

Post by sasukekun on May 13th 2013, 1:52 am

yeah thanks for help me mr.mark Smile

but that code doesn't work , i done add in my css


but not work Sad

----------
before this my code (.secondarytitle, .secondarytitle h2) in my css, what needs to be removed??
but i done try remove, But just the same. not changed. Sad
i dont understand about this mr.mark Smile


Code:
.secondarytitle, .secondarytitle h2 {
    color: #EEEEEE;
    text-align: left;
    font-family: Spy Agency;
    text-shadow: 0 -1px 0 #666;
    font-size: 11px;
    padding-left: 5px;
    text-transform: uppercase;
    letter-spacing: 1px;
    padding-top: 5px;
    font-weight: normal;
}

please help me, to fix this problem.

my forum
http://astajim.indonesianforum.net/

thanks before mr.mark Very Happy

--------------------------------------
and i get this code from someone mr.mark, and i dont know how to use Sad i dont understand about this Sad


well those are just fonts you can download your computer, there is a difference between computer fonts and webfonts. You have to remember you can assign any font in the font library, and if you don't have it on your computer it will not show up unless you have it on your personal computer. So that is where the google fonts come into play.

There are many additions to the WebFontConfig as you can see below that code we have

google: { families [""]}

We can also do the following

Code:
        WebFontConfig = { typekit: {
            id: 'myKitId'
          }
        };

or

Code:
        WebFontConfig ={
          ascender: {
            key: 'myAscenderKey',
            families: [ 'AscenderSans:bold,bolditalic,italic,regular' ]
          }
        };

or
Code:
        WebFontConfig ={
          monotype: {
            projectId: 'YourProjectId'
          }
        };

or
Code:

        WebFontConfig = {
          fontdeck: {
            id: 'xxxxx'
          }
        };


These are all providers -

The following can be found at

typekit: www.typekit.com
ascender: http://www.fontslive.com/
monotype: http://webfonts.fonts.com/
fontdeck: http://fontdeck.com/

the above you will have to sign up, create a deck and provide the information in the WebFontConfig via id or key. Hope this helps you and you get this working


sasukekun
Forumember

Posts : 253
Reputation : 6
Language : English

Back to top Go down

Re: Error using font for title Forum, sub forum and topic title.

Post by E-Mark on May 13th 2013, 2:51 am

Put it at the very beginning of the CSS Smile:

E-Mark
Active Poster

Male Posts : 1389
Reputation : 164
Language : English, Tagalog
Location : Republic of the Philippines

http://coding-spot.darkbb.com/

Back to top Go down

Re: Error using font for title Forum, sub forum and topic title.

Post by sasukekun on May 13th 2013, 4:04 am

i done try mr.mark but doesn't work Smile

result


Maybe you want to try to enter my ACP, i provide my account to you mr,mark via PM, no problem mr.mark Very Happy

please help me mr.mark Sad

thanks before Smile


sasukekun
Forumember

Posts : 253
Reputation : 6
Language : English

Back to top Go down

Re: Error using font for title Forum, sub forum and topic title.

Post by E-Mark on May 13th 2013, 4:19 am

They've prevented linking their font, ok, use this one instead:
Code:
@font-face {
    font-family: SpyAgency;
    src: url('http://static.tumblr.com/hhedat8/Nmjmmpt27/spyagencycond.ttf');
}
.secondarytitle, .secondarytitle h2 {
font-family: SpyAgency !important;
}

E-Mark
Active Poster

Male Posts : 1389
Reputation : 164
Language : English, Tagalog
Location : Republic of the Philippines

http://coding-spot.darkbb.com/

Back to top Go down

Re: Error using font for title Forum, sub forum and topic title.

Post by sasukekun on May 13th 2013, 5:08 am

doesn't work mr.mark Smile


before i want to ask.
Whether in your computer/laptop, that font it out (spy agency)??

in my pc doesn't work Sad

Maybe you want to try to enter my ACP, i provide my account to you mr,mark via PM, you could see that something was wrong in my settings.

please help me mr.mark Sad

thanks before Smile

my forum:
http://astajim.indonesianforum.net/

sasukekun
Forumember

Posts : 253
Reputation : 6
Language : English

Back to top Go down

Re: Error using font for title Forum, sub forum and topic title.

Post by E-Mark on May 13th 2013, 6:17 am

They're working fine now with me? bye

E-Mark
Active Poster

Male Posts : 1389
Reputation : 164
Language : English, Tagalog
Location : Republic of the Philippines

http://coding-spot.darkbb.com/

Back to top Go down

Re: Error using font for title Forum, sub forum and topic title.

Post by sasukekun on May 13th 2013, 6:45 am

what should I do mr.mark?
to get out on my computer?

maybe use javascript or other?

or maybe can replaced or change by image, like this


please help me mr.mark, please Sad


sasukekun
Forumember

Posts : 253
Reputation : 6
Language : English

Back to top Go down

Re: Error using font for title Forum, sub forum and topic title.

Post by E-Mark on May 13th 2013, 7:07 am

Installed already via font-face, the font is already uploaded and inserted on your site. :o
I'll test it later, since i'm using mobile for now.

E-Mark
Active Poster

Male Posts : 1389
Reputation : 164
Language : English, Tagalog
Location : Republic of the Philippines

http://coding-spot.darkbb.com/

Back to top Go down

Re: Error using font for title Forum, sub forum and topic title.

Post by sasukekun on May 13th 2013, 7:21 am

ok mr.mark, thanks Smile

if it can be used in the form of images, no problem.
examples like this. if use font image (im edit in photoshop)



If you have any other ideas. may use another code,
I will try mr.mark..

please help me Sad

thanks before Very Happy

sasukekun
Forumember

Posts : 253
Reputation : 6
Language : English

Back to top Go down

Re: Error using font for title Forum, sub forum and topic title.

Post by Jophy on May 14th 2013, 7:34 am


Jophy
ForumGuru

Male Posts : 17924
Reputation : 835
Language : English
Location : Somewhere

Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum