The forum of the forums
Welcome to the Official Support Forum of Forumotion!

To take full advantage of everything offered by our forum, please log in if you are already a member, or join our community if you've not yet.



Create a free forum like this one.

(Only Topic!) New Editor

Page 32 of 34 Previous  1 ... 17 ... 31, 32, 33, 34  Next

View previous topic View next topic Go down

In progress (Only Topic!) New Editor

Post by TWYLYGHT on June 12th 2013, 3:34 pm

First topic message reminder :

Is there a way to opt of this new editor? If not is there a way to at least set the smiley's back to the old way. They are hard to see even with the mouse over feature. Any member we have with poor eye sight will not be able to use them. I ware glasses and it's hard for me to make head nor tails on the smileys.

Thanks in advance for a quick reply.


Edit:
A few solutions for the problems.


Smiley Problem:
http://help.forumotion.com/t124671p60-only-topic-new-editor#830677

For the editor not appearing Problem:
http://help.forumotion.com/t124758-lost-my-new-text-editor-on-my-forum-the-fix#831689

For turning off the WYSYIWYG by default:
http://help.forumotion.com/t124664-language-issue-in-new-editor#830420

For the Quote problem, cursor still remaining in the Quote box

http://help.forumotion.com/t124671p600-only-topic-new-editor#832889
http://help.forumotion.com/t124671p600-only-topic-new-editor#832892


For changing the font color in the reply box [Working for phpbb2]
http://help.forumotion.com/t124671p960-only-topic-new-editor#838113

For changing the background color in the reply box [Working for phpbb2]
http://help.forumotion.com/t124671p960-only-topic-new-editor#838102

Currently the editor has bugs related to posting via mobile operating systems. Will advise not to use them, until they are fixed. Regret the Inconvenience.

Regards,
Sanket

To add an image to the text editor, add this to your CSS:
Code:
 .sceditor-container iframe, .sceditor-container textarea {
          background-image:  url("IMAGE'S URL") !important;
          background-position:  center center !important;
          background-repeat:  no-repeat !important;
    }

TWYLYGHT
Forumember

Posts : 64
Reputation : 6
Language : ENGLISH

Back to top Go down


In progress Re: (Only Topic!) New Editor

Post by 19CenturyWBTS on July 2nd 2013, 7:08 pm

The following issues/problems still remain persistent and don't seem to have been fixed yet - I wonder if it is being looked into:

1) If one uses html tables the editor automatically adds "line breaks" where no real line breaks have been inserted. So for example if someone is styling one's html table code in order to make editing and using the template easier one gets the following results (the first part of the image shows that line breaks are added; the second one shows what one has to do to make it display as it should look, as you can see there are supposed to be NO line breaks between the table and the two arrow lines; the layout of the code part on the right isn't as user-friendly as the above example but currently needed to be used in this way to get rid of the unwanted line-breaks):



-> it would be great if the editor wouldn't magically add line breaks like that!


2) Also sadly enough the "code" doesn't show the standard non-breaking-space tag for some reason (it is still showing up right where it is supposed to be if you edit the same posting, but it just refuses to display the tag in the "code" part.



-> It would be great if you could make the BBCode "code" tag display non-breaking-space tags as well (I've tried and this for example seem to work without any problems on other non-forummotion forums).

Thanks!

19CenturyWBTS
Forumember

Posts : 81
Reputation : 4
Language : English

http://19thcenturywbts.forumotion.com/forum.htm

Back to top Go down

In progress Re: (Only Topic!) New Editor

Post by VampireWicked on July 3rd 2013, 4:50 am

My forum Still has no smile list, & narrow quick reply window with java off.
Any word on a solution for unmodified forums on when this unwanted mess will be fixed.
Please revert back to the previous editor to fix everyone's issues.

VampireWicked
Forumember

Posts : 29
Reputation : 2
Language : english

Back to top Go down

In progress Re: (Only Topic!) New Editor

Post by Sanket on July 3rd 2013, 11:24 am

@VampireWicked wrote:
My forum Still has no smile list, & narrow quick reply window with java off.
Any word on a solution for unmodified forums on when this unwanted mess will be fixed.
Please revert back to the previous editor to fix everyone's issues.
Revert back to the default template & check please. Also have you done the changes mentioned http://help.forumotion.com/t124616-new-editor-for-forumotion-forums#830008

Sanket
ForumGuru

Male Posts : 48766
Reputation : 2819
Language : English
Location : Mumbai

http://webartzforum.com

Back to top Go down

In progress Re: (Only Topic!) New Editor

Post by Guest on July 3rd 2013, 2:01 pm

battuvuong wrote:Is current editor as the official editor?
@The Godfather: I want to have Quickreply Template.
?

Guest
Guest


Back to top Go down

In progress Re: (Only Topic!) New Editor

Post by Phrixus on July 3rd 2013, 3:26 pm

@angel_of_night wrote:
ACP >> Display >> Pictures and Colors >> Colors >> CSS Stylesheet


Code:
div.sceditor-container,#textarea_content{width:100%!important}
form[name="post"] textarea,form[name="post"] iframe{width:calc(100% - 10px)!important;background:#333!important;}
form[name="post"] div[class|="sceditor"],div.sceditor-dropdown{background-color:#666;border-color:#777!important}
.sceditor-button.active,.sceditor-button.hover,.sceditor-button:active,.sceditor-button:hover{background:#666!important;box-shadow:0 0 0 transparent!important;border-color:#DDD!important}
div.sceditor-group,div.sceditor-dropdown{border:1px outset #777!important;background:#c2c2c2!important;box-shadow:0 0 1px #999!important}
div.sceditor-dropdown .button{border:1px outset #999!important;background:#555!important}
form[name="post"] textarea,div.sceditor-dropdown input,div.sceditor-dropdown textarea{background:#333!important;border:1px inset #999!important;color:#DDD!important}
div.sceditor-dropdown .button:hover{border-style:inset!important}
.sceditor-color-option:hover:after{width:20px;height:20px;display:block;background:inherit;content:" ";position:absolute;top:-24px;left:2px;border:1px solid #FFF}
.sceditor-emoticons > div{max-height:200px;overflow-y:scroll}
.sceditor-emoticons > div > img{left:auto!important;top:-38px!important;right:-8px;background:#c2c2c2;border:1px solid #777;padding:5px}



Optimize your CSS: No


ACP >> Modules >> HTML & JAVASCRIPT >> Javascript codes management >> Create a new javascript
Title * : Edit style SCEditor
Placement : In all the pages
Javascript Code * :
Code:
$(window).load(function () {
   $(".sceditor-container iframe").contents().find("head").append("<style>body,html,p,table{background:#333!important;color:#DDD!important}table,td{border-color:#999!important}blockquote{background:#666!important;margin-left:10px;border:0;padding-left:10px;border-left:3px solid}blockquote cite{background:url(http://i78.servimg.com/u/f78/17/70/81/78/quote10.png) no-repeat left center;padding-left:20px;margin-bottom:10px}code{background:#666;padding-left:10px;margin-left:10px}code:before{background:url(http://i83.servimg.com/u/f83/16/58/89/73/page_w10.png) no-repeat 10px center #666!important;height:20px;top:-22px;left:-1px;border:1px solid #999;padding:0 5px 0 30px}</style>")
});



Thank you for the code, it works. Only one bug: it makes my emotions box very narrow for some reason (I see only 2 smilies per row). How can it be modified?

Phrixus
New Member

Posts : 6
Reputation : 1
Language : croatian

Back to top Go down

In progress Re: (Only Topic!) New Editor

Post by Guest on July 3rd 2013, 6:02 pm

ACP >> Display >> Pictures and Colors >> Colors >> CSS Stylesheet

Code:
div.sceditor-container,#textarea_content{width:100%!important}
form[name="post"] textarea,form[name="post"] iframe{width:calc(100% - 10px)!important;background:#333!important;}
form[name="post"] div[class|="sceditor"],div.sceditor-dropdown{background-color:#666;border-color:#777!important}
.sceditor-button.active,.sceditor-button.hover,.sceditor-button:active,.sceditor-button:hover{background:#666!important;box-shadow:0 0 0 transparent!important;border-color:#DDD!important}
div.sceditor-group,div.sceditor-dropdown{border:1px outset #777!important;background:#c2c2c2!important;box-shadow:0 0 1px #999!important}
div.sceditor-dropdown .button{border:1px outset #999!important;background:#555!important}
form[name="post"] textarea,div.sceditor-dropdown input,div.sceditor-dropdown textarea{background:#333!important;border:1px inset #999!important;color:#DDD!important}
div.sceditor-dropdown .button:hover{border-style:inset!important}
#smiley-box {position: absolute}
.sceditor-color-option:hover:after{width:24px;height:24px;display:block;background:inherit;content:" ";position:absolute;top:-26px;left:0;border:1px solid #FFF}
Optimize your CSS: No

ACP >> Modules >> HTML & JAVASCRIPT >> Javascript codes management >> Create a new javascript
Title * : Edit style SCEditor
Placement : In all the pages
Javascript Code * :
Code:
$(window).load(function () {$("#text_editor_textarea").sceditor("instance").css("body,html,p,table{background:#333!important;color:#DDD!important}table,td{border-color:#999!important}blockquote{background:#666!important;margin-left:10px;border:0;padding-left:10px;border-left:3px solid}blockquote cite{background:url(http://i78.servimg.com/u/f78/17/70/81/78/quote10.png) no-repeat left center;padding-left:20px;margin-bottom:10px}blockquote cite:after {content: ' wrote:'}code{background:#666;padding-left:10px;margin-left:10px}code:before{background:url(http://i83.servimg.com/u/f83/16/58/89/73/page_w10.png) no-repeat 10px center #666!important;height:20px;top:-22px;left:-1px;border:1px solid #999;padding:0 5px 0 30px}")});


Guest
Guest


Back to top Go down

In progress Re: (Only Topic!) New Editor

Post by Guest on July 3rd 2013, 6:14 pm

New bug: press preview 2 times or switch editor mode.
Code:
[color=blue][size=18][center][b]XXX[/b][/center][/size][/color]

XXX


Guest
Guest


Back to top Go down

In progress Re: (Only Topic!) New Editor

Post by Phrixus on July 3rd 2013, 7:06 pm

It's still the same, I'm afraid. It looks like this:



Without the code, when I leave it white by default, emotions window looks ok. Confused

Phrixus
New Member

Posts : 6
Reputation : 1
Language : croatian

Back to top Go down

In progress Re: (Only Topic!) New Editor

Post by Guest on July 3rd 2013, 8:36 pm

Paste the following in your CSS:
Code:
#smiley-box{width:200px!important}

Guest
Guest


Back to top Go down

In progress Re: (Only Topic!) New Editor

Post by Kryn Cluskio on July 3rd 2013, 9:31 pm

Remove
Code:
#smiley-box {position: absolute}
and
Code:
div.sceditor-container,#textarea_content{width:100%!important}
from the css. That's what I did.

Kryn Cluskio
Forumember

Posts : 28
Reputation : 3
Language : English

Back to top Go down

In progress Re: (Only Topic!) New Editor

Post by Mr. Eddster on July 3rd 2013, 10:41 pm

i got a question...
whenever i seem to post smileys like SmileSmile:)then type right after them the smiley code shows up but not the smiley... before this wasnt a problem, but now whenever i type a smiley code, or click on a smiley, then continue typing afterwards, it just shows the code of the last smiley posted Sad



EDIT: See? Its right here in the post. the typing goes backwards for some reason, and then its just like that!!

Mr. Eddster
Forumember

Male Posts : 382
Reputation : 7
Language : English

http://sports-forumbuzz.canadian-forum.com/

Back to top Go down

In progress Re: (Only Topic!) New Editor

Post by SLGray on July 3rd 2013, 11:00 pm

Yours:
Code:
:):):)then
SmileSmile:)then

Mine:
Code:
:):):) then
SmileSmileSmile then

You did not add a space between the last smiley and the word then.


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 35667
Reputation : 2375
Language : English
Location : United States

http://fmthemes.forumotion.com/

Back to top Go down

In progress Re: (Only Topic!) New Editor

Post by Mr. Eddster on July 4th 2013, 3:30 am

@SLGray wrote:Yours:
Code:
:):):)then
SmileSmile:)then

Mine:
Code:
:):):) then
SmileSmileSmile then

You did not add a space between the last smiley and the word then.
Thats what im saying, lol. i never had to add that space before... before i could just select the smileys like this Very HappyVery HappyVery Happy then continue typing, without having to put that space. a lot of my users forget to do something simple like that b/c they are so used to the old way, then the code is all messed up and looks weird

is there a way to edit something in my templates to make it so it gives an extra space so users dont have to?

Mr. Eddster
Forumember

Male Posts : 382
Reputation : 7
Language : English

http://sports-forumbuzz.canadian-forum.com/

Back to top Go down

In progress Re: (Only Topic!) New Editor

Post by ob1 on July 4th 2013, 4:02 am

Can someone add a solution to "white text on white background" to the OP in this thread?
Link Removed

ob1
Forumember

Male Posts : 58
Reputation : 0
Language : english
Location : San Diego Ca

http://www.gravitypirates.dust.tv

Back to top Go down

In progress Re: (Only Topic!) New Editor

Post by SLGray on July 4th 2013, 5:35 am

@ob1 wrote:Can someone add a solution to "white text on white background" to the OP in this thread?
Link Removed
Why did you post a link to a forum?


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 35667
Reputation : 2375
Language : English
Location : United States

http://fmthemes.forumotion.com/

Back to top Go down

In progress Re: (Only Topic!) New Editor

Post by ob1 on July 4th 2013, 5:48 am

@SLGray wrote:
@ob1 wrote:Can someone add a solution to "white text on white background" to the OP in this thread?
Link Removed
Why did you post a link to a forum?

The moderators here have said many times to post a link to your site if you're having issues. Just following directions. That's my site with the white text on white background problem. Why was my link removed?

ob1
Forumember

Male Posts : 58
Reputation : 0
Language : english
Location : San Diego Ca

http://www.gravitypirates.dust.tv

Back to top Go down

In progress Re: (Only Topic!) New Editor

Post by Guest on July 4th 2013, 6:53 am

New bug: Bold BBcode doesn't support class attribute and style attribute.
Code:
[b class="aaa" style="color:red"][color=red]abc[/color][/b]
[b class="aaa" style="color:red"]abc[/b]

Guest
Guest


Back to top Go down

In progress Re: (Only Topic!) New Editor

Post by SLGray on July 4th 2013, 6:16 pm

@ob1 wrote:
@SLGray wrote:
@ob1 wrote:Can someone add a solution to "white text on white background" to the OP in this thread?
Link Removed
Why did you post a link to a forum?

The moderators here have said many times to post a link to your site if you're having issues. Just following directions. That's my site with the white text on white background problem. Why was my link removed?
Have you looked through this whole thread, there many messages about how to change the background of the text editor? You may re-post the link.


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 35667
Reputation : 2375
Language : English
Location : United States

http://fmthemes.forumotion.com/

Back to top Go down

In progress Re: (Only Topic!) New Editor

Post by ob1 on July 5th 2013, 12:04 am

@SLGray wrote:
@ob1 wrote:
@SLGray wrote:
@ob1 wrote:Can someone add a solution to "white text on white background" to the OP in this thread?
Link Removed
Why did you post a link to a forum?

The moderators here have said many times to post a link to your site if you're having issues. Just following directions. That's my site with the white text on white background problem. Why was my link removed?
Have you looked through this whole thread, there many messages about how to change the background of the text editor? You may re-post the link.
I have no desire to post up my site. Just trying to follow rules. I'm sure there is mention of the white text on white background somewhere in this 32 page thread. Since others have tried to start new threads about said problem, I'm suggesting adding the solution to the OP. That is where you seem to be collecting solutions to common editor problems like this. The size of this thread, with it's many different topics, is making it difficult to solve specific "new editor" problems. Hope you find the right swatter for all these bugs. Thanks for all the hard work mods!

ob1
Forumember

Male Posts : 58
Reputation : 0
Language : english
Location : San Diego Ca

http://www.gravitypirates.dust.tv

Back to top Go down

In progress Re: (Only Topic!) New Editor

Post by runawayhorses on July 5th 2013, 4:27 am

battuvuong wrote:New bug: Bold BBcode doesn't support class attribute and style attribute.
Code:
[b class="aaa" style="color:red"][color=red]abc[/color][/b]
[b class="aaa" style="color"]abc[/b]
You would write it like this:

Code:

[b][color=#ff0000]Bold Text with Color[/color][/b]

Result:
Bold Text with Color

runawayhorses
Hyperactive

Male Posts : 2537
Reputation : 162
Language : English
Location : United States

http://runawayhorses.alldiscussion.net/

Back to top Go down

In progress Re: (Only Topic!) New Editor

Post by Guest on July 5th 2013, 8:25 am

@runawayhorses wrote:
battuvuong wrote:New bug: Bold BBcode doesn't support class attribute and style attribute.
Code:
[b class="aaa" style="color:red"][color=red]abc[/color][/b]
[b class="aaa" style="color"]abc[/b]
You would write it like this:

Code:

[b][color=#ff0000]Bold Text with Color[/color][/b]

Result:
Bold Text with Color
I did not ask how to use bbcode, which is bug reports.

Guest
Guest


Back to top Go down

In progress Re: (Only Topic!) New Editor

Post by Racer9088 on July 5th 2013, 8:44 am

OK I like others dont understand why you got rid of a perfectly good thing lol but this is what I need help with. I couldnt find the answer so if you answered this already my bad.
When you hit reply the new editor box appears.
The background is white and the font as you type is white.
I hit the Switch Editor mode and the font color box and something worked. Now my text as I type is black (It appears white in the forum though as I want it).
Others in my mod team have the same issue.
I could only find in my admin panel how to change the font color in the forum. But that color is good. I only need to edit the font color in the edit box. How can I do this for all users?
My forum is http://www.fallofsaigonmod.com

Racer9088
New Member

Posts : 10
Reputation : 0
Language : english

Back to top Go down

In progress Re: (Only Topic!) New Editor

Post by Sanket on July 5th 2013, 10:36 am

By edit box you mean in quick reply or preview mode?

Sanket
ForumGuru

Male Posts : 48766
Reputation : 2819
Language : English
Location : Mumbai

http://webartzforum.com

Back to top Go down

In progress Re: (Only Topic!) New Editor

Post by VampireWicked on July 6th 2013, 5:29 am

@Sanket wrote:Revert back to the default template & check please. Also have you done the changes mentioned
The good news is that I was able to return the smiley box back to left side, and change the full (Post) reply text field to black. However, (this is the bad news) it is only visible by PS3 when Javascript is on.

So pretty much no effect with Java script turned off.
Before this update members using PS3 or mobile device could run our forum with Java script off & have access to a full smile list & normal size reply text field.
Is there a way to get that back ?

VampireWicked
Forumember

Posts : 29
Reputation : 2
Language : english

Back to top Go down

In progress Re: (Only Topic!) New Editor

Post by Sanket on July 6th 2013, 8:46 am

I can access my forum's smileys via Phone too. What is your forum URL? Do you have a test account?

Sanket
ForumGuru

Male Posts : 48766
Reputation : 2819
Language : English
Location : Mumbai

http://webartzforum.com

Back to top Go down

In progress Re: (Only Topic!) New Editor

Post by VampireWicked on July 7th 2013, 1:27 am

@Sanket wrote:I can access my forum's smileys via Phone too. What is your forum URL? Do you have a test account?
I didn't say i could access smile list by phone.

is...is there a way to access the smiley box and full size quick reply, with javascript off.
Full size quick reply...........NOT reply preview, NOT posted message, BUT the window where members write in messages.
It is very NARROW with an off Java script, again how do i return that to Full size quick reply window with Java script off.

VampireWicked
Forumember

Posts : 29
Reputation : 2
Language : english

Back to top Go down

In progress Re: (Only Topic!) New Editor

Post by Racer9088 on July 7th 2013, 6:23 am

Thanks Sanket.
Im not sure about Quick Reply but in Reply for sure.
OK we dont have a quick reply option just "reply" and "new topic"
So the new editor has the white background and white default text.
I dont care what gets changed the background or the font just need one changed.
Again I changed it for myself but cant change it for all accounts.
Again thanks I know the switch is a bit of a pain for you guys as we are lol. , I saw others talking about the same thing I think but read the entire first page and the last few pages and saw no answer. Figured it be in a sticky link in the top post with the others.

Racer9088
New Member

Posts : 10
Reputation : 0
Language : english

Back to top Go down

In progress Re: (Only Topic!) New Editor

Post by Leslie G2G on July 7th 2013, 8:08 am

When attempting to create a new topic, or reply to a post, I'm getting white text on a white back ground. Is there a way to fix this?

Leslie G2G
New Member

Posts : 8
Reputation : 1
Language : English

Back to top Go down

In progress Re: (Only Topic!) New Editor

Post by Martind Forlon on July 7th 2013, 8:33 am

Only wanted ask if there is "solution" for "spaces problem" when is used preview. If are used html tags, tables or some smileys it add or remove spaces and this do posts formatting little harder as should be (I hope its not normal function Smile ).

Martind Forlon
New Member

Posts : 9
Reputation : 1
Language : Czech, English

Back to top Go down

In progress Re: (Only Topic!) New Editor

Post by Leslie G2G on July 7th 2013, 7:06 pm

I'm Still having white on white posting issues, here's what it looks like;

What I typed
http://s1313.photobucket.com/user/G2GSP/media/ForumWhiteonWhite1_zps21f1c152.png.html


I had to highlight to see what was written
http://s1313.photobucket.com/user/G2GSP/media/ForumWhiteonWhite2_zps0e8f8e0b.png.html

Is there anyway to fix this? It's getting extremely frustrating. Sorry for the links, the "insert Image" feature wasn't working either.

Leslie G2G
New Member

Posts : 8
Reputation : 1
Language : English

Back to top Go down

Page 32 of 34 Previous  1 ... 17 ... 31, 32, 33, 34  Next

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum