The forum of the forums
Welcome to the Official Support Forum of Forumotion!

To take full advantage of everything offered by our forum, please log in if you are already a member, or join our community if you've not yet.



Create a free forum like this one.

PNG image in widget appearing with white background

View previous topic View next topic Go down

Solved PNG image in widget appearing with white background

Post by moi_lolito on June 14th 2013, 12:49 pm

Hi all guys!

I have this small question. I have a widget of an affiliated website in my academy (prorevolution.net) and on the main page it's showing with no problems, but if you go to some subforum or topic for some reason it appears with white background (the picture itself is transparent, png format, so it's strange). Here I post a screenshot of the problem.



Maybe there is something wrong with the code?

<div align="center"><a href="http://ygopro.it/web/" target="_blank"><img src="http://i43.tinypic.com/fwss1t.png" class="hover" alt="ygopo.it" title="YGOPRO LINUX" /></a><br /><br /><div id="FM_widget_partners"></div></div>

Thanks a lot in advance! Cheers^^


Last edited by moi_lolito on June 14th 2013, 4:45 pm; edited 1 time in total

moi_lolito
Forumember

Posts : 92
Reputation : 1
Language : English

Back to top Go down

Solved Re: PNG image in widget appearing with white background

Post by Sanket on June 14th 2013, 2:21 pm

Try uploading the image to tinypic.com

Sanket
ForumGuru

Male Posts : 48766
Reputation : 2819
Language : English
Location : Mumbai

http://webartzforum.com

Back to top Go down

Solved Re: PNG image in widget appearing with white background

Post by moi_lolito on June 14th 2013, 2:39 pm

that's the point, the image is already uploaded in tinypic =(

moi_lolito
Forumember

Posts : 92
Reputation : 1
Language : English

Back to top Go down

Solved Re: PNG image in widget appearing with white background

Post by angel_of_night on June 14th 2013, 3:00 pm

That's cause it's on .jpg, not .png
http://oi43.tinypic.com/fwss1t.jpg <- this is the link of the image.

angel_of_night
Forumember

Female Posts : 565
Reputation : 10
Language : portuguese

Back to top Go down

Solved Re: PNG image in widget appearing with white background

Post by Przmus on June 14th 2013, 3:16 pm

It looks normal for me...

Przmus
Forumember

Male Posts : 60
Reputation : 2
Language : English

http://easywinclan.forummotion.com/

Back to top Go down

Solved Re: PNG image in widget appearing with white background

Post by moi_lolito on June 14th 2013, 3:39 pm

aangel_of_night this is the link of the imagehttp://i43.tinypic.com/fwss1t.png you can even see it in the code I posted in the 1st message:


<div align="center"><a href="http://ygopro.it/web/" target="_blank"><img src="http://i43.tinypic.com/fwss1t.png" class="hover" alt="ygopo.it" title="YGOPRO LINUX" /></a><br /><br /><div id="FM_widget_partners"></div></div>


Przmus, in teh MAIN (FRONT) page it looks normal, yes, but if you go to visit some subforum, it looks with white background =/

moi_lolito
Forumember

Posts : 92
Reputation : 1
Language : English

Back to top Go down

Solved Re: PNG image in widget appearing with white background

Post by Przmus on June 14th 2013, 3:53 pm

Przmus, in teh MAIN (FRONT) page it looks normal, yes, but if you go to visit some subforum, it looks with white background =/
Well, it's same for me:


Anyway, try to put this link:
Code:
http://i.imgur.com/i1NZO7x.png
Instead of:
Code:
http://i43.tinypic.com/fwss1t.png
Maybe it helps.

Przmus
Forumember

Male Posts : 60
Reputation : 2
Language : English

http://easywinclan.forummotion.com/

Back to top Go down

Solved Re: PNG image in widget appearing with white background

Post by moi_lolito on June 14th 2013, 3:56 pm


moi_lolito
Forumember

Posts : 92
Reputation : 1
Language : English

Back to top Go down

Solved Re: PNG image in widget appearing with white background

Post by Przmus on June 14th 2013, 4:00 pm

Works fine:


Wait, I'll register and log in to your forum, to check if the problem appears only for logged-in users.
I'll edit my post.

EDIT:
Oh yeah! When I'm logged-in it doesn't display correctly:


Last edited by Przmus on June 14th 2013, 4:03 pm; edited 1 time in total

Przmus
Forumember

Male Posts : 60
Reputation : 2
Language : English

http://easywinclan.forummotion.com/

Back to top Go down

Solved Re: PNG image in widget appearing with white background

Post by moi_lolito on June 14th 2013, 4:02 pm

this is really strange, for me still with white background O.O

moi_lolito
Forumember

Posts : 92
Reputation : 1
Language : English

Back to top Go down

Solved Re: PNG image in widget appearing with white background

Post by Przmus on June 14th 2013, 4:10 pm

What if you add this to CSS?:
Code:
.sceditor-container textarea {
background: #131314 !important;
}
div.sceditor-toolbar {
background: #131314 !important;
border-bottom: none !important;
}
.sceditor-container iframe {
background: #131314 !important;
color: white !important
}
div.sceditor-container.ltr.wysiwygMode {
background: #131314 !important;
}
.sceditor-container {
  width: 100% !important;
  background: #131314 !important;
}

I'm 90% sure it's because of new quickreply colors.

EDIT:
If it changed, then:
Code:

<div align="center"><a href="http://ygopro.it/web/" target="_blank"><img src="http://i43.tinypic.com/fwss1t.png" class="hover" alt="ygopo.it" title="YGOPRO LINUX" /></a><br /><br /><div id="FM_widget_partners"></div></div>

Replace: 'class="hover"' with 'class="hover2"' or something like this.

Przmus
Forumember

Male Posts : 60
Reputation : 2
Language : English

http://easywinclan.forummotion.com/

Back to top Go down

Solved Re: PNG image in widget appearing with white background

Post by moi_lolito on June 14th 2013, 4:31 pm

nope, still the same lol =(

moi_lolito
Forumember

Posts : 92
Reputation : 1
Language : English

Back to top Go down

Solved Re: PNG image in widget appearing with white background

Post by Przmus on June 14th 2013, 4:39 pm

@moi_lolito wrote:nope, still the same lol =(
It must work when you replace: class="hover" with class="blablabla":

Przmus
Forumember

Male Posts : 60
Reputation : 2
Language : English

http://easywinclan.forummotion.com/

Back to top Go down

Solved Re: PNG image in widget appearing with white background

Post by moi_lolito on June 14th 2013, 4:43 pm

yep, right, it was because of the hover, thanks a lot ^^

moi_lolito
Forumember

Posts : 92
Reputation : 1
Language : English

Back to top Go down

Solved Re: PNG image in widget appearing with white background

Post by Sanket on June 14th 2013, 6:05 pm

Topic Solved & Archived

Sanket
ForumGuru

Male Posts : 48766
Reputation : 2819
Language : English
Location : Mumbai

http://webartzforum.com

Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum