The forum of the forums
Welcome to the Official Support Forum of Forumotion!

To take full advantage of everything offered by our forum, please log in if you are already a member, or join our community if you've not yet.



Create a free forum like this one.

"No Post Mode specified"

View previous topic View next topic Go down

In progress "No Post Mode specified"

Post by Khaoz on July 22nd 2013, 11:43 am

ever since the new editor came out after clicking on several [BB codes] from the editor nav bar the forum redirects and says "No Post Mode Specified".

Could someone please explain to me what is up with it and why is it reacting this way on my forums?



All i have to do to get this message is click "B" "Center" "FONT SIZE" and then it redirects. Sometimes even previewing it will result to this.

usually happens after a first preview check and then a second

 noticed the url also changes: /post?f=20&mode=newtopic# to /post#

 so something with the script of the new editor is not working right?

Khaoz
Forumember

Posts : 48
Reputation : 4
Language : English

Back to top Go down

In progress Re: "No Post Mode specified"

Post by Derri on July 22nd 2013, 12:13 pm

Did you update your templates with the code that was given for the update?


Forum Rules: :Forumotion Staff: :Appeal A Warning: :FAQ: :Tips & Tricks: :Forgotten Password/Login Issues
You need one post to send a PM
When your topic has been solved, ensure you mark the topic solved
Never post your email in public


Derri
Administrator
Administrator

Male Posts : 8355
Reputation : 571
Language : English & Basic French
Location : Scotland, United Kingdom

Back to top Go down

In progress Re: "No Post Mode specified"

Post by Khaoz on July 22nd 2013, 12:22 pm

which code or where is it located?

Khaoz
Forumember

Posts : 48
Reputation : 4
Language : English

Back to top Go down

In progress Re: "No Post Mode specified"

Post by Derri on July 22nd 2013, 12:25 pm



Forum Rules: :Forumotion Staff: :Appeal A Warning: :FAQ: :Tips & Tricks: :Forgotten Password/Login Issues
You need one post to send a PM
When your topic has been solved, ensure you mark the topic solved
Never post your email in public


Derri
Administrator
Administrator

Male Posts : 8355
Reputation : 571
Language : English & Basic French
Location : Scotland, United Kingdom

Back to top Go down

In progress Re: "No Post Mode specified"

Post by Khaoz on July 22nd 2013, 12:26 pm

I checked but when i check my templates I don't have those edited at all and still having the issue as described.

Khaoz
Forumember

Posts : 48
Reputation : 4
Language : English

Back to top Go down

In progress Re: "No Post Mode specified"

Post by Derri on July 22nd 2013, 12:31 pm

But you need to add those codes in to make sure the new editor works properly.

Derri
Administrator
Administrator

Male Posts : 8355
Reputation : 571
Language : English & Basic French
Location : Scotland, United Kingdom

Back to top Go down

In progress Re: "No Post Mode specified"

Post by Khaoz on July 22nd 2013, 12:47 pm

shouldn't they be in automatically regardless if the template was unedited? that should be forumotions part. :o I'll check to see if it isnt updated.

Khaoz
Forumember

Posts : 48
Reputation : 4
Language : English

Back to top Go down

In progress Re: "No Post Mode specified"

Post by Derri on July 22nd 2013, 12:50 pm

Well you should at least check to see if they need updated.


Forum Rules: :Forumotion Staff: :Appeal A Warning: :FAQ: :Tips & Tricks: :Forgotten Password/Login Issues
You need one post to send a PM
When your topic has been solved, ensure you mark the topic solved
Never post your email in public


Derri
Administrator
Administrator

Male Posts : 8355
Reputation : 571
Language : English & Basic French
Location : Scotland, United Kingdom

Back to top Go down

In progress Re: "No Post Mode specified"

Post by Khaoz on July 22nd 2013, 2:28 pm

I have checked. the templates and everything seems to be fine as i never edited them in the first place. Went back to reply to a thread hit [B] [Center][Color picker] and as soon as i hit the sizer it directed me off the page into the post mode notice

Khaoz
Forumember

Posts : 48
Reputation : 4
Language : English

Back to top Go down

In progress Re: "No Post Mode specified"

Post by Derri on July 22nd 2013, 2:33 pm

So the codes in the templates match the replacement codes in the editor?


Forum Rules: :Forumotion Staff: :Appeal A Warning: :FAQ: :Tips & Tricks: :Forgotten Password/Login Issues
You need one post to send a PM
When your topic has been solved, ensure you mark the topic solved
Never post your email in public


Derri
Administrator
Administrator

Male Posts : 8355
Reputation : 571
Language : English & Basic French
Location : Scotland, United Kingdom

Back to top Go down

In progress Re: "No Post Mode specified"

Post by Khaoz on July 22nd 2013, 2:36 pm

yes they both match. i done research on what happens in other phpbb forums:
When your posting a message if you look at the URL above you will see something like this.


?mode=reply&t=2441 after the posting.php script. This tells the script what to do with the information it recives. Hence the mode of reply and the topic of 2441 so its saying that this message is a reply to the topic numbered 2441.

If these variables dont get passed to the script then you will encounter the "no post mode specified" error.

Edit: and i have also noticed that clicking the same link multiple times now does not redirect to the same url it just becomes inactive like placing a # in replacement of the url. its possible that in some way its doing the same thing here with the sumbit/preview buttons.

Khaoz
Forumember

Posts : 48
Reputation : 4
Language : English

Back to top Go down

In progress Re: "No Post Mode specified"

Post by Khaoz on July 23rd 2013, 4:44 pm

bump :s still no help .-.

Khaoz
Forumember

Posts : 48
Reputation : 4
Language : English

Back to top Go down

In progress Re: "No Post Mode specified"

Post by kirk on July 24th 2013, 3:47 pm

what is the sizer> font size?
and are you adding a post tittle?

Other then that post the link to your forum and open a forum that guest can post in so we can try.

kirk
Forumaster

Male Posts : 11037
Reputation : 651
Language : English,Vulcan,Klingon, Romulan,& Gorn

Back to top Go down

In progress Re: "No Post Mode specified"

Post by Khaoz on July 24th 2013, 8:00 pm

yes font size my bad :o
all forums should be guest viewable but i will enable free chat to guest reply:
http://www.dragonicera.com/f21-forum

Khaoz
Forumember

Posts : 48
Reputation : 4
Language : English

Back to top Go down

In progress Re: "No Post Mode specified"

Post by SLGray on July 24th 2013, 8:14 pm

I just tried it. It only occurred after I pressed the preview button. Do you have any JavaScripts? Turn off JavaScripts Management and see if it fixes the issue.


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 35667
Reputation : 2375
Language : English
Location : United States

http://fmthemes.forumotion.com/

Back to top Go down

In progress Re: "No Post Mode specified"

Post by Khaoz on July 24th 2013, 8:20 pm

I have now turned off the .js and now i dont see it messing up but the downside is some of these javascripts i do need and im not positive on which one is conflicting.

Khaoz
Forumember

Posts : 48
Reputation : 4
Language : English

Back to top Go down

In progress Re: "No Post Mode specified"

Post by SLGray on July 24th 2013, 8:21 pm

Try this:

Open a text program and copy & paste all your JavaScripts there.
Then remove all JavaScripts and add them one by one.


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 35667
Reputation : 2375
Language : English
Location : United States

http://fmthemes.forumotion.com/

Back to top Go down

In progress Re: "No Post Mode specified"

Post by Khaoz on July 24th 2013, 8:27 pm

okay i been sitting here deleteing js and having the js management off still not thinking about it and still now coming across the post error

Khaoz
Forumember

Posts : 48
Reputation : 4
Language : English

Back to top Go down

In progress Re: "No Post Mode specified"

Post by kirk on July 24th 2013, 10:24 pm

or try restoring your forum back to a time and date before this started happening?
Sounds to me like it has to be one of them scripts your using?

kirk
Forumaster

Male Posts : 11037
Reputation : 651
Language : English,Vulcan,Klingon, Romulan,& Gorn

Back to top Go down

In progress Re: "No Post Mode specified"

Post by Khaoz on July 25th 2013, 12:50 am

Issue may have been found:
Code:
<!-- SCM Music Player http://scmplayer.net -->
<script type="text/javascript" src="http://scmplayer.net/script.js"
data-config="{'skin':'skins/black/skin.css','volume':100,'autoplay':false,'shuffle':false,'repeat':false,'placement':'top','showplaylist':false,'playlist':[{'title':' LiveSoul Gaming | Call of Duty: Ghosts Advertisement','url':'http://www.youtube.com/watch?v=Zxnx3W-HA18'},{'title':' LiveSoul Gaming | Imagine Dragons - Radioactive ','url':'http://www.youtube.com/watch?v=ktvTqknDobU'},{'title':' LiveSoul Gaming | Linkin Park - CASTLE OF GLASS','url':'http://www.youtube.com/watch?v=ScNNfyq3d_w'},{'title':' LiveSoul Gaming | Linkin Park - BURN IT DOWN','url':'http://www.youtube.com/watch?v=dxytyRy-O1k'},{'title':' LiveSoul Gaming | GTA V Advertisement','url':'http://www.youtube.com/watch?v=QkkoHAzjnUs'},{'title':' LiveSoul Gaming | Steven Stern - Soul of a Man','url':'http://www.youtube.com/watch?v=VOeju9eMnuc'},{'title':' LiveSoul Gaming | Mad Max Advertisement','url':'http://www.youtube.com/user/madmaxgame?v=lN28TV7mA50'},{'title':' LiveSoul Gaming | TCS - Zombies Parody','url':'http://youtu.be/TCvf_SUD5WU?t=5s'}]}" ></script>
<!-- SCM Music Player script end -->

I removed the music player from the website and its not showing up the post error anymore so now the "seemless music player" tutorial will conflict with forums...? ugh thats just wonderful >.>

This is one of my favorite additions to the site that i really enjoyed. don't want to give it up but at the same time don't like the fact that the new editor conflicts with it. Its one of the select few players that doesnt obnoxiously take up alot of space and easy to cope/code with. It would be great if some testing could go around so that the preview button will not conflict. .-. is there any other way? mixpod tut does not work as the website is shutdown. playlist got switched to a radio station website that takes hours to load. it all comes down to license with those sites :/.

Khaoz
Forumember

Posts : 48
Reputation : 4
Language : English

Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum