The forum of the forums
Welcome to the Official Support Forum of Forumotion!

To take full advantage of everything offered by our forum, please log in if you are already a member, or join our community if you've not yet.



Create a free forum like this one.

Tutorial Messed Up The Layout

View previous topic View next topic Go down

Solved Tutorial Messed Up The Layout

Post by Faeryl Womyn on November 12th 2013, 7:38 pm

I was using one of the tutorials for adding a user control panel, which it turned out I didn't even need, but that is besides the point. I removed the code and took out the modules that suddenly appeared on my site, thinking this would return it all back to the original look, but that didn't happen.

This is the tutorial I used...
http://help.forumotion.com/t42100-control-panel-for-users

I don't know enough about CSS to figure where I need to alter the code and return the site back to normal. If you look at the the categories and posts and such, width is not correct.

http://faerylwomynscottage.canadian-forum.com/

If you check this post, you will see exactly what I mean about width. With each section I check, things are not suppose to be as wide as they are.
http://faerylwomynscottage.canadian-forum.com/t44-tutorial-mess-up#60

Faeryl Womyn
New Member

Posts : 14
Reputation : 1
Language : English

Back to top Go down

Solved Re: Tutorial Messed Up The Layout

Post by Ange Tuteur on November 12th 2013, 8:01 pm

Hello Faeryl Womyn,

I am not sure how your forum looked before, but this is the code you should edit to modify your forums width(it may already be in your CSS):
Administration Panel > Display > Pictures and colors > Colors > CSS stylesheet
Code:
#ipbwrapper{
margin: 0px auto;
min-width: 951px;
padding: 5px;
text-align: left;
width: 886px;
}
The two properties you should edit are:
Code:
min-width: 951px;
width: 886px;
You can also edit your forum width under:
Administration Panel > General > Forum > Configuration

Find 'Forum width (number or %)' and modify the percentage or pixels.

Ange Tuteur
Forumaster

Male Posts : 13021
Reputation : 2683
Language : EN10, FR5
Location : Pennsylvania

http://fmdesign.forumotion.com

Back to top Go down

Solved Re: Tutorial Messed Up The Layout

Post by Faeryl Womyn on November 12th 2013, 8:15 pm

Were you able to look at that last link, cause it shows you what went wrong? I posted the link before realizing you need to be a member in that section. This next one is in an open area, you don't need to be a member to access it.

http://faerylwomynscottage.canadian-forum.com/t45-site-theme-mess-up#61

Faeryl Womyn
New Member

Posts : 14
Reputation : 1
Language : English

Back to top Go down

Solved Re: Tutorial Messed Up The Layout

Post by Ange Tuteur on November 12th 2013, 8:18 pm

I still can't view that topic.

Ange Tuteur
Forumaster

Male Posts : 13021
Reputation : 2683
Language : EN10, FR5
Location : Pennsylvania

http://fmdesign.forumotion.com

Back to top Go down

Solved Re: Tutorial Messed Up The Layout

Post by Faeryl Womyn on November 12th 2013, 8:22 pm

Ok permissions have been changed, sorry about that.

Faeryl Womyn
New Member

Posts : 14
Reputation : 1
Language : English

Back to top Go down

Solved Re: Tutorial Messed Up The Layout

Post by Faeryl Womyn on November 12th 2013, 8:32 pm

Have to head out for appointments, will check on things when I get back.

Faeryl Womyn
New Member

Posts : 14
Reputation : 1
Language : English

Back to top Go down

Solved Re: Tutorial Messed Up The Layout

Post by Ange Tuteur on November 12th 2013, 9:35 pm

Please don't double/triple post. Your post need to be separated by 24 hours before bumping, replying or adding more information. Please use the edit button instead!

Could you upload and post the images to here? I cannot download attachments on your forum to see the issue.

Ange Tuteur
Forumaster

Male Posts : 13021
Reputation : 2683
Language : EN10, FR5
Location : Pennsylvania

http://fmdesign.forumotion.com

Back to top Go down

Solved Re: Tutorial Messed Up The Layout

Post by Faeryl Womyn on November 13th 2013, 12:18 am

I hope this works, posting images here is so different from other places I visit...lol


Faeryl Womyn
New Member

Posts : 14
Reputation : 1
Language : English

Back to top Go down

Solved Re: Tutorial Messed Up The Layout

Post by Ange Tuteur on November 13th 2013, 12:27 am

Those spaces are there because the table foot image doesn't repeat. You can fill in the space by applying a repeat. I'm assuming when you had the widgets they took up about 180px which clipped most of the image leaving no gaps as the ones you see now.

Try this in your CSS:
Code:
table.ipbtable tfoot td{
background-repeat:repeat !important;
}

Ange Tuteur
Forumaster

Male Posts : 13021
Reputation : 2683
Language : EN10, FR5
Location : Pennsylvania

http://fmdesign.forumotion.com

Back to top Go down

Solved Re: Tutorial Messed Up The Layout

Post by Faeryl Womyn on November 17th 2013, 8:06 am

Ok I found the line that has something similar in it but have no idea where to put this. Below is what the two lines look like. Where in those two lines do I add that piece of code you posted?

15 table.ipbtable tfoot td{background-color:transparent;background-image:url('http://i30.servimg.com/u/f30/13/30/32/72/b1_bas10.png');background-repeat:no-repeat;background-position:bottom center;padding:0px;height:34px!important;border:none;}
16.topic-footer{background-color:transparent;background-image:url('http://i30.servimg.com/u/f30/13/30/32/72/b1_bas10.png');background-repeat:no-repeat;background-position:bottom center;padding:0px;height:34px!important;border:none none !important;}

Faeryl Womyn
New Member

Posts : 14
Reputation : 1
Language : English

Back to top Go down

Solved Re: Tutorial Messed Up The Layout

Post by Ange Tuteur on November 17th 2013, 2:36 pm

In the code where it says:
Code:
background-repeat:no-repeat;
Replace with:
Code:
background-repeat:repeat;
You can replace the old CSS code you provided with this if you wish:
Code:
table.ipbtable tfoot td{
background-color:transparent;
background-image:url('http://i30.servimg.com/u/f30/13/30/32/72/b1_bas10.png');
background-repeat:repeat;
background-position:bottom center;
padding:0px;
height:34px!important;
border:none;
}
.topic-footer{
background-color:transparent;
background-image:url('http://i30.servimg.com/u/f30/13/30/32/72/b1_bas10.png');
background-repeat:repeat;
background-position:bottom center;
padding:0px;
height:34px!important;
border:none none !important;
}

Ange Tuteur
Forumaster

Male Posts : 13021
Reputation : 2683
Language : EN10, FR5
Location : Pennsylvania

http://fmdesign.forumotion.com

Back to top Go down

Solved Re: Tutorial Messed Up The Layout

Post by Faeryl Womyn on November 17th 2013, 11:25 pm

That did the opposite of what I wanted...lol

If you see in the image, the right length of the bottom of the section is what is suppose to be how the rest looks.
Looks like the repeat should be no repeat somewhere on the code. That must be what was changed when I tried to add the profile thingy. At least that is what seems to be the problem.

NOTE: Problem solved. I turned off widgets and the forum returned to normal. I do thank you for your help though.

Faeryl Womyn
New Member

Posts : 14
Reputation : 1
Language : English

Back to top Go down

Solved Re: Tutorial Messed Up The Layout

Post by Ange Tuteur on November 17th 2013, 11:52 pm

No problem, thanks for posting the solution.

Topic Solved and Archived

Ange Tuteur
Forumaster

Male Posts : 13021
Reputation : 2683
Language : EN10, FR5
Location : Pennsylvania

http://fmdesign.forumotion.com

Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum