The forum of the forums
Welcome to the Official Support Forum of Forumotion!

To take full advantage of everything offered by our forum, please log in if you are already a member, or join our community if you've not yet.



Create a free forum like this one.

Troubles with Embedding YT Videos - allowscriptaccess="always"

Page 1 of 2 1, 2  Next

View previous topic View next topic Go down

In progress Troubles with Embedding YT Videos - allowscriptaccess="always"

Post by Hardcore Gamer on November 29th 2013, 5:52 pm

When a member embeds a YouTube video on my forum, it works, but below the video or somewhere random in the post it says this: allowscriptaccess="always" allowfullscreen="true

Why is this? Can anybody help me so it doesn't do this no more?

Hardcore Gamer
Forumember

Male Posts : 409
Reputation : 3
Language : English

Back to top Go down

In progress Re: Troubles with Embedding YT Videos - allowscriptaccess="always"

Post by Sir Chivas™ on November 29th 2013, 5:55 pm

Hi,

Can you please post the following things?

1. Your forum URL and a URL of a thread where this is shown.
2. The following code or software used to embed the video.

Thank you,
Sir Chivas.

Sir Chivas™
Support Moderator
Support Moderator

Male Posts : 6783
Reputation : 430
Language : EN, FR, ES
Location : || CSS || HTML || Graphics Designs || Support ||

Back to top Go down

In progress Re: Troubles with Embedding YT Videos - allowscriptaccess="always"

Post by Hardcore Gamer on November 29th 2013, 6:01 pm

PM sent with my forum link.

2. The following code or software used to embed the video. --- What do you mean by that? It's just the YouTube embed option...

Hardcore Gamer
Forumember

Male Posts : 409
Reputation : 3
Language : English

Back to top Go down

In progress Re: Troubles with Embedding YT Videos - allowscriptaccess="always"

Post by Sir Chivas™ on November 29th 2013, 6:08 pm

Got it.

This is what is shown below the video:




Why don't you use: the youtube button?


Last edited by Sir Chivas™ on November 29th 2013, 6:16 pm; edited 1 time in total

Sir Chivas™
Support Moderator
Support Moderator

Male Posts : 6783
Reputation : 430
Language : EN, FR, ES
Location : || CSS || HTML || Graphics Designs || Support ||

Back to top Go down

In progress Re: Troubles with Embedding YT Videos - allowscriptaccess="always"

Post by Hardcore Gamer on November 29th 2013, 6:11 pm

Yeah, that's it. The members are using the YT button though... I even tried it out multiple times.

Hardcore Gamer
Forumember

Male Posts : 409
Reputation : 3
Language : English

Back to top Go down

In progress Re: Troubles with Embedding YT Videos - allowscriptaccess="always"

Post by Sir Chivas™ on November 29th 2013, 7:32 pm

Have you tried the following:

HTML:
Code:
<iframe width="560" height="315" src="http://www.youtube.com/embed/sMt9zLNDkTw" frameborder="0" allowfullscreen></iframe>

BBCode:
Code:
[flash(width,height)]YOUTUBE URL[/flash]
or

Code:
[youtube]Youtube Video URL Here[/youtube]

Sir Chivas™
Support Moderator
Support Moderator

Male Posts : 6783
Reputation : 430
Language : EN, FR, ES
Location : || CSS || HTML || Graphics Designs || Support ||

Back to top Go down

In progress Re: Troubles with Embedding YT Videos - allowscriptaccess="always"

Post by Hardcore Gamer on November 29th 2013, 7:39 pm

[youtube]Youtube Video URL Here[/youtube]

Is what the members use.

Hardcore Gamer
Forumember

Male Posts : 409
Reputation : 3
Language : English

Back to top Go down

In progress Re: Troubles with Embedding YT Videos - allowscriptaccess="always"

Post by Sir Chivas™ on November 29th 2013, 7:39 pm

Can you provide a test account? Thank you. I want to test something out.

Sir Chivas™
Support Moderator
Support Moderator

Male Posts : 6783
Reputation : 430
Language : EN, FR, ES
Location : || CSS || HTML || Graphics Designs || Support ||

Back to top Go down

In progress Re: Troubles with Embedding YT Videos - allowscriptaccess="always"

Post by Hardcore Gamer on November 29th 2013, 7:47 pm

Will send you a PM with details for that.

Hardcore Gamer
Forumember

Male Posts : 409
Reputation : 3
Language : English

Back to top Go down

In progress Re: Troubles with Embedding YT Videos - allowscriptaccess="always"

Post by runawayhorses on November 29th 2013, 10:39 pm

If you'd like to post the url to that particular video I'll see what it does on my forum and get back to you.

runawayhorses
Hyperactive

Male Posts : 2537
Reputation : 162
Language : English
Location : United States

http://runawayhorses.alldiscussion.net/

Back to top Go down

In progress Re: Troubles with Embedding YT Videos - allowscriptaccess="always"

Post by Hardcore Gamer on November 29th 2013, 10:54 pm

Sent the video through a PM. Let me know how it goes in this thread! Appreciate it.

By the way, the member that posted the video had a few lines of text... dunno if that changes things or not but you might want to have that in your post when using that video link. The allowscriptaccess="always" thing was just randomly cutting into a sentence of this members post too. Weird.

Hardcore Gamer
Forumember

Male Posts : 409
Reputation : 3
Language : English

Back to top Go down

In progress Re: Troubles with Embedding YT Videos - allowscriptaccess="always"

Post by runawayhorses on November 29th 2013, 11:12 pm

Ok, I received your PM with the address to the video here: http://www.youtube.com/watch?v=LSxtNd_ja6I

Now, I added the video URL to the YouTube video button on the text editor on my forum and it produced this code below. If you didn't know after you submit the code that has youtube brackets it is automatically converted into this flash code, which you can see if you edit the post.


Code:
[flash(425,350)]http://www.youtube.com/v/LSxtNd_ja6I[/flash]
When I used the YouTube video button there was no writing under the video, only the video was displaying.

I then used the YouTube video's embed code and no writing was under that as well, just the video was showing.

Code:
<iframe width="420" height="315" src="//www.youtube.com/embed/LSxtNd_ja6I" frameborder="0" allowfullscreen></iframe>
So on my forum is working correctly with no text just the video, why you are seeing text under the video on yours is a mystery to me. Good luck, hope this helped somewhat evaluate your problem.

runawayhorses
Hyperactive

Male Posts : 2537
Reputation : 162
Language : English
Location : United States

http://runawayhorses.alldiscussion.net/

Back to top Go down

In progress Re: Troubles with Embedding YT Videos - allowscriptaccess="always"

Post by SLGray on November 29th 2013, 11:22 pm

Could you post here how the video is post on your forum? I mean edit the post and copy & paste it here.


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 36748
Reputation : 2449
Language : English
Location : United States

http://ztwds.forumotion.com/

Back to top Go down

In progress Re: Troubles with Embedding YT Videos - allowscriptaccess="always"

Post by Hardcore Gamer on November 29th 2013, 11:26 pm

@SLGray wrote:Could you post here how the video is post on your forum? I mean edit the post and copy & paste it here.
Code:
[flash(425,350)]http://www.youtube.com/v/LSxtNd_ja6I[/flash]
EDIT: The error allowscriptaccess="always" allowfullscreen="true" ONLY shows up when you preview a post or actually submit the post to a thread. You simply cannot edit that error out of the post as it doesn't appear in it.

Hardcore Gamer
Forumember

Male Posts : 409
Reputation : 3
Language : English

Back to top Go down

In progress Re: Troubles with Embedding YT Videos - allowscriptaccess="always"

Post by SLGray on November 29th 2013, 11:32 pm

Try this:

Turn off JavaScript Management and forum widgets.


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 36748
Reputation : 2449
Language : English
Location : United States

http://ztwds.forumotion.com/

Back to top Go down

In progress Re: Troubles with Embedding YT Videos - allowscriptaccess="always"

Post by Hardcore Gamer on November 29th 2013, 11:37 pm

Turned off both, and nothing. Refreshed multiple times, edited the members post, ect. That thing still shows up. It only shows up when people embed YouTube videos.

Hardcore Gamer
Forumember

Male Posts : 409
Reputation : 3
Language : English

Back to top Go down

In progress Re: Troubles with Embedding YT Videos - allowscriptaccess="always"

Post by SLGray on November 29th 2013, 11:45 pm

Do you have HTML on for the whole forum and in your profile?


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 36748
Reputation : 2449
Language : English
Location : United States

http://ztwds.forumotion.com/

Back to top Go down

In progress Re: Troubles with Embedding YT Videos - allowscriptaccess="always"

Post by Hardcore Gamer on November 29th 2013, 11:47 pm

How would I check that for the whole forum?

Hardcore Gamer
Forumember

Male Posts : 409
Reputation : 3
Language : English

Back to top Go down

In progress Re: Troubles with Embedding YT Videos - allowscriptaccess="always"

Post by runawayhorses on November 29th 2013, 11:52 pm

It shouldn't matter if they are using the text editor YouTube button and pasting the URL into it (not the embed code). Only the embed code requires HTML be enabled for the whole forum, but checking might help eliminate some possibilities. Go to AP>>General>>Messages & emails>>Configuration.

On that page check and see if you have HTML enabled.

Also, ask your members if they are pasting the embed code into the text editors youtube button or the video page url? The video page URL is what is supposed to go into the text editor, not the embed code.

runawayhorses
Hyperactive

Male Posts : 2537
Reputation : 162
Language : English
Location : United States

http://runawayhorses.alldiscussion.net/

Back to top Go down

In progress Re: Troubles with Embedding YT Videos - allowscriptaccess="always"

Post by Hardcore Gamer on November 29th 2013, 11:54 pm

Yeah, it's enabled.

I've checked multiple posts where members have embedded videos - that error thing is in them all.

Hardcore Gamer
Forumember

Male Posts : 409
Reputation : 3
Language : English

Back to top Go down

In progress Re: Troubles with Embedding YT Videos - allowscriptaccess="always"

Post by runawayhorses on November 29th 2013, 11:55 pm

I added more to my post above you may have missed:

"Also, ask your members if they are pasting the embed code into the text editors youtube button or the video page url? The video page URL is what is supposed to go into the text editor, not the embed code."

runawayhorses
Hyperactive

Male Posts : 2537
Reputation : 162
Language : English
Location : United States

http://runawayhorses.alldiscussion.net/

Back to top Go down

In progress Re: Troubles with Embedding YT Videos - allowscriptaccess="always"

Post by Hardcore Gamer on November 30th 2013, 12:05 am

^They're all using the YouTube button.

WAIT, I just found something. The error ONLY pops up when someone puts something into quotes like "This music video is nice" THEN the error code goes as follow - allowscriptaccess="always" allowfullscreen="true" right after it.

Hardcore Gamer
Forumember

Male Posts : 409
Reputation : 3
Language : English

Back to top Go down

In progress Re: Troubles with Embedding YT Videos - allowscriptaccess="always"

Post by runawayhorses on November 30th 2013, 12:10 am

Yes they may be using the YouTube button to paste the embed code into, my question is are they pasting the video page URL only? When you paste the video page URL only the text editor will add the code needed to display correctly. My point being, if they are pasting the embed code into the text editor youtube button it could cause hidden problems resulting in what you are experiencing.

Quotes written outside the codes like how you mentioned should under normal circumstances not be a problem.

runawayhorses
Hyperactive

Male Posts : 2537
Reputation : 162
Language : English
Location : United States

http://runawayhorses.alldiscussion.net/

Back to top Go down

In progress Re: Troubles with Embedding YT Videos - allowscriptaccess="always"

Post by Hardcore Gamer on November 30th 2013, 12:20 am

I don't think I fully understand what you mean, sorry about that. Confused

No matter what way you do it, it all works out fine and there is no error except for when a member types a quote like "akgfhaefb test test" into their post when they have embedded a video in that post also. That's when the error only shows up.

Hardcore Gamer
Forumember

Male Posts : 409
Reputation : 3
Language : English

Back to top Go down

In progress Re: Troubles with Embedding YT Videos - allowscriptaccess="always"

Post by runawayhorses on November 30th 2013, 12:26 am

If some members are pasting the embed code into the text editors youtube button, when they use quote codes in could indeed cause the errors, because the editor had to strip down the embed code that was pasted into the youtube button and it left behind "allowscriptaccess="always" allowfullscreen="true" which is is still vulnerable to perhaps quotation marks.

However, if you're certain they are not doing that then I really am at a loss as to why you get the errors when quotes are written after the code. After the code is in place you should be able to write anything underneath because the video code has been closed.

runawayhorses
Hyperactive

Male Posts : 2537
Reputation : 162
Language : English
Location : United States

http://runawayhorses.alldiscussion.net/

Back to top Go down

In progress Re: Troubles with Embedding YT Videos - allowscriptaccess="always"

Post by Hardcore Gamer on November 30th 2013, 12:30 am

Ahh, okay yeah. I get you now. They aren't doing that.

Yeah, I just don't get it either. I cannot understand what could be wrong.

Hardcore Gamer
Forumember

Male Posts : 409
Reputation : 3
Language : English

Back to top Go down

In progress Re: Troubles with Embedding YT Videos - allowscriptaccess="always"

Post by SLGray on November 30th 2013, 7:50 am

Could I have a test account?


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 36748
Reputation : 2449
Language : English
Location : United States

http://ztwds.forumotion.com/

Back to top Go down

In progress Re: Troubles with Embedding YT Videos - allowscriptaccess="always"

Post by Hardcore Gamer on November 30th 2013, 8:29 am

Thanks. PM sent with details.

Hardcore Gamer
Forumember

Male Posts : 409
Reputation : 3
Language : English

Back to top Go down

In progress Re: Troubles with Embedding YT Videos - allowscriptaccess="always"

Post by SLGray on December 1st 2013, 12:38 am

I tested it after using the test account and did not have any issue posting a Youtube video using the button or the embeded code.

Are you posting the videos or a member?


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 36748
Reputation : 2449
Language : English
Location : United States

http://ztwds.forumotion.com/

Back to top Go down

In progress Re: Troubles with Embedding YT Videos - allowscriptaccess="always"

Post by Ultron's Vision on December 1st 2013, 2:17 am

Faulty HTML seems to be the cause of this.

Do tell me, when cliking the YouTube button, what options do you have of entering text? I'm on a phone which does not support the editor fully, so I don't know.
But it seems like some HTML attributes being cut off by the quotes indeed.

Ultron's Vision
Forumember

Male Posts : 634
Reputation : 45
Language : English | German | HTML | JavaScript | PHP | C++ | Perl | Java
Location : Vienna, Austria

http://duelacademy.net

Back to top Go down

Page 1 of 2 1, 2  Next

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum