The forum of the forums
Welcome to the Official Support Forum of Forumotion!

To take full advantage of everything offered by our forum, please log in if you are already a member, or join our community if you've not yet.



Create a free forum like this one.

Problem with bbcode/html changing automatically in posts (Invision theme)

View previous topic View next topic Go down

Problem with bbcode/html changing automatically in posts (Invision theme)

Post by Handyy on January 13th 2014, 12:57 pm

Hi,

I'm using Invision theme for my forum. For some reason when I'm posting a message, if I don't press 'preview' and post the message will be posted as it should. But if I look at the preview, or edit a posted message, the code for example bbcode tables is changed and messes up how it should look.

For example, if I want to post a table like this:

Code:
[table][tr height=20][td]Test[/td][/tr][/table]

It comes out ok when posting directly. But when I use preview or edit message, the code has changed to:

Code:
[table][tr][td]Test[/td]
[/tr]
[/table]

This alters the graphical view of the table and messes up what I was trying to do (removing height, adding line changes). Is there something I can do to prevent it, so my message would remain as I have intended it to be?

The same applies for using html font tags, when posting without previewing, the message is posted with the fonts I desired, but when previewing or editing the font tags have been removed.

This doesn't seem to happen with phpbb, only with invision. However, the style of my forum is pretty much tied to the type of the theme...

Any ideas?

Handyy
Forumember

Posts : 32
Reputation : 0
Language : English

Back to top Go down

Re: Problem with bbcode/html changing automatically in posts (Invision theme)

Post by Derri on January 13th 2014, 2:31 pm

Just to clarify, when you hit preview, the formatting changes and as a result the table does work?


Forum Rules: :Forumotion Staff: :Appeal A Warning: :FAQ: :Tips & Tricks: :Forgotten Password/Login Issues
You need one post to send a PM
When your topic has been solved, ensure you mark the topic solved
Never post your email in public


Derri
Administrator
Administrator

Male Posts : 8385
Reputation : 576
Language : English & Basic French
Location : Scotland, United Kingdom

Back to top Go down

Re: Problem with bbcode/html changing automatically in posts (Invision theme)

Post by Handyy on January 13th 2014, 2:51 pm

@Derri wrote:Just to clarify, when you hit preview, the formatting changes and as a result the table does work?
When I hit preview, the actual preview of the message results a working table. However now the changed code is in the message box and if I click send, it sends that faulty code. So I can't use preview option at all.

In another words, when I write the table code myself for the first time, it prints out fine. But when the forum opens the message box again (in preview or edit), the code comes out different and now it will not create a working message any more. It loses some of the formatting, widths, heights, fonts ect.

Edit: Here's an image about the situation. I submitted the same message twice to my forum, first without preview and second message is submitted with preview. The first message prints out exactly how I wanted it to be, but in the second message all the font changes have disappeared, table rows have different heights and things aren't aligned as should. For some reason it just deletes some of the formatting, when the message box is shown twice.

http://i.imgur.com/wX7okpZ.png

Handyy
Forumember

Posts : 32
Reputation : 0
Language : English

Back to top Go down

Re: Problem with bbcode/html changing automatically in posts (Invision theme)

Post by Derri on January 13th 2014, 3:03 pm

Yeah I was clarifying because I'm aware of this bug myself and it's currently being reported to the technicians who'll hopefully find a solution.

I have to use a BBcode template for doing my official reviews here and if I hit the preview button the formatting changes and line spacing changes so the code no longer look correct and therefore faults do occur.

Like I said above, this is currently reported to the techs and hopefully they'll fix this. Until then all I can suggest is you do as many checks as possible and then submit the HTML and hope for the best. I know this doesn't sound like a solution but it's all we can really do until the techs fix the problem.


Forum Rules: :Forumotion Staff: :Appeal A Warning: :FAQ: :Tips & Tricks: :Forgotten Password/Login Issues
You need one post to send a PM
When your topic has been solved, ensure you mark the topic solved
Never post your email in public


Derri
Administrator
Administrator

Male Posts : 8385
Reputation : 576
Language : English & Basic French
Location : Scotland, United Kingdom

Back to top Go down

Re: Problem with bbcode/html changing automatically in posts (Invision theme)

Post by Handyy on January 13th 2014, 3:23 pm

Thanks for the info, I really appreciate it. I can still make it work, I just can't use the preview or edit the messages for the time being.

Handyy
Forumember

Posts : 32
Reputation : 0
Language : English

Back to top Go down

Re: Problem with bbcode/html changing automatically in posts (Invision theme)

Post by Derri on January 13th 2014, 3:27 pm

Glad I could help.

Yes it does prevent you form using the preview button and in some cases, editing.

This is why I often have to triple post when doing a review here. However the issue has been reported and hopefully it will be fixed.


Forum Rules: :Forumotion Staff: :Appeal A Warning: :FAQ: :Tips & Tricks: :Forgotten Password/Login Issues
You need one post to send a PM
When your topic has been solved, ensure you mark the topic solved
Never post your email in public


Derri
Administrator
Administrator

Male Posts : 8385
Reputation : 576
Language : English & Basic French
Location : Scotland, United Kingdom

Back to top Go down

Re: Problem with bbcode/html changing automatically in posts (Invision theme)

Post by Jophy on January 24th 2014, 4:49 am

Hello,

Please refer to this topic:
http://help.forumotion.com/t129120-582-ie-problem-v2-editor-bugs

It's already in the notice of the techs, please post your issues there, thanks. Smile

Locked

Jophy
ForumGuru

Male Posts : 17924
Reputation : 835
Language : English
Location : Somewhere

Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum