The forum of the forums
Welcome to the Official Support Forum of Forumotion!

To take full advantage of everything offered by our forum, please log in if you are already a member, or join our community if you've not yet.



Create a free forum like this one.

Tables Problem

View previous topic View next topic Go down

Solved Tables Problem

Post by Rhino.Freak on February 18th 2014, 11:35 am

Hi guys, I made a simple table for a post in my forum but the lines / separator line which separates the rows and columns etc are not showing

how can I fix that? :/ thanx..

I didn't use any styling in table except the "border: 2px solid white".. thanx

and a mini question, how to know the forum version of another forum?

Rhino.Freak
Active Poster

Male Posts : 1243
Reputation : 105
Language : English
Location : Mumbai, India

http://freetest.forumotion.net/

Back to top Go down

Solved Re: Tables Problem

Post by Jophy on February 18th 2014, 11:52 am

Hello,

Can we see the codes you used?

Jophy
ForumGuru

Male Posts : 17924
Reputation : 835
Language : English
Location : Somewhere

Back to top Go down

Solved Re: Tables Problem

Post by Rhino.Freak on February 18th 2014, 12:10 pm

Code:

[table style="border: 2px solid white; color: white;"][tr][td]Head Administrator[/td][td]Administrator[/td][td]Administrator[/td][/tr][tr][td][url=http://onepiecea-edition.yoo7.com/u1][b][color=#2dbd2d]A-MAN[/color][/b][/url][/td][td][url=http://onepiecea-edition.yoo7.com/u2][b][color=#2dbd2d]pack5642[/color][/b][/url] [/td][td][url=http://onepiecea-edition.yoo7.com/u1][b][color=#595959]Rhino[/color] [color=#5e27b0]Freak[/color][/b][/url][/td][/tr][tr][td][url=http://onepiecea-edition.yoo7.com/privmsg?mode=post&u=1]PM[/url][/td][td][url=http://onepiecea-edition.yoo7.com/privmsg?mode=post&u=2]PM[/url] [/td][td][url=http://onepiecea-edition.yoo7.com/privmsg?mode=post&u=10]PM[/url] [/td][/tr][/table]

This.. sorry its messy coz it has links

checking how it looks here:

Head AdministratorAdministratorAdministrator
A-MANpack5642 Rhino Freak
PMPM PM


Last edited by Rhino.Freak on February 18th 2014, 3:09 pm; edited 2 times in total

Rhino.Freak
Active Poster

Male Posts : 1243
Reputation : 105
Language : English
Location : Mumbai, India

http://freetest.forumotion.net/

Back to top Go down

Solved Re: Tables Problem

Post by help@bearvillecamp on February 18th 2014, 12:31 pm

It's probably because u have ur thing on phpbb 3.
I've got mine on phpbb 2 and mine works

help@bearvillecamp
New Member

Female Posts : 6
Reputation : 1
Language : English

Http://bearvillecamp.forumotion.com

Back to top Go down

Solved Re: Tables Problem

Post by Rhino.Freak on February 18th 2014, 1:19 pm

@help@bearvillecamp wrote:It's probably because u have ur thing on phpbb 3.
I've got mine on phpbb 2 and mine works

sorry but I really don't think that could be the problem.

Rhino.Freak
Active Poster

Male Posts : 1243
Reputation : 105
Language : English
Location : Mumbai, India

http://freetest.forumotion.net/

Back to top Go down

Solved Re: Tables Problem

Post by Jophy on February 19th 2014, 6:47 am

Use this code:
Code:
[table class="modified" style="border: 2px solid white; color: white;"]
[tr]
[td style="border:2px solid white;"]Head Administrator[/td]
[td style="border:2px solid white;"]Administrator[/td]
[td style="border:2px solid white;"]Administrator[/td]
[/tr]
[tr]
[td style="border:2px solid white;"][url=http://onepiecea-edition.yoo7.com/u1][b][color=#2dbd2d]A-MAN[/color][/b][/url][/td]
[td style="border:2px solid white;"][url=http://onepiecea-edition.yoo7.com/u2][b][color=#2dbd2d]pack5642[/color][/b][/url] [/td]
[td style="border:2px solid white;"][url=http://onepiecea-edition.yoo7.com/u1][b][color=#595959]Rhino[/color] [color=#5e27b0]Freak[/color][/b][/url][/td]
[/tr]
[tr]
[td style="border:2px solid white;"][url=http://onepiecea-edition.yoo7.com/privmsg?mode=post&u=1]PM[/url][/td]
[td style="border:2px solid white;"][url=http://onepiecea-edition.yoo7.com/privmsg?mode=post&u=2]PM[/url] [/td]
[td style="border:2px solid white;"][url=http://onepiecea-edition.yoo7.com/privmsg?mode=post&u=10]PM[/url] [/td]
[/tr][/table]

Then add this to your css:
Code:
.modified {
 border-collapse: collapse !important;
}

See if it will work.

Jophy
ForumGuru

Male Posts : 17924
Reputation : 835
Language : English
Location : Somewhere

Back to top Go down

Solved Re: Tables Problem

Post by Rhino.Freak on February 19th 2014, 8:15 am

thank you, that did solve the problem, but I would have to make such table everytime? isn't there a normal solution that makes ALL tables normal?
+1 for this code by the way

Rhino.Freak
Active Poster

Male Posts : 1243
Reputation : 105
Language : English
Location : Mumbai, India

http://freetest.forumotion.net/

Back to top Go down

Solved Re: Tables Problem

Post by Jophy on February 19th 2014, 8:20 am

Well there might be a code in the CSS(on your forum theme) that's preventing the tables to show normally, you can just create tables by using the modified class:
Code:
[table class="modified"]
[/table]

And modify it accordingly. Wink


Last edited by Jophy on February 19th 2014, 8:23 am; edited 1 time in total

Jophy
ForumGuru

Male Posts : 17924
Reputation : 835
Language : English
Location : Somewhere

Back to top Go down

Solved Re: Tables Problem

Post by Rhino.Freak on February 19th 2014, 8:22 am

uhm sorry but can you provide the css for .modified ?  bwi nevrmind on that, and can someone provide me a css code that actually makes those lines normal?

also 1 last thing regarding tables, how can I make the width of each cell in table constant or same?
Like the one in which A-MAN is written is pretty nice width, I want it in all cells, any ways to do so?

Rhino.Freak
Active Poster

Male Posts : 1243
Reputation : 105
Language : English
Location : Mumbai, India

http://freetest.forumotion.net/

Back to top Go down

Solved Re: Tables Problem

Post by Jophy on February 19th 2014, 9:12 am

how can I make the width of each cell in table constant or same?
Like the one in which A-MAN is written is pretty nice width, I want it in all cells, any ways to do so?
You will need to insert the width property in the td:
Code:
[td style="border:2px solid white; width:125px;"][/td]
Try 125px first.

So this will be the code:
Code:
[table class="modified" style="border: 2px solid white; color: white;"]
[tr]
[td style="border:2px solid white; width:125px;"]Head Administrator[/td]
[td style="border:2px solid white; width:125px;"]Administrator[/td]
[td style="border:2px solid white; width:125px;"]Administrator[/td]
[/tr]
[tr]
[td style="border:2px solid white; width:125px;"][url=http://onepiecea-edition.yoo7.com/u1][b][color=#2dbd2d]A-MAN[/color][/b][/url][/td]
[td style="border:2px solid white; width:125px;"][url=http://onepiecea-edition.yoo7.com/u2][b][color=#2dbd2d]pack5642[/color][/b][/url] [/td]
[td style="border:2px solid white; width:125px;"]][url=http://onepiecea-edition.yoo7.com/u1][b][color=#595959]Rhino[/color] [color=#5e27b0]Freak[/color][/b][/url][/td]
[/tr]
[tr]
[td style="border:2px solid white; width:125px;"][url=http://onepiecea-edition.yoo7.com/privmsg?mode=post&u=1]PM[/url][/td]
[td style="border:2px solid white; width:125px;"][url=http://onepiecea-edition.yoo7.com/privmsg?mode=post&u=2]PM[/url] [/td]
[td style="border:2px solid white; width:125px;"][url=http://onepiecea-edition.yoo7.com/privmsg?mode=post&u=10]PM[/url] [/td]
[/tr][/table]

and can someone provide me a css code that actually makes those lines normal?
Which lines do you mean?

Jophy
ForumGuru

Male Posts : 17924
Reputation : 835
Language : English
Location : Somewhere

Back to top Go down

Solved Re: Tables Problem

Post by Rhino.Freak on February 19th 2014, 9:15 am

thanx that worked! Very Happy
hmm and the lines I am taking about are those which weren't appearing normally, the ones I made this topic for..

Rhino.Freak
Active Poster

Male Posts : 1243
Reputation : 105
Language : English
Location : Mumbai, India

http://freetest.forumotion.net/

Back to top Go down

Solved Re: Tables Problem

Post by Jophy on February 19th 2014, 9:21 am

Well, I'm not sure either, I tried the original code you posted on my test forum and the lines don't show either, I think the only way to fix it is by adding the border property to the td.

Code:
[td style="border:2px;"][/td]

I guess that's what's missing on your original code that's why the column and row lines won't show.

Jophy
ForumGuru

Male Posts : 17924
Reputation : 835
Language : English
Location : Somewhere

Back to top Go down

Solved Re: Tables Problem

Post by Rhino.Freak on February 20th 2014, 6:57 am

dude lol! I just read the BBcode guide and it said

Code:
use [table border="1"]


blabla
blabla2

I guess its solved now

(someone asnwer my mini question too)

Rhino.Freak
Active Poster

Male Posts : 1243
Reputation : 105
Language : English
Location : Mumbai, India

http://freetest.forumotion.net/

Back to top Go down

Solved Re: Tables Problem

Post by SLGray on February 20th 2014, 8:13 pm

Problem solved & topic archived.


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 35622
Reputation : 2372
Language : English
Location : United States

http://fmthemes.forumotion.com/

Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum