The forum of the forums
Welcome to the Official Support Forum of Forumotion!

To take full advantage of everything offered by our forum, please log in if you are already a member, or join our community if you've not yet.



Create a free forum like this one.

Link for Reply problem.

View previous topic View next topic Go down

Solved Link for Reply problem.

Post by Babybok on April 6th 2014, 11:06 am

Hello, Hi im here again, asking question about my problem in my forum.

My problem is, why my forum doesn't have a link for the reply of each user? like what forumotion has. I mean a direct link to the reply of a user. sorry i can't english well..

here's the screenshot to explain my problem..

I mean this thing... i can hover the topic/reply title of the poster.



and can right click on it with this menus "open link in new tab" open link in new window" and etc.


But my forum hasn't like that.



It only contains a font title..



Please help me...


Thanks in advance,
Babybok


Last edited by Babybok on April 8th 2014, 1:32 pm; edited 6 times in total

Babybok
Forumember

Male Posts : 136
Reputation : 0
Language : Filipino, English
Location : Philippines

http://rl-rp.board.st

Back to top Go down

Solved Re: Link for Reply problem.

Post by Babybok on April 6th 2014, 12:25 pm

Bump!

Babybok
Forumember

Male Posts : 136
Reputation : 0
Language : Filipino, English
Location : Philippines

http://rl-rp.board.st

Back to top Go down

Solved Re: Link for Reply problem.

Post by Ange Tuteur on April 6th 2014, 8:55 pm

Hello Babybok,

Please do not double post, you can bump your post if no one has replied once every 24hours. Remember that other members also have questions, so please be patient.

Thank you.


Go to :
Administration Panel > Display > General > Templates > viewtopic_body

Find this part :
Code:
<td><span class="postdetails"><img src="{postrow.displayed.MINI_POST_IMG}" alt="{postrow.displayed.L_MINI_POST_ALT}" title="{postrow.displayed.L_MINI_POST_ALT}" border="0" />{L_POST_SUBJECT}: {postrow.displayed.POST_SUBJECT} <img src="{postrow.displayed.MINI_TIME_IMG}" alt="" border="0" />{postrow.displayed.POST_DATE}</span></td>

Replace it with :
Code:
  <td><span class="postdetails"><img src="{postrow.displayed.MINI_POST_IMG}" alt="{postrow.displayed.L_MINI_POST_ALT}" title="{postrow.displayed.L_MINI_POST_ALT}" border="0" />{L_POST_SUBJECT}: <a href="#{postrow.displayed.U_POST_ID}">{postrow.displayed.POST_SUBJECT}</a> <img src="{postrow.displayed.MINI_TIME_IMG}" alt="" border="0" />{postrow.displayed.POST_DATE}</span></td>

Then save and publish the template.

Ange Tuteur
Forumaster

Male Posts : 13028
Reputation : 2704
Language : EN10, FR5
Location : Pennsylvania

http://fmdesign.forumotion.com

Back to top Go down

Solved Re: Link for Reply problem.

Post by Babybok on April 7th 2014, 1:32 pm

Thanks sir, Sorry for the Bump and Double Post.

Solved.


Last edited by Babybok on April 7th 2014, 1:57 pm; edited 1 time in total

Babybok
Forumember

Male Posts : 136
Reputation : 0
Language : Filipino, English
Location : Philippines

http://rl-rp.board.st

Back to top Go down

Solved Re: Link for Reply problem.

Post by Ange Tuteur on April 7th 2014, 1:52 pm

Did you replace more than you were supposed to ?

You only need to replace the part which contains the postdetails :
Code:
<td><span class="postdetails"><img src="{postrow.displayed.MINI_POST_IMG}" alt="{postrow.displayed.L_MINI_POST_ALT}" title="{postrow.displayed.L_MINI_POST_ALT}" border="0" />{L_POST_SUBJECT}: {postrow.displayed.POST_SUBJECT} <img src="{postrow.displayed.MINI_TIME_IMG}" alt="" border="0" />{postrow.displayed.POST_DATE}</span></td>

I would recommend reverting back to the default viewtopic_body and redoing the steps.

Ange Tuteur
Forumaster

Male Posts : 13028
Reputation : 2704
Language : EN10, FR5
Location : Pennsylvania

http://fmdesign.forumotion.com

Back to top Go down

Solved Re: Link for Reply problem.

Post by Babybok on April 7th 2014, 1:58 pm

Sorry, Wrong replacement cause I've also replace the

Code:
<td valign="top" nowrap="nowrap" class="post-options">
                  {postrow.displayed.THANK_IMG} {postrow.displayed.MULTIQUOTE_IMG} {postrow.displayed.QUOTE_IMG} {postrow.displayed.EDIT_IMG} {postrow.displayed.DELETE_IMG} {postrow.displayed.IP_IMG} {postrow.displayed.REPORT_IMG}
               </td>


Thanks it works but one problem is I've try to click the link of the topic I like, but it direct/move to the next topic, and not the one I've click. any solution mam /sir?




Babybok
Forumember

Male Posts : 136
Reputation : 0
Language : Filipino, English
Location : Philippines

http://rl-rp.board.st

Back to top Go down

Solved Re: Link for Reply problem.

Post by Ange Tuteur on April 8th 2014, 12:07 am

When you click that link it will add the post ID to the current URL. This will then move the browser window to that posts location. If you have moved this piece in your template to a lower portion of the posts then that is where the browser window will stop.
Code:
<a name="{postrow.displayed.U_POST_ID}" style="position: relative; top: -30px; width: 1px;" id="{postrow.displayed.U_POST_ID}"></a>

It would be best to place it after this part in the profile :
Code:
<td class="{postrow.displayed.ROW_CLASS}"{postrow.displayed.THANK_BGCOLOR} valign="top" width="150">

to :
Code:
<td class="{postrow.displayed.ROW_CLASS}"{postrow.displayed.THANK_BGCOLOR} valign="top" width="150">
  <a name="{postrow.displayed.U_POST_ID}" style="position: relative; top: -30px; width: 1px;" id="{postrow.displayed.U_POST_ID}"></a>

This is in the viewtopic_body where the postprofile is.

Ange Tuteur
Forumaster

Male Posts : 13028
Reputation : 2704
Language : EN10, FR5
Location : Pennsylvania

http://fmdesign.forumotion.com

Back to top Go down

Solved Re: Link for Reply problem.

Post by Babybok on April 8th 2014, 1:26 pm

Thanks mam... Solved.

Babybok
Forumember

Male Posts : 136
Reputation : 0
Language : Filipino, English
Location : Philippines

http://rl-rp.board.st

Back to top Go down

Solved Re: Link for Reply problem.

Post by Jophy on April 8th 2014, 1:38 pm

Solved

Jophy
ForumGuru

Male Posts : 17924
Reputation : 835
Language : English
Location : Somewhere

Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum