The forum of the forums
Welcome to the Official Support Forum of Forumotion!

To take full advantage of everything offered by our forum, please log in if you are already a member, or join our community if you've not yet.



Create a free forum like this one.

Losing topic/reply settings when editing

View previous topic View next topic Go down

Pro Admin Losing topic/reply settings when editing

Post by Shibiusa on May 22nd 2014, 7:44 pm

Hello!
I'm an admin in a portuguese forum (http://www.narutoportugalrpg.com/ ) and we have been noticing an issue for the last months that has been bugging us a lot. I can't say if it's a bug or something, but whenever we need to edit a topic or a reply, we lose our editing settings (bold, font size and all that) and the forum itself adds a lot of spacing between the paragraphs. We have to rewrite the whole topic to keep it the way we want to and that's really annoying. Every editing we do makes it even worse. I already tried writing with WYSIWYG ("what you see is what you get") and without it and it happens with both. Can you help us, please? I already tried the portuguese/brazilian support forum, but they don't give us any concrete answer about this...

Shibiusa
Forumember

Female Posts : 26
Reputation : 10
Language : English, Portuguese

http://www.narutoportugalrpg.com/

Back to top Go down

Pro Admin Re: Losing topic/reply settings when editing

Post by Tommy Lee on May 22nd 2014, 7:48 pm

Hello,

I do not understand Portuguese. So I cannot investigate on your forum. As this is a English Support Forum. I will try my hardest to investigate on your forum please be patient this make take up to 1-2 hours as i will translate text on your forum.

Tommy Lee
Forumember

Posts : 232
Reputation : 7
Language : English

Back to top Go down

Pro Admin Re: Losing topic/reply settings when editing

Post by Shibiusa on May 22nd 2014, 8:02 pm

Hi!
Thank you! I can give you an example. You don't need to understand portuguese Smile
http://www.narutoportugalrpg.com/t3018-regras-do-roleplay-ler-antes-de-comecar-a-jogar
See this topic? The original topic didn't have that much spacing. It adds a lot of spacing by itself whenever we edit that one. You can see by the spacing inside the listing area (and around the images). It just grows and grows... Then we edit to take away the spacing and it grows again... If we want to keep it without that spacing, we need to copy it to Word and restart the editing from scratch. Yesterday, it happened with another topic (it just lost the font we had on it when I had to edit it). And yes, it has been happening regularly with everyone. That topic is just an example.

Shibiusa
Forumember

Female Posts : 26
Reputation : 10
Language : English, Portuguese

http://www.narutoportugalrpg.com/

Back to top Go down

Pro Admin Re: Losing topic/reply settings when editing

Post by Derri on May 22nd 2014, 8:13 pm

Hi,

Do you at all use the
Code:
[list] [/list]
function at all without actually creating a list? What I mean by this is you use the list tags like showed above but you don't use
[*]to actually create a bullet point list?

If so the editor reacts strangely to this because its trying to auto correct the BBcode. It can also happen if you're using other BBcode as well.


Forum Rules: :Forumotion Staff: :Appeal A Warning: :FAQ: :Tips & Tricks: :Forgotten Password/Login Issues
You need one post to send a PM
When your topic has been solved, ensure you mark the topic solved
Never post your email in public


Derri
Administrator
Administrator

Male Posts : 8385
Reputation : 576
Language : English & Basic French
Location : Scotland, United Kingdom

Back to top Go down

Pro Admin Re: Losing topic/reply settings when editing

Post by Shibiusa on May 22nd 2014, 8:23 pm

@Derri wrote:Hi,

Do you at all use the
Code:
[list] [/list]
function at all without actually creating a list? What I mean by this is you use the list tags like showed above but you don't use
[*]to actually create a bullet point list?

If so the editor reacts strangely to this because its trying to auto correct the BBcode. It can also happen if you're using other BBcode as well.
Hi!
The original topic had the correct bbcode (that one you just mentioned too) and the topic started using it by itself. Some of the weird spacing is there because the topic added (by itself) a lot of:
Code:
[/list]

[/list]

[/list]
[list]
That's how the weird spacing appeared and it still adds it.
Yesterday, I had to edit this topic (http://www.narutoportugalrpg.com/t7578-sharingan) and it started again too. Those listings just mess with the topic and lots of spacing appears out of nowhere (the titles inside the topic didn't have that much space before and after them, the listing was right below its title, the quote was below the listing...).

Shibiusa
Forumember

Female Posts : 26
Reputation : 10
Language : English, Portuguese

http://www.narutoportugalrpg.com/

Back to top Go down

Pro Admin Re: Losing topic/reply settings when editing

Post by Derri on May 22nd 2014, 8:42 pm

The problem appears to come from when you use the list bbcode tags without actually creating a list. You need to have the list look like this:

Code:
[list][*]Test[/list]

Because if you use the list tags without the above [*] then that's what creates the problem and the table formatting just goes completely to hell. I had a similar problem on here as the review BBcode templates that us reviewers use has the [list] tag but without actually having [*] so we can post it fine but as soon as we go to edit it, all the formatting and stuff ends up really messy.

I believe this is what is causing the issue.


Forum Rules: :Forumotion Staff: :Appeal A Warning: :FAQ: :Tips & Tricks: :Forgotten Password/Login Issues
You need one post to send a PM
When your topic has been solved, ensure you mark the topic solved
Never post your email in public


Derri
Administrator
Administrator

Male Posts : 8385
Reputation : 576
Language : English & Basic French
Location : Scotland, United Kingdom

Back to top Go down

Pro Admin Re: Losing topic/reply settings when editing

Post by Shibiusa on May 22nd 2014, 8:46 pm

@Derri wrote:The problem appears to come from when you use the list bbcode tags without actually creating a list. You need to have the list look like this:

Code:
[list][*]Test[/list]

Because if you use the list tags without the above
[*] then that's what creates the problem and the table formatting just goes completely to hell. I had a similar problem on here as the review BBcode templates that us reviewers use has the [list] tag but without actually having
[*]so we can post it fine but as soon as we go to edit it, all the formatting and stuff ends up really messy.

I believe this is what is causing the issue.
I agree it might be the cause in the first topic. But it doesn't answer all of the problems... It seems any topic with a quote has the same issue (lots of spacing before and after the quote) or even a spoiler code. It is supposed to add spacing by itself and messing with our editing?

Shibiusa
Forumember

Female Posts : 26
Reputation : 10
Language : English, Portuguese

http://www.narutoportugalrpg.com/

Back to top Go down

Pro Admin Re: Losing topic/reply settings when editing

Post by Derri on May 22nd 2014, 9:53 pm

Hi,

When you say this does it with quotes and spoiler tags, these are within the same posts as the [list] tags are used right? If so everything gets effected and jumbled up.



Forum Rules: :Forumotion Staff: :Appeal A Warning: :FAQ: :Tips & Tricks: :Forgotten Password/Login Issues
You need one post to send a PM
When your topic has been solved, ensure you mark the topic solved
Never post your email in public


Derri
Administrator
Administrator

Male Posts : 8385
Reputation : 576
Language : English & Basic French
Location : Scotland, United Kingdom

Back to top Go down

Pro Admin Re: Losing topic/reply settings when editing

Post by Shibiusa on May 22nd 2014, 10:30 pm

@Derri wrote:Hi,

When you say this does it with quotes and spoiler tags, these are within the same posts as the [list] tags are used right? If so everything gets effected and jumbled up.

Hi!
No, just random topics with spoilers and quotes. The only thing that has to be there is one of them (or both). It just adds spacings if we edit something after we post. I noticed it happened after one general update. Even the quotes weren't working right after it (but now I think they are fine. Just this little issue with editing).

Shibiusa
Forumember

Female Posts : 26
Reputation : 10
Language : English, Portuguese

http://www.narutoportugalrpg.com/

Back to top Go down

Pro Admin Re: Losing topic/reply settings when editing

Post by Derri on May 22nd 2014, 10:52 pm

Okay,

I'll pass this problem along to our Pro Admin who'll be able to take a look into the issue.


Forum Rules: :Forumotion Staff: :Appeal A Warning: :FAQ: :Tips & Tricks: :Forgotten Password/Login Issues
You need one post to send a PM
When your topic has been solved, ensure you mark the topic solved
Never post your email in public


Derri
Administrator
Administrator

Male Posts : 8385
Reputation : 576
Language : English & Basic French
Location : Scotland, United Kingdom

Back to top Go down

Pro Admin Re: Losing topic/reply settings when editing

Post by Leviosa on June 9th 2014, 10:22 am

Hello

Could you please provide a screenshot before editing and after editing ?

Many thanks in advance


No help without your forum url
No support via private message



Leviosa
Administrator
Administrator

Female Posts : 15587
Reputation : 1589
Language : French, English

http://help.forumotion.com

Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum