The forum of the forums
Welcome to the Official Support Forum of Forumotion!

To take full advantage of everything offered by our forum, please log in if you are already a member, or join our community if you've not yet.



Create a free forum like this one.

Offline Icon Doesnt Appear

View previous topic View next topic Go down

Solved Offline Icon Doesnt Appear

Post by J0k3R^ on May 23rd 2014, 8:00 pm

Details: Hello. i got a small problem. The offline icon doesnt appear to the users that they are offline (at topic messages). i want to display this image.
Thanks Smile
Forum Address: myplanet.forumgreek.com
Forum Version: punbb

J0k3R^
Forumember

Male Posts : 742
Reputation : 28
Language : Greek > English > Russian > Spanish
Location : C:\>r00t

http://fmplanet.forumgreek.com

Back to top Go down

Solved Re: Offline Icon Doesnt Appear

Post by PunBBGR on May 23rd 2014, 8:05 pm

Hello,

What code did you use in the templates?

Regards.

PunBBGR
Forumember

Posts : 39
Reputation : 6
Language : Greek, English
Location : Greece

http://helpgr.forumgreek.com/forum

Back to top Go down

Solved Re: Offline Icon Doesnt Appear

Post by J0k3R^ on May 23rd 2014, 8:15 pm

i think i dont have any

J0k3R^
Forumember

Male Posts : 742
Reputation : 28
Language : Greek > English > Russian > Spanish
Location : C:\>r00t

http://fmplanet.forumgreek.com

Back to top Go down

Solved Re: Offline Icon Doesnt Appear

Post by PunBBGR on May 23rd 2014, 8:30 pm

Hello Jok3R^,

The reason why it is not appearing is, because it should have by default and image below the online image. That way, when a user goes off-line the online image disappears and the off-line image stays there.

To do that, go to your Administrator Panel, then to Display, after to Templates and choose the viewtopic_body template.

In the template you should find a code like this:
Code:
{postrow.displayed.ONLINE_IMG}

All you have to do is replace this code with this:
Code:
<div class="onlineoffline">{postrow.displayed.ONLINE_IMG}</div>

Save it and publish it and then go to Display again to Colors and Pics, Select Colors and click the CSS Stylesheet. In there you must add this code:
Code:
.onlineoffline {
background: transparent url("IMAGE URL HERE") no-repeat;
position: relative;
}

And save it.

This will work but it may be out of position. If so add "margin" and set it as wanted.


Regards.

PunBBGR
Forumember

Posts : 39
Reputation : 6
Language : Greek, English
Location : Greece

http://helpgr.forumgreek.com/forum

Back to top Go down

Solved Re: Offline Icon Doesnt Appear

Post by J0k3R^ on May 23rd 2014, 9:17 pm

Thanks for reply but it didnt work :/
(i had tried this way already)

J0k3R^
Forumember

Male Posts : 742
Reputation : 28
Language : Greek > English > Russian > Spanish
Location : C:\>r00t

http://fmplanet.forumgreek.com

Back to top Go down

Solved Re: Offline Icon Doesnt Appear

Post by PunBBGR on May 23rd 2014, 9:29 pm

Hello Jok3R^,

Where exactly do you want to add this icon? Can you provide an image with this icon or an image with the content you wish to have please?

Regards.

PunBBGR
Forumember

Posts : 39
Reputation : 6
Language : Greek, English
Location : Greece

http://helpgr.forumgreek.com/forum

Back to top Go down

Solved Re: Offline Icon Doesnt Appear

Post by J0k3R^ on May 23rd 2014, 9:54 pm

in the pic u see where the online icon is.
i want the same position when somebody is offline to show this icon:https://i71.servimg.com/u/f71/18/17/62/92/offlin10.png




J0k3R^
Forumember

Male Posts : 742
Reputation : 28
Language : Greek > English > Russian > Spanish
Location : C:\>r00t

http://fmplanet.forumgreek.com

Back to top Go down

Solved Re: Offline Icon Doesnt Appear

Post by PunBBGR on May 23rd 2014, 10:04 pm

Hello Jok3R^,

You could simply add an image there to be displayed always and when a user log in then the online image will be displayed on top of it. Did you try this?

Regards.

PunBBGR
Forumember

Posts : 39
Reputation : 6
Language : Greek, English
Location : Greece

http://helpgr.forumgreek.com/forum

Back to top Go down

Solved Re: Offline Icon Doesnt Appear

Post by J0k3R^ on May 23rd 2014, 10:06 pm

i tried ur code but it didnt make any result (i was using it the same way but now i dont know whats wrong Smile )

J0k3R^
Forumember

Male Posts : 742
Reputation : 28
Language : Greek > English > Russian > Spanish
Location : C:\>r00t

http://fmplanet.forumgreek.com

Back to top Go down

Solved Re: Offline Icon Doesnt Appear

Post by PunBBGR on May 23rd 2014, 10:16 pm

Hello Jok3R^,

Now lets try it the other way i told you.
Go to the template editting and edit the vewtopic_body
Find this:
Code:
{postrow.displayed.ONLINE_IMG}
and replace it with this one:
Code:
<span class="offlineicon"><img src="http://i71.servimg.com/u/f71/18/17/62/92/offlin10.png" /> </span><span class="onlineicon">{postrow.displayed.ONLINE_IMG}</span>
Save it and publish it.

Then go to the CSS Stylesheet and place the below code:
Code:
.offlineicon img {
position: relative;
margin-top: -25px;
margin-left: 90px;
}
.onlineicon img {
position: relative;
margin-top: -25px;
margin-left: 90px;
}
And save it.

That should do it.

Regards.

PunBBGR
Forumember

Posts : 39
Reputation : 6
Language : Greek, English
Location : Greece

http://helpgr.forumgreek.com/forum

Back to top Go down

Solved Re: Offline Icon Doesnt Appear

Post by J0k3R^ on May 23rd 2014, 10:27 pm

This is working but now the problem is that they are shown both icons when im online (they are in line). With ur css or not, i dont get any result Very Happy

J0k3R^
Forumember

Male Posts : 742
Reputation : 28
Language : Greek > English > Russian > Spanish
Location : C:\>r00t

http://fmplanet.forumgreek.com

Back to top Go down

Solved Re: Offline Icon Doesnt Appear

Post by PunBBGR on May 23rd 2014, 10:30 pm

Hello,

If they are shown in the same line then by moving the online img on top of the offline img that would get you the wanted result.
The CSS given is to make both one on an other. If not just change the margin and you should be done.

Regards.

PunBBGR
Forumember

Posts : 39
Reputation : 6
Language : Greek, English
Location : Greece

http://helpgr.forumgreek.com/forum

Back to top Go down

Solved Re: Offline Icon Doesnt Appear

Post by J0k3R^ on May 23rd 2014, 10:42 pm

i had thought about it but i think ti not work. see the image in my previous: the online icon is next to the username, so i cant put positions settings to css because if someone got big name yhe icon wont be displayed where it should :/

J0k3R^
Forumember

Male Posts : 742
Reputation : 28
Language : Greek > English > Russian > Spanish
Location : C:\>r00t

http://fmplanet.forumgreek.com

Back to top Go down

Solved Re: Offline Icon Doesnt Appear

Post by PunBBGR on May 23rd 2014, 10:44 pm

Hello,

Yes you could have the online and offline image shown to the right side of the bar. So you won't have any problem with the name.
To do that simply add
Code:
float:right;

Regards.

PunBBGR
Forumember

Posts : 39
Reputation : 6
Language : Greek, English
Location : Greece

http://helpgr.forumgreek.com/forum

Back to top Go down

Solved Re: Offline Icon Doesnt Appear

Post by J0k3R^ on May 24th 2014, 10:34 am

i tried float right but nothing changed

J0k3R^
Forumember

Male Posts : 742
Reputation : 28
Language : Greek > English > Russian > Spanish
Location : C:\>r00t

http://fmplanet.forumgreek.com

Back to top Go down

Solved Re: Offline Icon Doesnt Appear

Post by @Mark on May 24th 2014, 10:55 am

Find this on viewtopic_body:
Code:
{postrow.displayed.ONLINE_IMG}

Replace it with this:
Code:
<span class="officon"><img src="http://i71.servimg.com/u/f71/18/17/62/92/offlin10.png" /></span><span class="onicon">{postrow.displayed.ONLINE_IMG}</span>

Now add this to your CSS:
Code:
.officon {
  position: absolute;
  margin-top: 12px;
  margin-left: 5px;
}
.officon img {
  width: 46px;
  height: 15px;
}
.onicon {
margin-left: 5px;
margin-top: -3px;
position: relative;
}

@Mark
Forumember

Male Posts : 187
Reputation : 37
Language : HTML | CSS | Javascript | C | Java
Location : Republic of the Philippines

http://help.forumotion.com/

Back to top Go down

Solved Re: Offline Icon Doesnt Appear

Post by J0k3R^ on May 24th 2014, 11:12 am

ehm.. :/


J0k3R^
Forumember

Male Posts : 742
Reputation : 28
Language : Greek > English > Russian > Spanish
Location : C:\>r00t

http://fmplanet.forumgreek.com

Back to top Go down

Solved Re: Offline Icon Doesnt Appear

Post by @Mark on May 24th 2014, 11:22 am

Try removing first the previous ones you put on your viewtopic_body, then do it again.
Plus add an online icon on Pics and Management.

@Mark
Forumember

Male Posts : 187
Reputation : 37
Language : HTML | CSS | Javascript | C | Java
Location : Republic of the Philippines

http://help.forumotion.com/

Back to top Go down

Solved Re: Offline Icon Doesnt Appear

Post by J0k3R^ on May 24th 2014, 11:24 am

ive done both of these

J0k3R^
Forumember

Male Posts : 742
Reputation : 28
Language : Greek > English > Russian > Spanish
Location : C:\>r00t

http://fmplanet.forumgreek.com

Back to top Go down

Solved Re: Offline Icon Doesnt Appear

Post by @Mark on May 24th 2014, 11:25 am

I am still seeing the span class offlineicon. Very Happy
Provide me your viewtopic_body.

@Mark
Forumember

Male Posts : 187
Reputation : 37
Language : HTML | CSS | Javascript | C | Java
Location : Republic of the Philippines

http://help.forumotion.com/

Back to top Go down

Solved Re: Offline Icon Doesnt Appear

Post by mioshi11 on May 24th 2014, 11:59 am

@@Mark wrote:Find this on viewtopic_body:
Code:
{postrow.displayed.ONLINE_IMG}

Replace it with this:
Code:
<span class="officon"><img src="http://i71.servimg.com/u/f71/18/17/62/92/offlin10.png" /></span><span class="onicon">{postrow.displayed.ONLINE_IMG}</span>

Now add this to your CSS:
Code:
.officon {
 position: absolute;
 margin-top: 12px;
 margin-left: 5px;
}
.officon img {
 width: 46px;
 height: 15px;
}
.onicon {
margin-left: 5px;
margin-top: -3px;
position: relative;
}
is this working on invision?

mioshi11
Forumember

Male Posts : 153
Reputation : 4
Language : english
Location : Philippines

http://lovefx.forumtl.com

Back to top Go down

Solved Re: Offline Icon Doesnt Appear

Post by J0k3R^ on May 27th 2014, 6:20 pm

BUMPP

J0k3R^
Forumember

Male Posts : 742
Reputation : 28
Language : Greek > English > Russian > Spanish
Location : C:\>r00t

http://fmplanet.forumgreek.com

Back to top Go down

Solved Re: Offline Icon Doesnt Appear

Post by @Mark on May 28th 2014, 9:03 am

Hi Joker, please provide your viewtopic_body.

@Mark
Forumember

Male Posts : 187
Reputation : 37
Language : HTML | CSS | Javascript | C | Java
Location : Republic of the Philippines

http://help.forumotion.com/

Back to top Go down

Solved Re: Offline Icon Doesnt Appear

Post by J0k3R^ on May 28th 2014, 3:22 pm

i sent my viewtopic via pm.
waiting for ur reply Smile

J0k3R^
Forumember

Male Posts : 742
Reputation : 28
Language : Greek > English > Russian > Spanish
Location : C:\>r00t

http://fmplanet.forumgreek.com

Back to top Go down

Solved Re: Offline Icon Doesnt Appear

Post by @Mark on May 28th 2014, 3:34 pm

Find this part:
Code:
<span style="margin-left: 5px; margin-top: -3px;">{postrow.displayed.ONLINE_IMG}</span>

Replace it with this:
Code:
<span class="officon"><img src="http://i71.servimg.com/u/f71/18/17/62/92/offlin10.png" /></span><span class="onicon">{postrow.displayed.ONLINE_IMG}</span>

CSS:
Code:
.officon {
  position: absolute;
}
.officon img {
  width: 46px;
  height: 15px;
  margin-left: 5px;
}
.onicon {
  margin-left: 5px;
  margin-top: -3px;
  position: relative;
}

@Mark
Forumember

Male Posts : 187
Reputation : 37
Language : HTML | CSS | Javascript | C | Java
Location : Republic of the Philippines

http://help.forumotion.com/

Back to top Go down

Solved Re: Offline Icon Doesnt Appear

Post by J0k3R^ on May 28th 2014, 3:41 pm

thank u:wouhou:

Solved

J0k3R^
Forumember

Male Posts : 742
Reputation : 28
Language : Greek > English > Russian > Spanish
Location : C:\>r00t

http://fmplanet.forumgreek.com

Back to top Go down

Solved Re: Offline Icon Doesnt Appear

Post by SLGray on May 28th 2014, 8:04 pm

Problem solved & topic archived.


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 36705
Reputation : 2445
Language : English
Location : United States

http://ztwds.forumotion.com/

Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum