The forum of the forums
Welcome to the Official Support Forum of Forumotion!

To take full advantage of everything offered by our forum, please log in if you are already a member, or join our community if you've not yet.



Create a free forum like this one.

Users being deleted before I can authorise them?

View previous topic View next topic Go down

Solved Users being deleted before I can authorise them?

Post by mkstevo on June 5th 2014, 11:36 pm

Hello.
Recently, I've had a few emails from people signing up the my forum saying that they have been deactivated, almost immediately after signing up to the forum.

I have the new members require authorisation by administrators option turned on, to prevent spammers from signing up and flooding the forum with spam.

The message that the users get is:

> Subject: Your Account has been removed
> From: noreply@forumotion.com
> Date: Thu, 5 Jun 2014 22:22:21 +0200
>
> Hello [user name],
>
> Your account on "renaultwind.motionforum.net" has been removed by a administrator, this is probably due to inactivity on the forum.
>
> If you wish to be an active part of our community again, then please re-register using this link:
> http://renaultwind.motionforum.net/profile.forum?mode=register
>
> --
> (unofficial) Forum For The Renault Wind

If they then attempt to re-sign, they are again deleted, and get the same message for a second time.

This happens within 10-15 minutes of the user signing up. If I am online, and am quick, I can authorise the new user normally, but if I'm not online, their account gets removed.

Have I done something inadvertently that would cause this, or is there a bug in the registration process? I've turned the administrator approval required off for the time being in the hope that it will allow users to sign up again, but I'd like to turn it back on if I could.

mkstevo
New Member

Posts : 21
Reputation : 0
Language : English

Back to top Go down

Solved Re: Users being deleted before I can authorise them?

Post by Derri on June 6th 2014, 1:02 am

Are you the only admin?


Forum Rules: :Forumotion Staff: :Appeal A Warning: :FAQ: :Tips & Tricks: :Forgotten Password/Login Issues
You need one post to send a PM
When your topic has been solved, ensure you mark the topic solved
Never post your email in public


Derri
Administrator
Administrator

Male Posts : 8386
Reputation : 577
Language : English & Basic French
Location : Scotland, United Kingdom

Back to top Go down

Solved Re: Users being deleted before I can authorise them?

Post by mkstevo on June 6th 2014, 9:03 am

We currently have two administrators [with a single shared password].

I have checked the activity of the administrators in the control panel, and cannot see the member deletions that have occurred since this problem became apparent.

We have no moderators.

Here is a clipping from the Actions Panel:
Last actions

Last Updated Username IP Address Action Description
Fri 6 Jun 2014 - 8:04 ****** Member Deleted User tempuser has been deleted
Thu 5 Jun 2014 - 22:15 ****** General configuration updated Data updated
Tue 3 Jun 2014 - 19:06 ****** User updated User N111 has been activated
Tue 3 Jun 2014 - 17:54 ****** User updated User P222 has been activated
Tue 27 May 2014 - 14:58 ****** Member Deleted User XXXX has been deleted
Fri 9 May 2014 - 8:20 ****** User updated User B333 has been activated
Mon 5 May 2014 - 14:06 ****** User updated User o444 has been activated
Mon 5 May 2014 - 14:05 ****** User updated User g555 has been activated
Fri 25 Apr 2014 - 8:20 ****** User updated User n666 has been activated

Both user N111 and P222 had their accounts deleted (twice - they emailed me) before I successfully managed to activate them. In the period from 9th May to 3rd June at least three other members signed up and were presumably unsuccessful but the panel shows no trace of them either. The user that was deleted on 27th May, was deliberately deleted. TempUser was a sign up that I tried yesterday/this morning to see if users were able to sign up correctly with the forum set to allow users to sign up without requiring Administrator authorisation. This worked as expected, so I deleted myself.


Last edited by mkstevo on June 6th 2014, 9:16 am; edited 3 times in total (Reason for editing : Added information.)

mkstevo
New Member

Posts : 21
Reputation : 0
Language : English

Back to top Go down

Solved Re: Users being deleted before I can authorise them?

Post by SLGray on June 6th 2014, 11:45 am

Check here:

Administration Panel > Users & Usergroups > Users > Inactive Users


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 36735
Reputation : 2447
Language : English
Location : United States

http://ztwds.forumotion.com/

Back to top Go down

Solved Re: Users being deleted before I can authorise them?

Post by mkstevo on June 6th 2014, 7:00 pm

@SLGray wrote:Check here:

Administration Panel > Users & Usergroups > Users > Inactive Users

That is how I normally authorise users. Unfortunately, they are being deleted somehow before I have the chance to authorise them, when I look at the inactive users it is empty. And the potential new member has already had an email stating that they have been deleted due to inactivity unless I can authorise them within 2-3 minutes of them signing up.

> Your account on "renaultwind.motionforum.net" has been removed by a administrator, this is probably due to inactivity on the forum.

This is a different message to that received when a user is deleted by an administrator.

>You receive this automatic e-mail because your account on "(unofficial) Forum For The Renault Wind" - http://renaultwind.motionforum.net has been deleted.

Further, you can see the user I deleted in the activity panel (TempUser). The ones that were deleted automatically are not showing in the panel at all. As if they never existed.

mkstevo
New Member

Posts : 21
Reputation : 0
Language : English

Back to top Go down

Solved Re: Users being deleted before I can authorise them?

Post by Derri on June 6th 2014, 7:17 pm

So when you look in the admin panel to see that they've been deleted does it show a username of an admin? Because it could be the other admin you mentioned deleting them.


Forum Rules: :Forumotion Staff: :Appeal A Warning: :FAQ: :Tips & Tricks: :Forgotten Password/Login Issues
You need one post to send a PM
When your topic has been solved, ensure you mark the topic solved
Never post your email in public


Derri
Administrator
Administrator

Male Posts : 8386
Reputation : 577
Language : English & Basic French
Location : Scotland, United Kingdom

Back to top Go down

Solved Re: Users being deleted before I can authorise them?

Post by SLGray on June 6th 2014, 10:37 pm

Did the people in question receive any emails (login information) from the forum?


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 36735
Reputation : 2447
Language : English
Location : United States

http://ztwds.forumotion.com/

Back to top Go down

Solved Re: Users being deleted before I can authorise them?

Post by mkstevo on June 8th 2014, 11:42 am

@Derri wrote:So when you look in the admin panel to see that they've been deleted does it show a username of an admin? Because it could be the other admin you mentioned deleting them.

When I look in the Admin Activity Panel, users that have been refused access to the site before I can authorise them, are not listed at all. They do not show as deleted, banned, nothing. It is as if they never existed. I only know that they have tried to sign up as I have had an email to say that they require my authorisation. By the time I look at the Users > Inactive Users panel they have vanished. Unless I'm very very quick to get there (2-3 minutes after the user attempts to sign up).

@SLGray wrote:Did the people in question receive any emails (login information) from the forum?

The users have definitely had the message stating that they have been 'removed', this is a direct quote from their email they forwarded to me:

> Your account on "renaultwind.motionforum.net" has been removed by a administrator, this is probably due to inactivity on the forum.

I don't know if they had any previous emails. I'll check with them and try to find out. I have certainly had the usual message:

The account owned by "Shuv & Daz" has been deactivated or newly created, you should check the details of this user (if required) and activate it using the following link:

http://renaultwind.motionforum.net/act?u=1&ak=488fa7

The account owned by "Edithmac" has been deactivated or newly created, you should check the details of this user (if required) and activate it using the following link:

http://renaultwind.motionforum.net/act?u=1&ak=5b8cc9

The account owned by "kev" has been deactivated or newly created, you should check the details of this user (if required) and activate it using the following link:

http://renaultwind.motionforum.net/act?u=1&ak=af5859

The account owned by "P" has been deactivated or newly created, you should check the details of this user (if required) and activate it using the following link:

http://renaultwind.motionforum.net/act?u=1&ak=a051cd

The account owned by "P" has been deactivated or newly created, you should check the details of this user (if required) and activate it using the following link:

http://renaultwind.motionforum.net/act?u=1&ak=4f793c

The account owned by "P" has been deactivated or newly created, you should check the details of this user (if required) and activate it using the following link:

http://renaultwind.motionforum.net/act?u=1&ak=c77f61

The account owned by "N" has been deactivated or newly created, you should check the details of this user (if required) and activate it using the following link:

http://renaultwind.motionforum.net/act?u=1&ak=770cf5

The account owned by "D" has been deactivated or newly created, you should check the details of this user (if required) and activate it using the following link:

http://renaultwind.motionforum.net/act?u=1&ak=74dd6f

You can see that user 'P' attempted to sign up twice (and had their account removed before I could authorise it) on the third attempt, I signed them up, and authorised them immediately, giving them access to the site. User 'N' signed up whilst I was online, and I managed to authorise them too immediately. The next user, 'D' attempted to sign up but had their account removed before I could authorise them. This prompted me to change the sign up procedure so that Administrators were not required to authorise new member accounts and 'D' was then able to sign up normally.

The accounts 'Shuv & Daz', 'EdithMac' and 'Kev' all attempted to sign up but by the time I tried to authorise them they had vanished. If I looked in Users > Inactive Users they have disappeared, if I try to authorise them by clicking on the email link, I got the message 'No User with that name exists' [Or something very similar].

The other Admin assures me categorically that they have looked in Users > Inactive Users, and found it empty too. They are adamant they have not deleted them, accidentally or otherwise. As nothing shows up to say other in the Actions Panel I have to believe that they are not deleting the new users, by accident or by design.

mkstevo
New Member

Posts : 21
Reputation : 0
Language : English

Back to top Go down

Solved Re: Users being deleted before I can authorise them?

Post by SLGray on June 8th 2014, 4:02 pm

I will inform the Pro-Admin, Buttercup, about this.


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 36735
Reputation : 2447
Language : English
Location : United States

http://ztwds.forumotion.com/

Back to top Go down

Solved Re: Users being deleted before I can authorise them?

Post by Leviosa on June 9th 2014, 9:26 am

Hello

I have created an account on your forum. Like that I will be able to see what exactly happens.

Please don't activate my account.

Thanks in advance

Buttercup


No help without your forum url
No support via private message



Leviosa
Administrator
Administrator

Female Posts : 15587
Reputation : 1589
Language : French, English

http://help.forumotion.com

Back to top Go down

Solved Re: Users being deleted before I can authorise them?

Post by mkstevo on June 9th 2014, 9:30 am

Buttercup wrote:Hello

I have created an account on your forum. Like that I will be able to see what exactly happens.

Please don't activate my account.

Thanks in advance

Buttercup

At the moment you won't see.

I would need to turn on the 'Administrator Approval Required For New Accounts' option. It is there that the problem seems to occur.
If you sign up now, you will be accepted correctly.

mkstevo
New Member

Posts : 21
Reputation : 0
Language : English

Back to top Go down

Solved Re: Users being deleted before I can authorise them?

Post by SLGray on June 9th 2014, 10:22 am

I have also registered, so we can have two tests.

Something just came to mind. Could the other administrator been sending notifications to inactive members and checked the delete option instead of the inform one?

Administration Panel > Users & Usergroups > User > Handle Users


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 36735
Reputation : 2447
Language : English
Location : United States

http://ztwds.forumotion.com/

Back to top Go down

Solved Re: Users being deleted before I can authorise them?

Post by mkstevo on June 9th 2014, 8:14 pm

@SLGray wrote:I have also registered, so we can have two tests.

Something just came to mind. Could the other administrator been sending notifications to inactive members and checked the delete option instead of the inform one?

Administration Panel > Users & Usergroups > User > Handle Users

You too will currently be accepted without problems. If you want me to set the forum back so that users require administrator authorisation please let me know and I'll post here once I've made the changes.

Regarding the other administrator sending notifications to inactive members, I suppose it is possible, but they are certain they have not done so, and would that not show in the Actions Panel?

mkstevo
New Member

Posts : 21
Reputation : 0
Language : English

Back to top Go down

Solved Re: Users being deleted before I can authorise them?

Post by mkstevo on June 10th 2014, 9:24 am

@SLGray wrote:Did the people in question receive any emails (login information) from the forum?

I've had a reply from one of the members who attempted to sign up twice unsuccessfully. He did get the standard reply:

Code:
Welcome to (unofficial) Forum For The Renault Wind forums

Please keep this e-mail for your savebox. Your account information is as follows:

----------------------------
Username: P
Password: *******
----------------------------

Your account is currently inactive, the administrator of the board will need to activate it before you can log in. You will receive another e-mail when this will be done.

He then got the message that his account had been removed due to inactivity:

Code:
Hello P,

Your account on "renaultwind.motionforum.net" has been removed by a administrator, this is probably due to inactivity on the forum.

If you wish to be an active part of our community again, then please re-register using this link:
http://renaultwind.motionforum.net/profile.forum?mode=register

mkstevo
New Member

Posts : 21
Reputation : 0
Language : English

Back to top Go down

Solved Re: Users being deleted before I can authorise them?

Post by mkstevo on June 10th 2014, 9:29 am

Buttercup wrote:Hello

I have created an account on your forum. Like that I will be able to see what exactly happens.

Please don't activate my account.

Thanks in advance

Buttercup

The forum is now set to require administration approval once more. If you have the time to try to create an account please do so.

mkstevo
New Member

Posts : 21
Reputation : 0
Language : English

Back to top Go down

Solved Re: Users being deleted before I can authorise them?

Post by mkstevo on June 10th 2014, 9:30 am

@SLGray wrote:I have also registered, so we can have two tests.

The forum is now set to require administration approval once more. If you have the time to try to create an account please do so.

mkstevo
New Member

Posts : 21
Reputation : 0
Language : English

Back to top Go down

Solved Re: Users being deleted before I can authorise them?

Post by Leviosa on June 10th 2014, 10:07 am

I just created a new account. @Buttercup


No help without your forum url
No support via private message



Leviosa
Administrator
Administrator

Female Posts : 15587
Reputation : 1589
Language : French, English

http://help.forumotion.com

Back to top Go down

Solved Re: Users being deleted before I can authorise them?

Post by mkstevo on June 10th 2014, 8:23 pm

And I've just authorised you and SLGray.

Before I mark this topic as 'solved' can I give it a week or two, just to be on the safe side?

Perhaps it is simply the act of changing the authorisation required back and forth that settled things down. Thanks for everything so far.

Can I delete you both now?

mkstevo
New Member

Posts : 21
Reputation : 0
Language : English

Back to top Go down

Solved Re: Users being deleted before I can authorise them?

Post by Derri on June 11th 2014, 1:17 am

Hi,

With regards to your request of keeping the topic open for you, the topic will stay open for 7 days without a post and then will be sent to the garbage if not posted in. The reason for this is our auto prune system.

If you keep us updated every few days then there won't be a problem Very Happy


Forum Rules: :Forumotion Staff: :Appeal A Warning: :FAQ: :Tips & Tricks: :Forgotten Password/Login Issues
You need one post to send a PM
When your topic has been solved, ensure you mark the topic solved
Never post your email in public


Derri
Administrator
Administrator

Male Posts : 8386
Reputation : 577
Language : English & Basic French
Location : Scotland, United Kingdom

Back to top Go down

Solved Re: Users being deleted before I can authorise them?

Post by mkstevo on June 16th 2014, 9:19 am

Things seem to be working correctly now.

I'm not sure what caused the glitch, but if I have any more problems, I'll let you know.

Thanks to all who were kind enough to look into this for me. I do appreciate your assistance.

mkstevo
New Member

Posts : 21
Reputation : 0
Language : English

Back to top Go down

Solved Re: Users being deleted before I can authorise them?

Post by SLGray on June 16th 2014, 7:25 pm

Topic Solved & Archived


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 36735
Reputation : 2447
Language : English
Location : United States

http://ztwds.forumotion.com/

Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum