The forum of the forums
Welcome to the Official Support Forum of Forumotion!

To take full advantage of everything offered by our forum, please log in if you are already a member, or join our community if you've not yet.



Create a free forum like this one.

css code won't work

View previous topic View next topic Go down

Solved css code won't work

Post by kieksė on June 12th 2014, 6:20 pm

Hello once more! ^^ So have this code that worked on every other forum but it doesn't work on my new one:
Code:
.name{
font-family: handlee
font-size: 16px;
line-height: 60%;
text-shadow: 1px 1px 1px #000000;!important;
}
@font-face {
font-family: 'Handlee';
font-style: normal;
font-weight: 400;
src: local('Handlee Regular'), local('Handlee-Regular'), url(http://themes.googleusercontent.com/static/fonts/handlee/v3/6AfIXNH5pZ1Jj_pfExPOWQ.woff) format('woff');
}
I mean, if the code worked on other forums, why didn't it work on my new one? At first I though maybe it was a font problem but it wasn't. When I add this code nothing happens at all. Maybe it is because other css are somehow "blocking" this code? Thanks for any help. Embarassed
my forum is phpbb2 secondchance.grayapple.com
my whole css:

.name{
font-family: handlee
font-size: 16px;
line-height: 60%;
text-shadow: 1px 1px 1px #000000;!important;
}

.forumline {
-webkit-border-radius: 46px;
border-radius: 46px;
}
.bodyline {
-webkit-border-radius: 46px;
border-radius: 46px;
}

A:link {text-decoration: none!important;text-transform: uppercase;letter-spacing: 0px;
font-style:italic; font-size: 9px;}
A:active {text-decoration: none!important;}
A:visited {text-decoration: none!important;}
a:hover {text-decoration: none!important;}

a.cattitle {
display:block;
font: 25px georgia;
font-weight: bold;
text-align: center;
text-transform:lowercase;
letter-spacing: 5px;
line-height:55%;
text-shadow: 1px 1px 1px #000000;
}


.bodyline{
background-image: none;
border-right: 10px #111111 solid;
border-left: 10px #111111 solid;
border-top:none;
border-bottom:none;}

a[href="/calendar"]{
display:none;
}

a[href="/faq"]{
display:none;
}

a[href="/groups"]{
display:none;
}

a[href="/search"]{
display:none;
}


.mainmenu:hover {
text-decoration: none;
letter-spacing: 1px; transition-duration: 2s; -moz-transition-duration: 2s; -webkit-transition-duration: 2s;
}

body
{
opacity: 0.8
}

.sceditor-container textarea {
color: #fff !important;
}


@font-face {
font-family: 'Handlee';
font-style: normal;
font-weight: 400;
src: local('Handlee Regular'), local('Handlee-Regular'), url(http://themes.googleusercontent.com/static/fonts/handlee/v3/6AfIXNH5pZ1Jj_pfExPOWQ.woff) format('woff');
}


kieksė
Forumember

Female Posts : 69
Reputation : 1
Language : lithuanian - english - korean - russian

Back to top Go down

Solved Re: css code won't work

Post by SLGray on June 12th 2014, 6:49 pm

Add it to the top of your CSS stylesheet. If that does not work, add !important to the codes.


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 36751
Reputation : 2449
Language : English
Location : United States

http://ztwds.forumotion.com/

Back to top Go down

Solved Re: css code won't work

Post by kieksė on June 12th 2014, 7:08 pm

Did both. Did not work. ;///

kieksė
Forumember

Female Posts : 69
Reputation : 1
Language : lithuanian - english - korean - russian

Back to top Go down

Solved Re: css code won't work

Post by SLGray on June 12th 2014, 7:12 pm

Are all the forums the same version?


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 36751
Reputation : 2449
Language : English
Location : United States

http://ztwds.forumotion.com/

Back to top Go down

Solved Re: css code won't work

Post by Ange Tuteur on June 12th 2014, 9:15 pm

Hello kieksė,

In your first rule you're missing a semi-colon in the font-family declaration.
Code:
font-family: handlee

Should be :
Code:
font-family: handlee;

Ange Tuteur
Forumaster

Male Posts : 13028
Reputation : 2704
Language : EN10, FR5
Location : Pennsylvania

http://fmdesign.forumotion.com

Back to top Go down

Solved Re: css code won't work

Post by kieksė on June 13th 2014, 7:42 am

Yeah, all forums are phpbb2.
Yes, I saw that mistake and I corrected it but still nothing changes. ;//

kieksė
Forumember

Female Posts : 69
Reputation : 1
Language : lithuanian - english - korean - russian

Back to top Go down

Solved Re: css code won't work

Post by Jophy on June 13th 2014, 8:01 am

Hello,

This part seems wrong:

Code:
text-shadow: 1px 1px 1px #000000;!important;

It should be:

Code:
text-shadow: 1px 1px 1px #000000 !important;

Try this code then:

Code:
.name{
font-family: handlee;
 font-size: 16px;
  line-height: 60%;
text-shadow: 1px 1px 1px #000000 !important;
}
@font-face {
  font-family: 'Handlee';
  font-style: normal;
  font-weight: 400;
  src: local('Handlee Regular'), local('Handlee-Regular'), url(http://themes.googleusercontent.com/static/fonts/handlee/v3/6AfIXNH5pZ1Jj_pfExPOWQ.woff) format('woff');
}

Jophy
ForumGuru

Male Posts : 17924
Reputation : 835
Language : English
Location : Somewhere

Back to top Go down

Solved Re: css code won't work

Post by kieksė on June 13th 2014, 8:05 am

Okay, I found a new problem. When I have this code:
Code:

A:link {text-decoration: none!important;text-transform: uppercase;letter-spacing: 0px;
font-style:italic; font-size: 9px;}
A:active {text-decoration: none!important;}
A:visited {text-decoration: none!important;}
a:hover {text-decoration: none!important;}
It just doesn't work because the username is a link. But when I remove this code - it works. So is there a way to have the code above AND make the name code work? ^^

kieksė
Forumember

Female Posts : 69
Reputation : 1
Language : lithuanian - english - korean - russian

Back to top Go down

Solved Re: css code won't work

Post by Ange Tuteur on June 13th 2014, 8:12 am

Place it at the top of the stylesheet and remove the !important keyword.

Code:
A:link {text-decoration: none;text-transform: uppercase;letter-spacing: 0px;
font-style:italic; font-size: 9px;}
A:active {text-decoration: none;}
A:visited {text-decoration: none;}
a:hover {text-decoration: none;}

That should do it.

Ange Tuteur
Forumaster

Male Posts : 13028
Reputation : 2704
Language : EN10, FR5
Location : Pennsylvania

http://fmdesign.forumotion.com

Back to top Go down

Solved Re: css code won't work

Post by kieksė on June 13th 2014, 8:14 am

The username gets small and uppercase and the links have underline when hovered. ://

kieksė
Forumember

Female Posts : 69
Reputation : 1
Language : lithuanian - english - korean - russian

Back to top Go down

Solved Re: css code won't work

Post by Ange Tuteur on June 13th 2014, 8:21 am

Place this anywhere after the link rules.
Code:
.name a {
 text-decoration:none !important;
 text-transform:none;
 font-size:16px;
}

Ange Tuteur
Forumaster

Male Posts : 13028
Reputation : 2704
Language : EN10, FR5
Location : Pennsylvania

http://fmdesign.forumotion.com

Back to top Go down

Solved Re: css code won't work

Post by kieksė on June 13th 2014, 10:59 am

did nothing. :////
EDIT: solved by myself, can be locked. ^^

kieksė
Forumember

Female Posts : 69
Reputation : 1
Language : lithuanian - english - korean - russian

Back to top Go down

Solved Re: css code won't work

Post by SLGray on June 13th 2014, 7:58 pm

Topic Solved & Archived


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 36751
Reputation : 2449
Language : English
Location : United States

http://ztwds.forumotion.com/

Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum