The forum of the forums
Welcome to the Official Support Forum of Forumotion!

To take full advantage of everything offered by our forum, please log in if you are already a member, or join our community if you've not yet.



Create a free forum like this one.

Profile Fields aren't showing

View previous topic View next topic Go down

In progress Profile Fields aren't showing

Post by DK on Mon Jul 14, 2014 6:36 pm

I followed this topic : http://csshelp.forumotion.net/t693-tutorial-show-hide-members-profile-fields-for-all-version
My forum version is PunBB


If I check yes , the tutorial that I followed doesn't appear. But if I check no, it does appear and then I get this unwanted thing at the bottom of my chatbox and I don't want it there.


Here is my index_body
Code:
            {JAVASCRIPT}


                <!-- BEGIN switch_user_logged_out -->


                <div id="pun-visit">


                  <p>{L_NOT_CONNECTED} {L_LOGIN_REGISTER}</p>


                </div>


                <!-- END switch_user_logged_out -->





                <!-- BEGIN message_admin_index -->


                <div class="main">


                  <!-- BEGIN message_admin_titre -->


                  <div class="main-head">


                      <h1 class="page-title">{message_admin_index.message_admin_titre.MES_TITRE}</h1>


                  </div>


                  <!-- END message_admin_titre -->





                  <!-- BEGIN message_admin_txt -->


                  <div id="pun-announcement">


                      <p>{message_admin_index.message_admin_txt.MES_TXT}</p>


                  </div>


                  <!-- END message_admin_txt -->


                </div>


                <!-- END message_admin_index -->





                <!-- BEGIN switch_user_login_form_header -->


                <div class="main">


                <form action="{S_LOGIN_ACTION}" method="post" name="form_login">


                  <div class="user_login_form main-box center">


                      <label><span class="genmed">{L_USERNAME} :</span> <input class="post" type="text" size="10" name="username" /></label>


                      <label><span class="genmed">{L_PASSWORD} :</span> <input class="post" type="password" size="10" name="password" /></label>


                      <label><span class="gensmall">{L_AUTO_LOGIN}</span> <input class="radio" type="checkbox" name="autologin" {AUTOLOGIN_CHECKED} /></label>


                      {S_HIDDEN_FIELDS}<input class="mainoption" type="submit" name="login" value="{L_LOGIN}" />


                      <!-- BEGIN switch_fb_connect -->


                      <span class="fb_or">{switch_user_login_form_header.switch_fb_connect.L_OR}</span>


                      <fb:login-button size="large" onlogin="window.location='/facebook_connect.forum'" v="2" scope="{switch_user_login_form_header.switch_fb_connect.L_FB_PERMISSIONS}">{switch_user_login_form_header.switch_fb_connect.L_FB_LOGIN_BUTTON}</fb:login-button>


                      <!-- END switch_fb_connect -->


                  </div>


                </form>


                </div>


                <!-- END switch_user_login_form_header -->





                {CHATBOX_TOP}


                {BOARD_INDEX}





                <!-- BEGIN disable_viewonline -->


                <div id="pun-info" class="main">


                  <div class="main-content">


                      <div id="stats">


                        <p class="right">{TOTAL_POSTS}</p>


                        <p>{TOTAL_USERS}</p>


                        <p>{NEWEST_USER}</p>


                      </div>


                      <div id="onlinelist">


                        <img src="{L_ONLINE_IMG}" alt="{L_WHO_IS_ONLINE}" />


                        <p class="right">


                            <!-- BEGIN switch_viewonline_link -->


                            <a href="{U_VIEWONLINE}" rel="nofollow">{L_WHO_IS_ONLINE}</a>


                            <!-- END switch_viewonline_link -->


                            <!-- BEGIN switch_viewonline_nolink -->


                            {L_WHO_IS_ONLINE}


                            <!-- END switch_viewonline_nolink -->


                        </p>


                        <p>{TOTAL_USERS_ONLINE}<br />


                        {RECORD_USERS}





                        <br />


                        {LOGGED_IN_USER_LIST}





                        {L_ONLINE_USERS}


                        {L_CONNECTED_MEMBERS}<br />


                        {L_WHOSBIRTHDAY_TODAY}{L_WHOSBIRTHDAY_WEEK}</p>


                        <div class="clear"></div>





                        <p>{LEGEND} : {GROUP_LEGEND}</p>





                      </div>


                      <!-- BEGIN switch_chatbox_activate -->


                      <div id="onlinechat">


                        <p class="page-bottom">


                        {TOTAL_CHATTERS_ONLINE} :


                        {CHATTERS_LIST}<br />


                        <!-- BEGIN switch_chatbox_popup -->


                            <div id="chatbox_popup"></div>


                            <script type="text/javascript">


                              insertChatBoxPopup('{disable_viewonline.switch_chatbox_activate.switch_chatbox_popup.U_FRAME_CHATBOX}', '{L_CLICK_TO_JOIN_CHAT}');


                            </script>


                        <!-- END switch_chatbox_popup -->


                        </p>


                      </div>


                      <!-- END switch_chatbox_activate -->


                  </div>


                </div>


                <!-- END disable_viewonline -->





                <!-- BEGIN switch_user_login_form_footer -->


                <form action="{S_LOGIN_ACTION}" method="post" name="form_login">


                  <div class="user_login_form main-box center">


                      <label><span class="genmed">{L_USERNAME} :</span> <input class="post" type="text" size="10" name="username"/></label>


                      <label><span class="genmed">{L_PASSWORD} :</span> <input class="post" type="password" size="10" name="password"/></label>


                      <label><span class="gensmall">{L_AUTO_LOGIN}</span> <input class="radio" type="checkbox" name="autologin" {AUTOLOGIN_CHECKED} /></label>


                      {S_HIDDEN_FIELDS}<input class="mainoption" type="submit" name="login" value="{L_LOGIN}" />


                      <!-- BEGIN switch_fb_connect -->


                      <span class="genmed fb_or">{switch_user_login_form_footer.switch_fb_connect.L_OR}</span>


                      <fb:login-button size="large" onlogin="window.location='/facebook_connect.forum'" v="2" scope="{switch_user_login_form_footer.switch_fb_connect.L_FB_PERMISSIONS}">{switch_user_login_form_footer.switch_fb_connect.L_FB_LOGIN_BUTTON}</fb:login-button>


                      <!-- END switch_fb_connect -->


                  </div>


                </form>


                <!-- END switch_user_login_form_footer -->





                {CHATBOX_BOTTOM}





                <!-- BEGIN switch_legend -->


                <ul id="pun-legend">


                  <li>


                      <img src="{FORUM_NEW_IMG}" alt="{L_NEW_POSTS}" /> {L_NEW_POSTS}


                      <img src="{FORUM_IMG}" alt="{L_NO_NEW_POSTS}" /> {L_NO_NEW_POSTS}


                      <img src="{FORUM_LOCKED_IMG}" alt="{L_FORUM_LOCKED}" /> {L_FORUM_LOCKED}


                  </li>


                </ul>


                <!-- END switch_legend -->





                {AUTO_DST}





                <!-- BEGIN switch_fb_index_login -->


                <div id="fb-root"></div>


                <script type="text/javascript">


                //<![CDATA[
                FB.init({
                  appId: '{switch_fb_index_login.FACEBOOK_APP_ID}',
                    status: true,
                    cookie: true,
                    xfbml: true,
                  oauth: true
                });
                //]]>


                </script>


                <!-- END switch_fb_index_login -->


                <div id="stats">


                <img src="{L_ONLINE_IMG}" alt="{L_WHO_IS_ONLINE}" />


                <p>


                <!-- BEGIN switch_viewonline_link -->


                <a href="{U_VIEWONLINE}" rel="nofollow"></a>


                <!-- END switch_viewonline_link -->


                <!-- BEGIN switch_viewonline_nolink -->


                {L_WHO_IS_ONLINE}


                <!-- END switch_viewonline_nolink --></p>


                <p>{TOTAL_USERS_ONLINE}<br />


                {RECORD_USERS}


                <br />


                {LOGGED_IN_USER_LIST}


                {L_ONLINE_USERS}


                {L_CONNECTED_MEMBERS}<br />


                <div class="clear"></div>


                      <p><p>{L_WHOSBIRTHDAY_TODAY}</p>


                        <p>{L_WHOSBIRTHDAY_WEEK}</p></p>


                <p>{LEGEND} : {GROUP_LEGEND}</p>
Please help me.

DK
Forumember

Male Posts : 609
Reputation : 13
Language : English

http://ourworldhub.forumotion.com/forum

Back to top Go down

In progress Re: Profile Fields aren't showing

Post by SLGray on Mon Jul 14, 2014 6:41 pm

Post the modified template.


Last edited by SLGray on Mon Jul 14, 2014 6:52 pm; edited 1 time in total


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 36616
Reputation : 2439
Language : English
Location : United States

http://ztwds.forumotion.com/

Back to top Go down

In progress Re: Profile Fields aren't showing

Post by DK on Mon Jul 14, 2014 6:45 pm

@SLGray wrote:Post the modified template.

I did, I edited my post and posted my index_body

DK
Forumember

Male Posts : 609
Reputation : 13
Language : English

http://ourworldhub.forumotion.com/forum

Back to top Go down

In progress Re: Profile Fields aren't showing

Post by SLGray on Mon Jul 14, 2014 6:52 pm

Do this: copy and paste the template in Notepad or whatever you use. Then delete the modified template. Then try the tutorial again.


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 36616
Reputation : 2439
Language : English
Location : United States

http://ztwds.forumotion.com/

Back to top Go down

In progress Re: Profile Fields aren't showing

Post by DK on Mon Jul 14, 2014 7:10 pm

@SLGray wrote:Do this: copy and paste the template in Notepad or whatever you use. Then delete the modified template. Then try the tutorial again.

Alright that's what I did. Here is my new index_body
Code:
                {JAVASCRIPT}


                    <!-- BEGIN switch_user_logged_out -->


                    <div id="pun-visit">


                      <p>{L_NOT_CONNECTED} {L_LOGIN_REGISTER}</p>


                    </div>


                    <!-- END switch_user_logged_out -->





                    <!-- BEGIN message_admin_index -->


                    <div class="main">


                      <!-- BEGIN message_admin_titre -->


                      <div class="main-head">


                          <h1 class="page-title">{message_admin_index.message_admin_titre.MES_TITRE}</h1>


                      </div>


                      <!-- END message_admin_titre -->





                      <!-- BEGIN message_admin_txt -->


                      <div id="pun-announcement">


                          <p>{message_admin_index.message_admin_txt.MES_TXT}</p>


                      </div>


                      <!-- END message_admin_txt -->


                    </div>


                    <!-- END message_admin_index -->





                    <!-- BEGIN switch_user_login_form_header -->


                    <div class="main">


                    <form action="{S_LOGIN_ACTION}" method="post" name="form_login">


                      <div class="user_login_form main-box center">


                          <label><span class="genmed">{L_USERNAME} :</span> <input class="post" type="text" size="10" name="username" /></label>


                          <label><span class="genmed">{L_PASSWORD} :</span> <input class="post" type="password" size="10" name="password" /></label>


                          <label><span class="gensmall">{L_AUTO_LOGIN}</span> <input class="radio" type="checkbox" name="autologin" {AUTOLOGIN_CHECKED} /></label>


                          {S_HIDDEN_FIELDS}<input class="mainoption" type="submit" name="login" value="{L_LOGIN}" />


                          <!-- BEGIN switch_fb_connect -->


                          <span class="fb_or">{switch_user_login_form_header.switch_fb_connect.L_OR}</span>


                          <fb:login-button size="large" onlogin="window.location='/facebook_connect.forum'" v="2" scope="{switch_user_login_form_header.switch_fb_connect.L_FB_PERMISSIONS}">{switch_user_login_form_header.switch_fb_connect.L_FB_LOGIN_BUTTON}</fb:login-button>


                          <!-- END switch_fb_connect -->


                      </div>


                    </form>


                    </div>


                    <!-- END switch_user_login_form_header -->





                    {CHATBOX_TOP}


                    {BOARD_INDEX}





                    <!-- BEGIN disable_viewonline -->


                    <div id="pun-info" class="main">


                      <div class="main-content">


                          <div id="stats">


                            <p class="right">{TOTAL_POSTS}</p>


                            <p>{TOTAL_USERS}</p>


                            <p>{NEWEST_USER}</p>


                          </div>


                          <div id="onlinelist">


                            <img src="{L_ONLINE_IMG}" alt="{L_WHO_IS_ONLINE}" />


                            <p class="right">


                                <!-- BEGIN switch_viewonline_link -->


                                <a href="{U_VIEWONLINE}" rel="nofollow">{L_WHO_IS_ONLINE}</a>


                                <!-- END switch_viewonline_link -->


                                <!-- BEGIN switch_viewonline_nolink -->


                                {L_WHO_IS_ONLINE}


                                <!-- END switch_viewonline_nolink -->


                            </p>


                            <p>{TOTAL_USERS_ONLINE}<br />


                            {RECORD_USERS}





                            <br />


                            {LOGGED_IN_USER_LIST}





                            {L_ONLINE_USERS}


                            {L_CONNECTED_MEMBERS}<br />


                            {L_WHOSBIRTHDAY_TODAY}{L_WHOSBIRTHDAY_WEEK}</p>


                            <div class="clear"></div>





                            <p>{LEGEND} : {GROUP_LEGEND}</p>





                          </div>


                          <!-- BEGIN switch_chatbox_activate -->


                          <div id="onlinechat">


                            <p class="page-bottom">


                            {TOTAL_CHATTERS_ONLINE} :


                            {CHATTERS_LIST}<br />


                            <!-- BEGIN switch_chatbox_popup -->


                                <div id="chatbox_popup"></div>


                                <script type="text/javascript">


                                  insertChatBoxPopup('{disable_viewonline.switch_chatbox_activate.switch_chatbox_popup.U_FRAME_CHATBOX}', '{L_CLICK_TO_JOIN_CHAT}');


                                </script>


                            <!-- END switch_chatbox_popup -->


                            </p>


                          </div>


                          <!-- END switch_chatbox_activate -->


                      </div>


                    </div>


                    <!-- END disable_viewonline -->





                    <!-- BEGIN switch_user_login_form_footer -->


                    <form action="{S_LOGIN_ACTION}" method="post" name="form_login">


                      <div class="user_login_form main-box center">


                          <label><span class="genmed">{L_USERNAME} :</span> <input class="post" type="text" size="10" name="username"/></label>


                          <label><span class="genmed">{L_PASSWORD} :</span> <input class="post" type="password" size="10" name="password"/></label>


                          <label><span class="gensmall">{L_AUTO_LOGIN}</span> <input class="radio" type="checkbox" name="autologin" {AUTOLOGIN_CHECKED} /></label>


                          {S_HIDDEN_FIELDS}<input class="mainoption" type="submit" name="login" value="{L_LOGIN}" />


                          <!-- BEGIN switch_fb_connect -->


                          <span class="genmed fb_or">{switch_user_login_form_footer.switch_fb_connect.L_OR}</span>


                          <fb:login-button size="large" onlogin="window.location='/facebook_connect.forum'" v="2" scope="{switch_user_login_form_footer.switch_fb_connect.L_FB_PERMISSIONS}">{switch_user_login_form_footer.switch_fb_connect.L_FB_LOGIN_BUTTON}</fb:login-button>


                          <!-- END switch_fb_connect -->


                      </div>


                    </form>


                    <!-- END switch_user_login_form_footer -->





                    {CHATBOX_BOTTOM}





                    <!-- BEGIN switch_legend -->


                    <ul id="pun-legend">


                      <li>


                          <img src="{FORUM_NEW_IMG}" alt="{L_NEW_POSTS}" /> {L_NEW_POSTS}


                          <img src="{FORUM_IMG}" alt="{L_NO_NEW_POSTS}" /> {L_NO_NEW_POSTS}


                          <img src="{FORUM_LOCKED_IMG}" alt="{L_FORUM_LOCKED}" /> {L_FORUM_LOCKED}


                      </li>


                    </ul>


                    <!-- END switch_legend -->





                    {AUTO_DST}





                    <!-- BEGIN switch_fb_index_login -->


                    <div id="fb-root"></div>


                    <script type="text/javascript">


                    //<![CDATA[
                    FB.init({
                      appId: '{switch_fb_index_login.FACEBOOK_APP_ID}',
                        status: true,
                        cookie: true,
                        xfbml: true,
                      oauth: true
                    });
                    //]]>


                    </script>


                    <!-- END switch_fb_index_login -->
fdsssss
But now the avatars are missing if I check No for " Force the default Templates "

DK
Forumember

Male Posts : 609
Reputation : 13
Language : English

http://ourworldhub.forumotion.com/forum

Back to top Go down

In progress Re: Profile Fields aren't showing

Post by SLGray on Mon Jul 14, 2014 7:20 pm

Do you have the option activated?


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 36616
Reputation : 2439
Language : English
Location : United States

http://ztwds.forumotion.com/

Back to top Go down

In progress Re: Profile Fields aren't showing

Post by DK on Mon Jul 14, 2014 7:43 pm

@SLGray wrote:Do you have the option activated?

yes it is

DK
Forumember

Male Posts : 609
Reputation : 13
Language : English

http://ourworldhub.forumotion.com/forum

Back to top Go down

In progress Re: Profile Fields aren't showing

Post by SLGray on Mon Jul 14, 2014 7:47 pm

Please send me a test account again.


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 36616
Reputation : 2439
Language : English
Location : United States

http://ztwds.forumotion.com/

Back to top Go down

In progress Re: Profile Fields aren't showing

Post by DK on Mon Jul 14, 2014 8:10 pm

@SLGray wrote:Please send me a test account again.

I fixed it. I just uninstalled the previous avatar on index codes that I had and reinstalled this code http://help.forumotion.com/t132473-avatar-of-who-last-posted-on-the-index#889883

DK
Forumember

Male Posts : 609
Reputation : 13
Language : English

http://ourworldhub.forumotion.com/forum

Back to top Go down

In progress Re: Profile Fields aren't showing

Post by SLGray on Mon Jul 14, 2014 8:15 pm

You do know that you do not need a code for that it.


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 36616
Reputation : 2439
Language : English
Location : United States

http://ztwds.forumotion.com/

Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum