The forum of the forums
Welcome to the Official Support Forum of Forumotion!

To take full advantage of everything offered by our forum, please log in if you are already a member, or join our community if you've not yet.



Create a free forum like this one.

Name Color Not Working

Page 1 of 2 1, 2  Next

View previous topic View next topic Go down

In progress Name Color Not Working

Post by SpyroDragon on May 23rd 2015, 9:21 pm

Yea , i had added ///// to my CSS sheet, then it had screwd up my name colors , i removed the //// and changed the css sheet the way it was, but the name color has disapeerd, can somebody tell me where i have screwed up ?


I have this for my name color via JavaScript
Code:
$(function(){
multiColor(1, '<strong><font color="#ffffff">Sp</font><font color="#00ffff">yr</font><font color="#666666">o</font><font color="#00ffff"> ▀█▀ </font><font color="#ffffff">Dr</font><font color="#00ffff">ag</font><font color="#666666">on</font></strong>');

function multiColor(id, html){$('a[href="/u'+id+'"] strong').not(function(){return $("img",this)[0]}).html(html)}
});


Then i have this as my CSS sheet... obviously there is an error somewhere


Code:
#sceditor_smilies {
background-color: transparent; !important
}
#sce_smilies_body, .smiley-element {
background: transparent !important;
#sce_smilies_body, .smiley-element {
background: transparent !important;
position: fixed !important:
}
#sceditor_smilies body { overflow:hidden }
body{
background-attachment:fixed;
background-color:;
}
ul#picture_legend, ul#privmsgs-menu {
text-align: center;
display: none;
}
ul#picture_legend li, ul#privmsgs-menu li {
display: inline;
margin: 2px 10px;
display: none;
}
ul#picture_legend li img, ul#privmsgs-menu li img {
vertical-align: middle;
display: none;
}
#profile-advanced-details div.separator {
border-bottom: 0px solid #DCDCDC;

td.catHead, th.thHead {
border-width: 0px;
}
td.catHead, th.thHead { border-width:0 !important }

td.catBottom, th.thBottom {
border-width: 0px;
}

.sceditor-container {
background:none !important;
border:none !important;
width:450px !important;
height:275px !important;
margin:80px !important;
}
#profile-advanced-details dl dt { width:auto; }
#profile-advanced-details dl dd { padding:0; margin-left:40px; }
#info_open, #info_close { display:none; }
td.hr, .post td table td .postdetails { display:none; }
#profile-advanced-details dl dt { font-size:0; }
.sceditor-container {
background:none !important;
border:none !important;
width:450px !important;
height:275px !important;
margin:80px !important;
}
.sceditor-toolbar {
background:none !important;
border:none !important;
}
.sceditor-container textarea {
color:#2C97C3 !important;
font-weight:bold !important;
}
.sceditor-container:before {
content:url([url=http://i39.servimg.com/u/f39/18/21/60/73/left10.png]http://i39.servimg.com/u/f39/18/21/60/73/left10.png[/url]);
position:absolute;
top:-85px;
left:-80px;
z-index:-1;
}
.sceditor-container:after {
content:url([url=http://i39.servimg.com/u/f39/18/21/60/73/right10.png]http://i39.servimg.com/u/f39/18/21/60/73/right10.png[/url]);
position:absolute;
right:-80px;
bottom:-85px;
z-index:-1;
}
input.liteoption, input.mainoption {
background:url([url=http://i38.servimg.com/u/f38/17/84/98/50/better10.gif]http://i38.servimg.com/u/f38/17/84/98/50/better10.gif[/url]) no-repeat center;
border:none;
padding:0;
height:30px;
width:98px;
position:relative;
z-index:4;
cursor:pointer;
}
input.post {
background:url([url=http://i39.servimg.com/u/f39/17/84/98/50/better13.png]http://i39.servimg.com/u/f39/17/84/98/50/better13.png[/url]) repeat-x center;
padding:3px;
height:24px;
}

.sceditor-container textarea { overflow:hidden }
input.post[name="subject"] { border:none }
#pollitems, #pollitems_show, form[name="post"] + table[width="100%"] + table.forumline[width="100%"] { display:none }
form[name="post"] td.row1 b { display:none }
form[name="post"] .forumline th.thHead strong, form[action="/privmsg"] select, form[action="/privmsg"] #add_username { display:none }
input, select, textarea {
border-width: 0px;
}
div.sceditor-dropdown {
background: transparent!important;
}



div.sceditor-container iframe, div.sceditor-container textarea { background:transparent }
.postbg { background-position:0 0; background-repeat:repeat; }


#profile-advanced-details div.separator { display:none !important }
#profile-advanced-details dl { display:inline }
#profile-advanced-details dl#field_id8 { display:block }
#profile-advanced-details dl dd, #profile-advanced-details .field_uneditable { display:inline }
#profile-advanced-details dl dt { float:none; display:inline }
#profile-advanced-details dl dd { margin-left:5px }
#profile-advanced-details { white-space:pre-wrap }
.forumline { border-spacing:0 }
th.thLeft, .thRight {
border: none !important;
font-size: 0;
}


.forumline .row1.over { position:relative }
.forumline .row1.over .hierarchy {
position:absolute;
top:20px;
}
.post .postdetails.poster-profile > a img {
max-width:0px;
max-height:0px;
}
.post .postdetails.poster-profile > a {
display:inline-block;
background:url([url=http://i38.servimg.com/u/f38/16/87/57/90/modsqu10.png]http://i38.servimg.com/u/f38/16/87/57/90/modsqu10.png[/url]) no-repeat 50% 50% / 100% 100%;
padding:55x;
}
td.catLeft, th.thLeft {
border-width: 0px 0px 0px 0px;
}

SpyroDragon
Forumember

Posts : 277
Reputation : 2
Language : English

http://SpyroDragon.com/

Back to top Go down

In progress Re: Name Color Not Working

Post by SLGray on May 23rd 2015, 9:26 pm

I do not see any CSS code for usernames?

Is this only for your username?


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 35641
Reputation : 2374
Language : English
Location : United States

http://fmthemes.forumotion.com/

Back to top Go down

In progress Re: Name Color Not Working

Post by SpyroDragon on May 23rd 2015, 9:38 pm

I have separate javascripts for each username..

Heres one for one member
Code:
$(function(){
multiColor(130, '<strong><font color="#0bfeb2">ᴛᴡɪʟɪ</font><font color="#242424"> ▀█▀ </font><font color="#0bfeb2">ᴅʀᴀɢᴏɴ</font></strong>');

function multiColor(id, html){$('a[href="/u'+id+'"] strong').not(function(){return $("img",this)[0]}).html(html)}
});


Here is one for another member

Code:


$(function(){
multiColor(268, '<strong><font color="#ffffff">Sp</font><font color="#ffff00">ar</font><font color="#666666">x</font><font color="#ffff00"> ▀█▀ </font><font color="#ffffff">Dr</font><font color="#ffff00">ag</font><font color="#666666">on</font><font color="#fffff>Unicorn 8 year old</font></strong>');

function multiColor(id, html){$('a[href="/u'+id+'"] strong').not(function(){return $("img",this)[0]}).html(html)}
});


And they are all marked " In all pages "

SpyroDragon
Forumember

Posts : 277
Reputation : 2
Language : English

http://SpyroDragon.com/

Back to top Go down

In progress Re: Name Color Not Working

Post by SLGray on May 23rd 2015, 9:42 pm

Try this: turn off JavaScript Management and turn it back on again.


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 35641
Reputation : 2374
Language : English
Location : United States

http://fmthemes.forumotion.com/

Back to top Go down

In progress Re: Name Color Not Working

Post by SpyroDragon on May 23rd 2015, 9:44 pm

I turned it off, refreshed page... Turned it on.. Refreshed page... Still not working

SpyroDragon
Forumember

Posts : 277
Reputation : 2
Language : English

http://SpyroDragon.com/

Back to top Go down

In progress Re: Name Color Not Working

Post by SLGray on May 23rd 2015, 9:49 pm

So this stopped working when you edited the CSS stylesheet?


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 35641
Reputation : 2374
Language : English
Location : United States

http://fmthemes.forumotion.com/

Back to top Go down

In progress Re: Name Color Not Working

Post by SpyroDragon on May 23rd 2015, 9:53 pm

yes, i was trying to organize it by putting them in categories like ////////// Backgrounds //////

then i saved , and it went to You have invalid { and } code we advise you to check back and rewview your sheet or something like that, so i had deleted the /////// backgrounds //// and put it back the way it was, and when i clicked save it was still having the same error You have invalid { and } code we advise you to check back and rewview your sheet so i clicked Disable optimize CSS , saved , then optimize css, saved and the error went away, but now My name color had stopped working, I have a Double posting Java Script thing were it puts double posts together which is working fine, so its just the name color that is having issues.


The Doublepost javascript is

Code:
$(function() {
var c = "", a, d = 0, b = 0;
$("tr.post").each(function() {
var e = $("> td:first span.name", this).text();
e != c ? (d++, b++, a = $(this), b % 2 != d % 2 && $("> td", a).add($("> td", a.next())).toggleClass("row1 row2"), c = e) : (b++, $(a).find("div.signature_div").remove(), $("> td:last", a).append($("> td:last > table ", this).addClass("doublepost").attr("id", $(this).attr("id").replace(/^p([0-9]+)$/, "$1"))), $(this).next().remove(), $(this).remove())
});
var f = location.hash;
location.hash = "";
location.hash = f
});



Which works fine, which tells me the javascript management is working, unless ?


Last edited by SpyroDragon on May 23rd 2015, 9:55 pm; edited 1 time in total

SpyroDragon
Forumember

Posts : 277
Reputation : 2
Language : English

http://SpyroDragon.com/

Back to top Go down

In progress Re: Name Color Not Working

Post by brandon_g on May 23rd 2015, 9:54 pm

Hello,

What exactly do you mean by ///?

Do you mean /*...*/ if so that is called a comment, it makes a line of code invisible to the web browser. It should not affect a code enough to break it though.

-Brandon

Edit: Yes thats probably what you mean is a comment. You didn't add an artisk. Which is why it showed invalid.

It should be ///* Category *\\\


Last edited by brandon_g on May 23rd 2015, 9:57 pm; edited 1 time in total


Remember to mark your topic when a solution is found.

brandon_g
Support Moderator
Support Moderator

Male Posts : 5140
Reputation : 478
Language : English
Location : USA

http://broadcastingduo.forumotion.com/

Back to top Go down

In progress Re: Name Color Not Working

Post by SpyroDragon on May 23rd 2015, 9:57 pm

i had put exactly this " ////// Custom Backgrounds ////// "

in an attempt to organize some of the codes -- i have no background codes, but i was going to add some later.

SpyroDragon
Forumember

Posts : 277
Reputation : 2
Language : English

http://SpyroDragon.com/

Back to top Go down

In progress Re: Name Color Not Working

Post by SLGray on May 23rd 2015, 9:58 pm

You are missing a lot of closing brackets. Also some lines do not have sime-colons. Also I seen some where the semi-colons are in the wrong place. You also use : instead of a semi-colon.


Last edited by SLGray on May 23rd 2015, 9:59 pm; edited 1 time in total


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 35641
Reputation : 2374
Language : English
Location : United States

http://fmthemes.forumotion.com/

Back to top Go down

In progress Re: Name Color Not Working

Post by brandon_g on May 23rd 2015, 9:59 pm

@brandon_g wrote:Hello,

What exactly do you mean by ///?

Do you mean /*...*/ if so that is called a comment, it makes a line of code invisible to the web browser. It should not affect a code enough to break it though.

-Brandon

Edit: Yes thats probably what you mean is a comment. You didn't add an artisk. Which is why it showed invalid.

It should be ///* Category *\\\

Edited... Try the above in your code. That should work. Wink

-Brandon


Remember to mark your topic when a solution is found.

brandon_g
Support Moderator
Support Moderator

Male Posts : 5140
Reputation : 478
Language : English
Location : USA

http://broadcastingduo.forumotion.com/

Back to top Go down

In progress Re: Name Color Not Working

Post by SpyroDragon on May 23rd 2015, 10:00 pm

@SLGrey - where am i missing the closed brakkets and etc?

SpyroDragon
Forumember

Posts : 277
Reputation : 2
Language : English

http://SpyroDragon.com/

Back to top Go down

In progress Re: Name Color Not Working

Post by SLGray on May 23rd 2015, 10:02 pm

Here is one example:

Code:
#sce_smilies_body, .smiley-element {
background: transparent !important;
Exactly you have it twice.


Last edited by SLGray on May 23rd 2015, 10:03 pm; edited 1 time in total


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 35641
Reputation : 2374
Language : English
Location : United States

http://fmthemes.forumotion.com/

Back to top Go down

In progress Re: Name Color Not Working

Post by SpyroDragon on May 23rd 2015, 10:02 pm

Is there any thing else that might of caused the name color break down?
and im not sure how to fix these codes , because they were all copy n pasted

SpyroDragon
Forumember

Posts : 277
Reputation : 2
Language : English

http://SpyroDragon.com/

Back to top Go down

In progress Re: Name Color Not Working

Post by SLGray on May 23rd 2015, 10:08 pm

There are many issues with your CSS stylesheet. You will need to go through each line.

Issues I saw:
No closing brackets
Using : instead of ;
Using () not {}
Semi-colons in the wrong place

There could be more.


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 35641
Reputation : 2374
Language : English
Location : United States

http://fmthemes.forumotion.com/

Back to top Go down

In progress Re: Name Color Not Working

Post by SpyroDragon on May 23rd 2015, 10:10 pm

I wouldent be able to do this, because i would have no idea where any of the closed brackets go
or what to replace with what, if someone could do this for me, would be greatly appericiated, although i see all those codes working , except the broken name color.. No offense but i believe all these codes in the stylesheet are working properly, only thing that is wrong is the name color broke just cause i added //// backgrounds //// to it.

SpyroDragon
Forumember

Posts : 277
Reputation : 2
Language : English

http://SpyroDragon.com/

Back to top Go down

In progress Re: Name Color Not Working

Post by brandon_g on May 23rd 2015, 10:14 pm

Ok... Here is what you should do.... Remove the code... Re copy and paste it.


When you break it into categories use ///* Category here \\\* instead of what you had.

brandon_g
Support Moderator
Support Moderator

Male Posts : 5140
Reputation : 478
Language : English
Location : USA

http://broadcastingduo.forumotion.com/

Back to top Go down

In progress Re: Name Color Not Working

Post by SpyroDragon on May 23rd 2015, 10:16 pm

Brandon_g can you please re-read the problem, because your trying to help me with a problem im not having making you seem random, please help with the correct problem or please just let other people help thanks

SpyroDragon
Forumember

Posts : 277
Reputation : 2
Language : English

http://SpyroDragon.com/

Back to top Go down

In progress Re: Name Color Not Working

Post by SLGray on May 23rd 2015, 10:18 pm

They might be working, but there are many issues with it.

Try this for the usernames: Redo the JavaScripts.


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 35641
Reputation : 2374
Language : English
Location : United States

http://fmthemes.forumotion.com/

Back to top Go down

In progress Re: Name Color Not Working

Post by SpyroDragon on May 23rd 2015, 10:22 pm

This is also not working as well

This is mindblowing for me to, how a simple /// backgrounds // can shut off my name color like that.. when i have no name color codes at all on my css sytlesheet , that's just weird, one thing for certain is that i need my name color back asap because i had the name color as an item in my " Crystal Store "

SpyroDragon
Forumember

Posts : 277
Reputation : 2
Language : English

http://SpyroDragon.com/

Back to top Go down

In progress Re: Name Color Not Working

Post by SLGray on May 23rd 2015, 10:30 pm

I believe you should only use one / at the start and one at the end.

Example:
Code:
/*IF YOU EDIT FORUM WIDTH, BETTER CHANGE THE VALUE "900px WITH THE NEW WIDTH"*/


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 35641
Reputation : 2374
Language : English
Location : United States

http://fmthemes.forumotion.com/

Back to top Go down

In progress Re: Name Color Not Working

Post by SpyroDragon on May 23rd 2015, 10:32 pm

well, that's not my problem now, i need to fix the name color, i don't kno where the issue is that's keeping javascript from changing my members name color the way it was, this is getting fusterating to a point i want to throw my mouse threw the window and on purposely destroy the glass along with it.

SpyroDragon
Forumember

Posts : 277
Reputation : 2
Language : English

http://SpyroDragon.com/

Back to top Go down

In progress Re: Name Color Not Working

Post by SLGray on May 23rd 2015, 10:38 pm

Are you sure that they were working before you edited the CSS?


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 35641
Reputation : 2374
Language : English
Location : United States

http://fmthemes.forumotion.com/

Back to top Go down

In progress Re: Name Color Not Working

Post by SpyroDragon on May 23rd 2015, 10:40 pm

yes, i had absolutely no problem with the name color until i had added and removed " ///// custom backgrounds ///// " from my style sheet, which makes absoultly no sense what so ever.

SpyroDragon
Forumember

Posts : 277
Reputation : 2
Language : English

http://SpyroDragon.com/

Back to top Go down

In progress Re: Name Color Not Working

Post by SLGray on May 23rd 2015, 10:41 pm

Could you have deleted more CSS by accident?


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 35641
Reputation : 2374
Language : English
Location : United States

http://fmthemes.forumotion.com/

Back to top Go down

In progress Re: Name Color Not Working

Post by SpyroDragon on May 23rd 2015, 10:50 pm

i remember the smilies being at the very top, so im 99% sure, unless i might have deleted an extra space or a slot , but i kno those are the only codes i had

SpyroDragon
Forumember

Posts : 277
Reputation : 2
Language : English

http://SpyroDragon.com/

Back to top Go down

In progress Re: Name Color Not Working

Post by brandon_g on May 23rd 2015, 10:54 pm

@SpyroDragon wrote:Brandon_g can you please re-read the problem, because your trying to help me with a problem im not having making you seem random, please help with the correct problem or please just let other people help thanks


I have read the problem. Now from what I can gather you were trying to seperate it into sections when the code broke. You removed the slashes and the code was broken. You may have removed a little bit more code by mistake.

So since we do not know where you copied and pasted the codes from, I am telling you, you should remove what is currently there and re copy and paste the code back in. That way it is the way it was before the slashes were even put in.

The other part of my post addresses how you can correctly seperate it into sections once the code has been re copied back in.

Slashes (///) by itself is NOT a valid css input... Hence why it said invalid.

The way I showed you with ///* ... \\\* IS valid and should give you the desired result that you were trying to accomplish before with the INVALID ///.

So yes I was helping you with your problem.

Have a nice day, hope the above helps, if you don't read it or try it then thats on you, but I tried helping you. Just don't say that I didn't read your topic before trying.


-Brandon


Remember to mark your topic when a solution is found.

brandon_g
Support Moderator
Support Moderator

Male Posts : 5140
Reputation : 478
Language : English
Location : USA

http://broadcastingduo.forumotion.com/

Back to top Go down

In progress Re: Name Color Not Working

Post by SLGray on May 23rd 2015, 10:59 pm

After reading your pm. it would be best to wait until @Ange Tuteur read this topic.


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 35641
Reputation : 2374
Language : English
Location : United States

http://fmthemes.forumotion.com/

Back to top Go down

In progress Re: Name Color Not Working

Post by SpyroDragon on May 23rd 2015, 10:59 pm

The //// background ///

trying to serperate the codes, is not my problem Brandon, learn how to read, The cause of trying to sepearte the codes broke my name color,

Trying to fix my name color is my problem Brandon, so can you please stop trying to help me with something that i don't need fixed, SLGrey understands the problem, obviously you misread the problem somewhere thinking i was a problem with something else just cause i menchioned something similar to what you kno, so just stop plz. and yea you tried helping me, you tried helping me with some random problem i don't have, so please let people who acualy can read and kno what my problem is before you just start giving random information outon buncha random crap that has nothing to do with my problem.


@SLGrey - Ok ill wait for Angetutor, but you couldent find anything that was wrong with the css sheet while you were logged into the test account?

SpyroDragon
Forumember

Posts : 277
Reputation : 2
Language : English

http://SpyroDragon.com/

Back to top Go down

In progress Re: Name Color Not Working

Post by brandon_g on May 23rd 2015, 11:10 pm

Ok now your begining to piss me off!

I just said since the code broke that you should re copy and paste it from the source! So that way it is fixed again. I am trying to help... If you dont want the help just say so... But DO NOT insult me... Because I will NOT tolerate that.

Maybe YOU should learn how to read... Because you seemed to missed that part!


Last edited by brandon_g on May 23rd 2015, 11:19 pm; edited 2 times in total

brandon_g
Support Moderator
Support Moderator

Male Posts : 5140
Reputation : 478
Language : English
Location : USA

http://broadcastingduo.forumotion.com/

Back to top Go down

Page 1 of 2 1, 2  Next

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum