The forum of the forums
Welcome to the Official Support Forum of Forumotion!

To take full advantage of everything offered by our forum, please log in if you are already a member, or join our community if you've not yet.



Create a free forum like this one.

Problem with full date in posts

View previous topic View next topic Go down

Solved Problem with full date in posts

Post by FIB on July 20th 2015, 10:59 pm

I run various forums and I have an issue with the date on posts I can't seem to put right what I mean is this forum http://bangernomics.editboard.com/ shows the full date of a post inc the year see below



However this forum http://www.ourbulgariaforum.com/ doesn't show the year see below





They are both phpbb2 subsilver and the settings all seem to be identical, so can anyone shed some light on what the problem might be??? or what I'm doing wrong ?

FIB
Forumember

Male Posts : 490
Reputation : 2
Language : English
Location : UK

http://ourbulgariaforum.freeforums.eu/

Back to top Go down

Solved Re: Problem with full date in posts

Post by Pizza Boi on July 21st 2015, 4:54 am

Hi Very Happy

They have edited their templates for it.

Regards,
Pizza Boi

Pizza Boi
Hyperactive

Male Posts : 2016
Reputation : 160
Language : French
Location : Pizza Hut!

http://redlustempire.forumtl.com/

Back to top Go down

Solved Re: Problem with full date in posts

Post by SLGray on July 21st 2015, 4:56 am

@Pizza Boi wrote:Hi Very Happy

They have edited their templates for it.

Regards,
Pizza Boi
He said that he runs both forums. Both forums have the same settings.


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 36705
Reputation : 2445
Language : English
Location : United States

http://ztwds.forumotion.com/

Back to top Go down

Solved Re: Problem with full date in posts

Post by Pizza Boi on July 21st 2015, 5:03 am

Hi Very Happy

Considering they both have different skins, I believe it's safe to say that it was the preset of each in terms of template and whatnot.

Regards,
Pizza Boi

Pizza Boi
Hyperactive

Male Posts : 2016
Reputation : 160
Language : French
Location : Pizza Hut!

http://redlustempire.forumtl.com/

Back to top Go down

Solved Re: Problem with full date in posts

Post by FIB on July 21st 2015, 10:34 am

Not understanding what your saying here Pizza Boi and if there is a way of me editing the template to show the full date can you tell me how???

FIB
Forumember

Male Posts : 490
Reputation : 2
Language : English
Location : UK

http://ourbulgariaforum.freeforums.eu/

Back to top Go down

Solved Re: Problem with full date in posts

Post by Pizza Boi on July 21st 2015, 12:06 pm

Hi Very Happy

It should be located in your index_box. The one I'll write down is for PunBB since I'm too lazy to change the test forum to BB2 ;-;. You have to copy the dates and parts that you wish to have in the other forum from the forum with the functional setup:

Code:
<!-- BEGIN forumrow -->
               <tr>
                  <td class="tcl" style="padding-right: {catrow.forumrow.INC_LEVEL_RIGHT}; padding-left: {catrow.forumrow.INC_LEVEL_LEFT};">
                     <span class="status" style="margin-right: -{catrow.forumrow.INC_WIDTH_ICON}; margin-left: -{catrow.forumrow.INC_WIDTH_ICON};">
                        <img title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" src="{catrow.forumrow.FORUM_FOLDER_IMG}" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" style="padding-top: 7px;" />
                     </span>
                     <h{catrow.forumrow.LEVEL} class="hierarchy"><a href="{catrow.forumrow.U_VIEWFORUM}" class="forumtitle">{catrow.forumrow.FORUM_NAME}</a></h{catrow.forumrow.LEVEL}>
                     <br />
                                                  <span style="padding-left: 15px; display: block; color: #777; width: 400px;">{catrow.forumrow.FORUM_DESC}</span>
                     <!-- BEGIN switch_moderators_links -->
                     <br />
                     {catrow.forumrow.switch_moderators_links.L_MODERATOR}{catrow.forumrow.switch_moderators_links.MODERATORS}
                     <!-- END switch_moderators_links -->
                     {catrow.forumrow.L_LINKS}{catrow.forumrow.LINKS}
                     <strong>{forumrow.L_SUBFORUM_STR}</strong> {forumrow.SUBFORUMS}
                  </td>
                                          <td class="tc2" style="text-align: right; padding-right: 5px;"><b>{catrow.forumrow.TOPICS}</b> topics<br/>
                                            <b>{catrow.forumrow.POSTS}</b> replies</td>
                  <td class="tcr">
                     <span>
                     <!-- BEGIN switch_topic_title -->
                     <a href="{catrow.forumrow.U_LATEST_TOPIC}" title="{catrow.forumrow.LATEST_TOPIC_TITLE}">{catrow.forumrow.LATEST_TOPIC_NAME}</a><br />
                          <!-- END switch_topic_title -->
                                                        {catrow.forumrow.USER_LAST_POST}
                     </span>
                  </td>
               </tr>
   <!-- END forumrow -->

^ That's for punBB. See the ones for PHPBB2 and add it in yours.

Regards,
Pizza Boi


Pizza Boi
Hyperactive

Male Posts : 2016
Reputation : 160
Language : French
Location : Pizza Hut!

http://redlustempire.forumtl.com/

Back to top Go down

Solved Re: Problem with full date in posts

Post by FIB on July 21st 2015, 4:05 pm

Ok I've looked at the 2 forums and this is what I have.. the first one is the problem forum

Code:
<!-- BEGIN forumrow -->
   <tr>
      <!-- BEGIN inc -->
      <td class="{catrow.forumrow.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" alt="." /></td>
      <!-- END inc -->
      <td class="{catrow.forumrow.INC_CLASS}" align="center" valign="middle">
         <img title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" src="{catrow.forumrow.FORUM_FOLDER_IMG}" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" />
      </td>
      <td class="row1 over" colspan="{catrow.forumrow.INC_SPAN}" valign="top" width="100%" height="50">
         <h{catrow.forumrow.LEVEL} class="hierarchy">
            <span class="forumlink">
               <a class="forumlink" href="{catrow.forumrow.U_VIEWFORUM}">{catrow.forumrow.FORUM_NAME}</a><br />
            </span>
         </h{catrow.forumrow.LEVEL}>
         <span class="genmed">{catrow.forumrow.FORUM_DESC}</span>
         <span class="gensmall">
            <!-- BEGIN switch_moderators_links -->
            {catrow.forumrow.switch_moderators_links.L_MODERATOR}{catrow.forumrow.switch_moderators_links.MODERATORS}
            <!-- END switch_moderators_links -->
            {catrow.forumrow.L_LINKS}{catrow.forumrow.LINKS}
         </span>
      </td>
      <td class="row3" align="center" valign="middle" height="50">
         <span class="gensmall">{catrow.forumrow.TOPICS}</span>
      </td>
      <td class="row2" align="center" valign="middle" height="50">
         <span class="gensmall">{catrow.forumrow.POSTS}</span>
      </td>
      <td class="row3 over" align="center" valign="middle" height="50">
            <!-- BEGIN avatar -->
            <div style="width: 200px;"></div>
            <span class="lastpost-avatar">{catrow.forumrow.avatar.LAST_POST_AVATAR}</span>
            <!-- END avatar -->

         <span class="gensmall">{catrow.forumrow.LAST_POST}</span>
      </td>
   </tr>
   <!-- END forumrow -->

This is from a working correctly forum

Code:
<!-- BEGIN forumrow -->
   <tr>
      <!-- BEGIN inc -->
      <td class="{catrow.forumrow.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" alt="." /></td>
      <!-- END inc -->
      <td class="{catrow.forumrow.INC_CLASS}" align="center" valign="middle">
         <img title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" src="{catrow.forumrow.FORUM_FOLDER_IMG}" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" />
      </td>
      <td class="row1 over" colspan="{catrow.forumrow.INC_SPAN}" valign="top" width="100%" height="50">
         <h{catrow.forumrow.LEVEL} class="hierarchy">
            <span class="forumlink">
               <a class="forumlink" href="{catrow.forumrow.U_VIEWFORUM}">{catrow.forumrow.FORUM_NAME}</a><br />
            </span>
         </h{catrow.forumrow.LEVEL}>
         <span class="genmed">{catrow.forumrow.FORUM_DESC}</span>
         <span class="gensmall">
            <!-- BEGIN switch_moderators_links -->
            {catrow.forumrow.switch_moderators_links.L_MODERATOR}{catrow.forumrow.switch_moderators_links.MODERATORS}
            <!-- END switch_moderators_links -->
            {catrow.forumrow.L_LINKS}{catrow.forumrow.LINKS}
         </span>
      </td>
      <td class="row3" align="center" valign="middle" height="50">
         <span class="gensmall">{catrow.forumrow.TOPICS}</span>
      </td>
      <td class="row2" align="center" valign="middle" height="50">
         <span class="gensmall">{catrow.forumrow.POSTS}</span>
      </td>
      <td class="row3 over" align="center" valign="middle" height="50">
            <!-- BEGIN avatar -->
            <div style="width: 200px;"></div>
            <span class="lastpost-avatar">{catrow.forumrow.avatar.LAST_POST_AVATAR}</span>
            <!-- END avatar -->

         <span class="gensmall">{catrow.forumrow.LAST_POST}</span>
      </td>
   </tr>
   <!-- END forumrow -->

FIB
Forumember

Male Posts : 490
Reputation : 2
Language : English
Location : UK

http://ourbulgariaforum.freeforums.eu/

Back to top Go down

Solved Re: Problem with full date in posts

Post by Pizza Boi on July 21st 2015, 5:31 pm

Hi Very Happy

Oh wow... this is odd, I compared both templates, they're the same ._." hmm... can you screen the entire forum setting.

I don't think I can solve this alone x_x"

Regards,
Pizza Boi

Pizza Boi
Hyperactive

Male Posts : 2016
Reputation : 160
Language : French
Location : Pizza Hut!

http://redlustempire.forumtl.com/

Back to top Go down

Solved Re: Problem with full date in posts

Post by SLGray on July 21st 2015, 6:15 pm

How do you have the time/date format set for both forums?

There is two places where you can set it: AP and your profile.


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 36705
Reputation : 2445
Language : English
Location : United States

http://ztwds.forumotion.com/

Back to top Go down

Solved Re: Problem with full date in posts

Post by FIB on July 21st 2015, 11:51 pm

@SLGray wrote:How do you have the time/date format set for both forums?

There is two places where you can set it: AP and your profile.

They are both the same





Pizza Boi what do you mean by ...can you screen the entire forum setting.

FIB
Forumember

Male Posts : 490
Reputation : 2
Language : English
Location : UK

http://ourbulgariaforum.freeforums.eu/

Back to top Go down

Solved Re: Problem with full date in posts

Post by SLGray on July 22nd 2015, 3:57 am

I just noticed that in your second screenshot in the first message exactly is mixed some have the day and others do not.


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 36705
Reputation : 2445
Language : English
Location : United States

http://ztwds.forumotion.com/

Back to top Go down

Solved Re: Problem with full date in posts

Post by FIB on July 22nd 2015, 9:24 am

@SLGray wrote:I just noticed that in your second screenshot in the first message exactly is mixed some have the day and others do not.

The only one I can see is the one that says 'Today' which I believe is normal until the following day when it will show the partial date

FIB
Forumember

Male Posts : 490
Reputation : 2
Language : English
Location : UK

http://ourbulgariaforum.freeforums.eu/

Back to top Go down

Solved Re: Problem with full date in posts

Post by SLGray on July 22nd 2015, 7:52 pm

Try this: resyn your whole forum.

AP > General > Forum > Configuration
At the bottom of the page.


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 36705
Reputation : 2445
Language : English
Location : United States

http://ztwds.forumotion.com/

Back to top Go down

Solved Re: Problem with full date in posts

Post by FIB on July 22nd 2015, 8:37 pm

@SLGray wrote:Try this: resyn your whole forum.

AP > General > Forum > Configuration
At the bottom of the page.


done that but there's no change

FIB
Forumember

Male Posts : 490
Reputation : 2
Language : English
Location : UK

http://ourbulgariaforum.freeforums.eu/

Back to top Go down

Solved Re: Problem with full date in posts

Post by SLGray on July 23rd 2015, 4:18 am

On the forum that has this issue, have you checked your profile setting for the format?


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 36705
Reputation : 2445
Language : English
Location : United States

http://ztwds.forumotion.com/

Back to top Go down

Solved Re: Problem with full date in posts

Post by FIB on July 23rd 2015, 9:18 am

@SLGray wrote:On the forum that has this issue, have you checked your profile setting for the format?


That worked fine just need to get all the members to do the same now.

Although this is solved I'll leave it open so someone can deal with the above spammer.

FIB
Forumember

Male Posts : 490
Reputation : 2
Language : English
Location : UK

http://ourbulgariaforum.freeforums.eu/

Back to top Go down

Solved Re: Problem with full date in posts

Post by SLGray on July 23rd 2015, 6:58 pm

Topic solved and archived


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 36705
Reputation : 2445
Language : English
Location : United States

http://ztwds.forumotion.com/

Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum