The forum of the forums
Welcome to the Official Support Forum of Forumotion!

To take full advantage of everything offered by our forum, please log in if you are already a member, or join our community if you've not yet.



Create a free forum like this one.

modorator/staff post color code issue

View previous topic View next topic Go down

In progress modorator/staff post color code issue

Post by LexWolfe on January 27th 2016, 5:16 pm

I asked in a previous thread about this code however I guess the question was overlooked so asking again, sorry for the multitude of posts over one thing.

I used the previous gradient tutorial to install gradient colors to ky staffs posts however I changed the layout to dark and wanted to implement another type of gradiabt with more detail and my question is - is there any way to make this code work so the image covers JUST the area with the users picture and information, and not the post box itself?

I edited the CSS code provided in the tutorial so not to stretch the image however its still copying over to the post box where it really isn't wanted.

http://prntscr.com/9vceo1
http://prntscr.com/9vcek1

I am trying to do this on a phpBB2

Thank you in advance.

LexWolfe
New Member

Posts : 15
Reputation : 1
Language : English; ASL

http://testingcoding.forumotion.com/

Back to top Go down

In progress Re: modorator/staff post color code issue

Post by brandon_g on January 27th 2016, 6:37 pm

Hello,

You can use the javascript from this topic: http://help.forumotion.com/t137582-javascript-for-an-image .

You should use this css:
Code:
.post.staff-post td { background:none }
.post.staff-post { background:url(http://i39.servimg.com/u/f39/18/21/41/30/f6011.png) no-repeat left bottom #1d1d1d }
.

-Brandon


Remember to mark your topic when a solution is found.

brandon_g
Support Moderator
Support Moderator

Male Posts : 5139
Reputation : 478
Language : English
Location : USA

http://broadcastingduo.forumotion.com/

Back to top Go down

In progress Re: modorator/staff post color code issue

Post by APE on January 27th 2016, 10:27 pm

In that code you will see this part of the code Wink
Code:
http://i39.servimg.com/u/f39/18/21/41/30/f6011.png
You just have to change the way it is
Right now its all over the post background
You need to have one made that is just the size of your profiles and not over run that part of your post.
You can ask for that to be made here >> Graphic Design Section





APE
Manager
Manager

Male Posts : 8311
Reputation : 716
Language : fluent in dork / mumbojumbo & English haha
Location : STUCK IN FORUMOTIONS SERVERS HELP ME !!!!!!

http://chatworld.forumotion.co.uk/

Back to top Go down

In progress Re: modorator/staff post color code issue

Post by LexWolfe on January 28th 2016, 12:48 am

@brandon_g wrote:Hello,

You can use the javascript from this topic: http://help.forumotion.com/t137582-javascript-for-an-image .

You should use this css:
Code:
.post.staff-post td { background:none }
.post.staff-post { background:url(http://i39.servimg.com/u/f39/18/21/41/30/f6011.png) no-repeat left bottom #1d1d1d }
.

-Brandon

That isnt the issue, I have everything implemented, and i know i did it correctly because it originally worked until i tried to change out the image.

codes -
http://prntscr.com/9vptae
http://prntscr.com/9vq3om
http://prntscr.com/9vq5ex

Even with it before my edits /to make sure each rank has its own color/ it still does this.
http://prntscr.com/9vq624

So im not sure if its with the code of my forum or what and i'm at a loss of what to do to fix it.


@APE wrote:In that code you will see this part of the code Wink
Code:
http://i39.servimg.com/u/f39/18/21/41/30/f6011.png
You just have to change the way it is
Right now its all over the post background
You need to have one made that is just the size of your profiles and not over run that part of your post.
You can ask for that to be made here >> Graphic Design Section

I have the image made, in two sizes, one at size and one extended with transparent to hope it pushes it over but it doesn't work

http://i.imgur.com/HbG5gqB.png
http://i.imgur.com/JPwhAI9.png

However as listed above, its still not working and giving me the issue.

at size image - http://prntscr.com/9vq624
large with transparent - http://prntscr.com/9vq6qv

they seem to be working exactly the same with a cut unless the post itself is long.

LexWolfe
New Member

Posts : 15
Reputation : 1
Language : English; ASL

http://testingcoding.forumotion.com/

Back to top Go down

In progress Re: modorator/staff post color code issue

Post by brandon_g on January 28th 2016, 1:37 am

Your edits have completely changed the code that is why it doesn't work. You put ´{´ brackets in instead of '(' when replacing the image and you also took off the entire last line of the css.

-Brandon


Remember to mark your topic when a solution is found.

brandon_g
Support Moderator
Support Moderator

Male Posts : 5139
Reputation : 478
Language : English
Location : USA

http://broadcastingduo.forumotion.com/

Back to top Go down

In progress Re: modorator/staff post color code issue

Post by LexWolfe on January 28th 2016, 2:47 am

Even copy/pasting the codes with none of the changes it does the same thing.

http://prntscr.com/9vr91h - I changed nothing but dropped in your code.

Code:
.post.staff-post td { background:none }
.post.staff-post { background:url(http://i39.servimg.com/u/f39/18/21/41/30/f6011.png) no-repeat left bottom #1d1d1d }

Code:
$(function() {
  $('.post:has(.staff-Tech)').addClass('staff-post');
});

Code:
<span class="staff-Tech"><img src="http://i.imgur.com/hrpynTp.png" title="Tech" /></span>

It isn't extending past the profile image but rather mirroring over the line, like a tiled image.

http://prntscr.com/9vra1p

&nothing but the java seems to have 3 lines of code for me, since my screen is large enough it stretches out entirely.

LexWolfe
New Member

Posts : 15
Reputation : 1
Language : English; ASL

http://testingcoding.forumotion.com/

Back to top Go down

In progress Re: modorator/staff post color code issue

Post by APE on January 28th 2016, 2:59 am

Your code here is not right
   
Code:
   .post.staff-post td { background:none }
        .post.staff-post { background:url(http://i39.servimg.com/u/f39/18/21/41/30/f6011.png) no-repeat left bottom #1d1d1d }

as you can see this part of the code is not right

       .post.staff-post { background:url(http://i39.servimg.com/u/f39/18/21/41/30/f6011.png) no-repeat left bottom #1d1d1d }
You are missing the ;
It should be like this
.post.staff-post { background:url(http://i39.servimg.com/u/f39/18/21/41/30/f6011.png) no-repeat left bottom #1d1d1d; } see the red ; <<

so your code is now to be

Code:
.post.staff-post td { background:none }
.post.staff-post {
background:url(http://i39.servimg.com/u/f39/18/21/41/30/f6011.png) no-repeat left bottom #1d1d1d;
}





APE
Manager
Manager

Male Posts : 8311
Reputation : 716
Language : fluent in dork / mumbojumbo & English haha
Location : STUCK IN FORUMOTIONS SERVERS HELP ME !!!!!!

http://chatworld.forumotion.co.uk/

Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum