The forum of the forums
Welcome to the Official Support Forum of Forumotion!

To take full advantage of everything offered by our forum, please log in if you are already a member, or join our community if you've not yet.



Create a free forum like this one.

Problem With Embedding Tweets In The Blogs Only...

View previous topic View next topic Go down

Solved Problem With Embedding Tweets In The Blogs Only...

Post by Rukiafan on February 2nd 2016, 8:45 pm

Hello! I'm the owner of WiiWareWave a forumotion hosted website. And my staff are having issues with getting tweets from Twitter properly embeded into our blogs, they look fine in a forum, but if you place the same code in the blog it loses most of its styling.

Here's an example of a twitter embed we used on our blog recently

<blockquote class="twitter-tweet" data-lang="en"><p lang="en" dir="ltr">Did you get our hint? Get fired up as 7th Dragon III Code: VFD swoops down to North America on the 3DS!<a href="https://t.co/DA3lgWUdsa">pic.twitter.com/DA3lgWUdsa</a></p>— SEGA (@SEGA) <a href="https://twitter.com/SEGA/status/694582414748692480">February 2, 2016</a></blockquote>
<script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script>

This is what it looks like in our blog: http://www.wiiwarewave.com/t5134-news-7th-dragon-iii-code-vfd-is-set-to-release-on-the-3ds-in-north-america-during-summer-2016

Thanks in advance for any advice or help on the matter. Wink


Last edited by Rukiafan on February 10th 2016, 7:11 am; edited 1 time in total

Rukiafan
Forumember

Posts : 276
Reputation : 9
Language : English

Back to top Go down

Solved Re: Problem With Embedding Tweets In The Blogs Only...

Post by SLGray on February 2nd 2016, 8:50 pm

Could you please exactly tell us what is not right or show how it should look like?


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 36735
Reputation : 2447
Language : English
Location : United States

http://ztwds.forumotion.com/

Back to top Go down

Solved Re: Problem With Embedding Tweets In The Blogs Only...

Post by Rukiafan on February 2nd 2016, 8:55 pm

This is what it looks like in the forums and is the way it should look in the blogs as well... http://www.wiiwarewave.com/t5135-twitter-embed-test

Rukiafan
Forumember

Posts : 276
Reputation : 9
Language : English

Back to top Go down

Solved Re: Problem With Embedding Tweets In The Blogs Only...

Post by Rukiafan on February 9th 2016, 7:48 pm

Anyone? Bump.

Edit: Btw my blog template was edited before Twitter embeds even existed, could this be causing the issue?


Last edited by Rukiafan on February 9th 2016, 7:50 pm; edited 1 time in total (Reason for editing : Added some important information.)

Rukiafan
Forumember

Posts : 276
Reputation : 9
Language : English

Back to top Go down

Solved Re: Problem With Embedding Tweets In The Blogs Only...

Post by SLGray on February 9th 2016, 9:28 pm

It could be. Try this: force the default templates and check a blog with a embedded Tweet.


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 36735
Reputation : 2447
Language : English
Location : United States

http://ztwds.forumotion.com/

Back to top Go down

Solved Re: Problem With Embedding Tweets In The Blogs Only...

Post by Ange Tuteur on February 9th 2016, 9:31 pm

Hi @Rukiafan,

Have you ever done the following ?

Admin Panel > Modules > JS codes management > Create a new script

Placement : In all the pages
Code:
document.write('<script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script>');

That should format the tweets.

Ange Tuteur
Forumaster

Male Posts : 13028
Reputation : 2704
Language : EN10, FR5
Location : Pennsylvania

http://fmdesign.forumotion.com

Back to top Go down

Solved Re: Problem With Embedding Tweets In The Blogs Only...

Post by Rukiafan on February 10th 2016, 7:10 am

That worked! I done and goofed up and originally added that code to my CSS. >_>

Topic solved thanks you guys! Wink

Rukiafan
Forumember

Posts : 276
Reputation : 9
Language : English

Back to top Go down

Solved Re: Problem With Embedding Tweets In The Blogs Only...

Post by brandon_g on February 10th 2016, 12:40 pm

Topic solved and archived ~ brandon_g


Remember to mark your topic when a solution is found.

brandon_g
Support Moderator
Support Moderator

Male Posts : 5358
Reputation : 489
Language : English
Location : USA

http://broadcastingduo.forumotion.com/

Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum