The forum of the forums
Welcome to the Official Support Forum of Forumotion!

To take full advantage of everything offered by our forum, please log in if you are already a member, or join our community if you've not yet.



Create a free forum like this one.

Loss of content when using Emoji

View previous topic View next topic Go down

In progress Loss of content when using Emoji

Post by Zzbaivong on October 22nd 2016, 4:08 pm

When I use the emoji joy (face with tears), the entire content behind it are gone when posting.



Example: http://pastebin.com/raw/AQybXFQZ
Copy and paste into editor.

Preview, no problem.


But, after posting...


I tried disabling JavaScript in the browser, but the problem still occurs.



Update: I tried to recreate this problem on Help Forumotion but could not. Why?

Zzbaivong
Forumember

Posts : 95
Reputation : 47
Language : JavaScript ^^

http://devs.forumvi.com

Back to top Go down

In progress Re: Loss of content when using Emoji

Post by SLGray on October 22nd 2016, 11:39 pm

Are you using the one from the smilies box?


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 36735
Reputation : 2447
Language : English
Location : United States

http://ztwds.forumotion.com/

Back to top Go down

In progress Re: Loss of content when using Emoji

Post by Zzbaivong on October 23rd 2016, 2:17 am

I use emoji character.
Native: 😂
Unicode: U+1F602
Description: Face with tears of joy
Full details: http://apps.timwhitlock.info/unicode/inspect/hex/1F602

Zzbaivong
Forumember

Posts : 95
Reputation : 47
Language : JavaScript ^^

http://devs.forumvi.com

Back to top Go down

In progress Re: Loss of content when using Emoji

Post by SLGray on November 2nd 2016, 1:36 am

Removed from the Garbage by Request


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 36735
Reputation : 2447
Language : English
Location : United States

http://ztwds.forumotion.com/

Back to top Go down

In progress Re: Loss of content when using Emoji

Post by Zzbaivong on November 3rd 2016, 10:42 am

Bump

Zzbaivong
Forumember

Posts : 95
Reputation : 47
Language : JavaScript ^^

http://devs.forumvi.com

Back to top Go down

In progress Re: Loss of content when using Emoji

Post by SLGray on November 3rd 2016, 7:34 pm

@Zzbaivong wrote:I use emoji character.
Native: 😂
Unicode: U+1F602
Description: Face with tears of joy
Full details: http://apps.timwhitlock.info/unicode/inspect/hex/1F602
I still do not understand how you use this?


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 36735
Reputation : 2447
Language : English
Location : United States

http://ztwds.forumotion.com/

Back to top Go down

In progress Re: Loss of content when using Emoji

Post by Zzbaivong on November 4th 2016, 1:42 am

I use emoji from Touch Keyboard, how to?
All modern OS support emoji characters. So, if you use the native, emoji will show better fit the style of your OS. In addition, you are also easily converting them to match the forum style, with the library as Twemoji, EmojiOne, ...

Zzbaivong
Forumember

Posts : 95
Reputation : 47
Language : JavaScript ^^

http://devs.forumvi.com

Back to top Go down

In progress Re: Loss of content when using Emoji

Post by SLGray on November 4th 2016, 1:58 am



When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 36735
Reputation : 2447
Language : English
Location : United States

http://ztwds.forumotion.com/

Back to top Go down

In progress Re: Loss of content when using Emoji

Post by Zzbaivong on November 4th 2016, 2:12 am

I have read that tutorial, I used in my project. But, so is inconvenient, take up much space. To show an emoticon that way requiring more than 50 characters, while using native unicode character is only 2.

Zzbaivong
Forumember

Posts : 95
Reputation : 47
Language : JavaScript ^^

http://devs.forumvi.com

Back to top Go down

In progress Re: Loss of content when using Emoji

Post by Zzbaivong on November 6th 2016, 12:44 am

Bump

Zzbaivong
Forumember

Posts : 95
Reputation : 47
Language : JavaScript ^^

http://devs.forumvi.com

Back to top Go down

In progress Re: Loss of content when using Emoji

Post by ChanelW on November 6th 2016, 11:30 am

Hello,

What device are you using to add these emoji's into your post?

Thanks,
ChanelW :rose:

ChanelW
Trial Reviewer
Trial Reviewer

Posts : 276
Reputation : 35
Language : English

Back to top Go down

In progress Re: Loss of content when using Emoji

Post by Zzbaivong on November 6th 2016, 12:51 pm


Zzbaivong
Forumember

Posts : 95
Reputation : 47
Language : JavaScript ^^

http://devs.forumvi.com

Back to top Go down

In progress Re: Loss of content when using Emoji

Post by Zzbaivong on November 9th 2016, 7:26 am

Bump

Zzbaivong
Forumember

Posts : 95
Reputation : 47
Language : JavaScript ^^

http://devs.forumvi.com

Back to top Go down

In progress Re: Loss of content when using Emoji

Post by Zzbaivong on November 11th 2016, 4:38 pm

Bump

Zzbaivong
Forumember

Posts : 95
Reputation : 47
Language : JavaScript ^^

http://devs.forumvi.com

Back to top Go down

In progress Re: Loss of content when using Emoji

Post by Zzbaivong on November 14th 2016, 2:11 pm

Bump

Zzbaivong
Forumember

Posts : 95
Reputation : 47
Language : JavaScript ^^

http://devs.forumvi.com

Back to top Go down

In progress Re: Loss of content when using Emoji

Post by Zzbaivong on November 20th 2016, 3:21 pm

Bump

Zzbaivong
Forumember

Posts : 95
Reputation : 47
Language : JavaScript ^^

http://devs.forumvi.com

Back to top Go down

In progress Re: Loss of content when using Emoji

Post by Zzbaivong on November 21st 2016, 6:06 pm


Zzbaivong
Forumember

Posts : 95
Reputation : 47
Language : JavaScript ^^

http://devs.forumvi.com

Back to top Go down

In progress Re: Loss of content when using Emoji

Post by SLGray on November 21st 2016, 7:21 pm

Could you post a screenshot of a post in a topic that has this issue? I mean of the edit page in source mode of the post.


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 36735
Reputation : 2447
Language : English
Location : United States

http://ztwds.forumotion.com/

Back to top Go down

In progress Re: Loss of content when using Emoji

Post by Ange Tuteur on November 21st 2016, 8:41 pm

I can confirm that emoji characters aren't parsing -- well more like destroying posts, actually, since they cut off all content that's written after them.

Topic : http://generaltesting.forumotion.com/t1p125-test-subject#440


Works here though. I'm assuming it has something to do with the character set of the forum.
test 😎 test

Ange Tuteur
Forumaster

Male Posts : 13028
Reputation : 2704
Language : EN10, FR5
Location : Pennsylvania

http://fmdesign.forumotion.com

Back to top Go down

In progress Re: Loss of content when using Emoji

Post by SLGray on November 21st 2016, 8:45 pm

Thanks @Ange Tuteur for the video.


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 36735
Reputation : 2447
Language : English
Location : United States

http://ztwds.forumotion.com/

Back to top Go down

In progress Re: Loss of content when using Emoji

Post by Zzbaivong on November 22nd 2016, 3:19 am


Zzbaivong
Forumember

Posts : 95
Reputation : 47
Language : JavaScript ^^

http://devs.forumvi.com

Back to top Go down

In progress Re: Loss of content when using Emoji

Post by Lorem on November 29th 2016, 12:33 pm

I also encountered the same problem on my forum Sad

Lorem
Forumember

Male Posts : 64
Reputation : 5
Language : Vietnamese
Location : Vietnam

http://www.forumgiaitri.net/

Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum