The forum of the forums
Welcome to the Official Support Forum of Forumotion!

To take full advantage of everything offered by our forum, please log in if you are already a member, or join our community if you've not yet.



Create a free forum like this one.

Sub-Forums

View previous topic View next topic Go down

Solved Sub-Forums

Post by PlayToy on August 10th 2017, 5:32 pm

How do you make topics look like this? Lined up and the space between each row.
avatar
PlayToy
Forumember

Male Posts : 83
Reputation : 1
Language : English
Location : USA

http://bestwowaddons.forumotion.com/forum

Back to top Go down

Solved Re: Sub-Forums

Post by Justice™ on August 10th 2017, 5:41 pm

@PlayToy wrote:How do you make topics look like this? Lined up and the space between each row.
By coding Razz

You want them in 3 rows and with space between the rows, right? What's your forum's link?
avatar
Justice™
Forumember

Posts : 489
Reputation : 115
Language : Romanian and English

http://board.realmsn.com

Back to top Go down

Solved Re: Sub-Forums

Post by PlayToy on August 10th 2017, 5:50 pm

Wolfuryo wrote:
@PlayToy wrote:How do you make topics look like this? Lined up and the space between each row.
By coding Razz

You want them in 3 rows and with space between the rows, right? What's your forum's link?
Yes i do, still working on the forum.
http://wowaddons.forumotion.com/
avatar
PlayToy
Forumember

Male Posts : 83
Reputation : 1
Language : English
Location : USA

http://bestwowaddons.forumotion.com/forum

Back to top Go down

Solved Re: Sub-Forums

Post by Justice™ on August 10th 2017, 6:10 pm

You have to make a few topics in a forum(about 5 topics would be enough).
avatar
Justice™
Forumember

Posts : 489
Reputation : 115
Language : Romanian and English

http://board.realmsn.com

Back to top Go down

Solved Re: Sub-Forums

Post by PlayToy on August 10th 2017, 6:20 pm

Wolfuryo wrote:You have to make a few topics in a forum(about 5 topics would be enough).
What does making a comment in one of the topics have to do with the alignment of the post?
avatar
PlayToy
Forumember

Male Posts : 83
Reputation : 1
Language : English
Location : USA

http://bestwowaddons.forumotion.com/forum

Back to top Go down

Solved Re: Sub-Forums

Post by Justice™ on August 10th 2017, 6:26 pm

Your forum has no topics. Because of that, I cannot get the selectors needed for this. I can't align the topics if they don't exist, can I? Also, I need at least 4 topics to make sure the alignment works. Make those topics or wait for someone else to help Wink
avatar
Justice™
Forumember

Posts : 489
Reputation : 115
Language : Romanian and English

http://board.realmsn.com

Back to top Go down

Solved Re: Sub-Forums

Post by SLGray on August 10th 2017, 7:42 pm

Where have you seen this? Are these exactly topics or sub-forums of a forum?


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.

avatar
SLGray
Administrator
Administrator

Male Posts : 39639
Reputation : 2666
Language : English
Location : United States

https://fmthemes.forumotion.com/

Back to top Go down

Solved Re: Sub-Forums

Post by PlayToy on August 10th 2017, 9:18 pm

@SLGray wrote:Where have you seen this? Are these exactly topics or sub-forums of a forum?
I got them from here http://forum.warmane.com/, i don't know how to refer tom them as.
avatar
PlayToy
Forumember

Male Posts : 83
Reputation : 1
Language : English
Location : USA

http://bestwowaddons.forumotion.com/forum

Back to top Go down

Solved Re: Sub-Forums

Post by SLGray on August 10th 2017, 10:14 pm

Those are sub-forums. You are referring to the links below the forum titles, correct?


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.

avatar
SLGray
Administrator
Administrator

Male Posts : 39639
Reputation : 2666
Language : English
Location : United States

https://fmthemes.forumotion.com/

Back to top Go down

Solved Re: Sub-Forums

Post by PlayToy on August 10th 2017, 10:22 pm

@SLGray wrote:Those are sub-forums. You are referring to the links below the forum titles, correct?
Yes i am, i found this post and seeing what happens.
avatar
PlayToy
Forumember

Male Posts : 83
Reputation : 1
Language : English
Location : USA

http://bestwowaddons.forumotion.com/forum

Back to top Go down

Solved Re: Sub-Forums

Post by APE on August 10th 2017, 11:45 pm

I think my code here will help Smile
http://help.forumotion.com/t137321-personalize-sub-forums-display-all-version-s

Please note it may not work for the new ModernBB forums



avatar
APE
Manager
Manager

Male Posts : 10436
Reputation : 963
Language : fluent in dork / mumbojumbo & English haha
Location : STUCK IN FORUMOTIONS SERVERS HELP ME !!!!!!

http://chatworld.forumotion.co.uk/

Back to top Go down

Solved Re: Sub-Forums

Post by PlayToy on August 11th 2017, 12:09 am

@APE wrote:I think my code here will help Smile
http://help.forumotion.com/t137321-personalize-sub-forums-display-all-version-s

Please note it may not work for the new ModernBB forums
Im kinda new to this whole thing and need to know once you add this to the javascript what you do next. And is it possible to remove the separator with a space instead? And did i do the code correctly?
Code:
<table width="100%" border="0" cellspacing="1" cellpadding="0" align="center">
   <tr>
      <td valign="bottom">
         <!-- BEGIN switch_user_logged_in -->
         <span class="gensmall">{LAST_VISIT_DATE}<br />
         {CURRENT_TIME}<br />
         </span>
         <!-- END switch_user_logged_in -->
         <div class="nav"><a class="nav" href="{U_INDEX}">{L_INDEX}</a>{NAV_CAT_DESC}</div>
      </td>
      <td class="gensmall" align="right" valign="bottom">
         <!-- BEGIN switch_user_logged_in -->
         <a class="gensmall" href="{U_SEARCH_NEW}">{L_SEARCH_NEW}</a><br />
         <a class="gensmall" href="{U_SEARCH_SELF}">{L_SEARCH_SELF}</a><br />
         <!-- END switch_user_logged_in -->
         <a class="gensmall" href="{U_SEARCH_UNANSWERED}">{L_SEARCH_UNANSWERED}</a>
      </td>
   </tr>
</table>
<!-- BEGIN catrow --><!-- BEGIN tablehead --><table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0">
   <tr>
      <th colspan="{catrow.tablehead.INC_SPAN}" nowrap="nowrap" width="100%" class="secondarytitle">&nbsp;{catrow.tablehead.L_FORUM}&nbsp;</th>
      <th nowrap="nowrap" width="50">{L_TOPICS}</th>
      <th nowrap="nowrap" width="50">{L_POSTS}</th>
      <th nowrap="nowrap" width="150"><div style="width:150px;">{L_LASTPOST}</div></th>
   </tr>
   <!-- END tablehead -->
   <!-- BEGIN cathead -->
   <tr>
      <!-- BEGIN inc -->
      <td class="{catrow.cathead.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" /></td>
      <!-- END inc -->
      <td class="{catrow.cathead.CLASS_CAT}" colspan="{catrow.cathead.INC_SPAN}" width="100%">
         <h{catrow.cathead.LEVEL} class="hierarchy">
            <span class="cattitle">
               <a class="cattitle" title="{catrow.cathead.CAT_DESC}" href="{catrow.cathead.U_VIEWCAT}">{catrow.cathead.CAT_TITLE}</a>
            </span>
         </h{catrow.cathead.LEVEL}>
      </td>
      <td class="{catrow.cathead.CLASS_ROWPIC}" colspan="3" align="right">&nbsp;</td>
   </tr>
   <!-- END cathead -->
   <!-- BEGIN forumrow -->
   <tr>
      <!-- BEGIN inc -->
      <td class="{catrow.forumrow.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" alt="." /></td>
      <!-- END inc -->
      <td class="{catrow.forumrow.INC_CLASS}" align="center" valign="middle">
         <img title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" src="{catrow.forumrow.FORUM_FOLDER_IMG}" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" />
      </td>
      <td class="row1 over" colspan="{catrow.forumrow.INC_SPAN}" valign="top" width="100%" height="50">
         <h{catrow.forumrow.LEVEL} class="hierarchy">
            <span class="forumlink">
               <a class="forumlink" href="{catrow.forumrow.U_VIEWFORUM}">{catrow.forumrow.FORUM_NAME}</a><br />
            </span>
         </h{catrow.forumrow.LEVEL}>
         <span class="genmed">{catrow.forumrow.FORUM_DESC}</span>
         <span class="gensmall">
            <!-- BEGIN switch_moderators_links -->
            {catrow.forumrow.switch_moderators_links.L_MODERATOR}{catrow.forumrow.switch_moderators_links.MODERATORS}
            <!-- END switch_moderators_links -->
            <div class="s_forum">{catrow.forumrow.L_LINKS}{catrow.forumrow.LINKS}</div>
         </span>
      </td>
      <td class="row3" align="center" valign="middle" height="50">
         <span class="gensmall">{catrow.forumrow.TOPICS}</span>
      </td>
      <td class="row2" align="center" valign="middle" height="50">
         <span class="gensmall">{catrow.forumrow.POSTS}</span>
      </td>
      <td class="row3 over" align="center" valign="middle" height="50">
            <!-- BEGIN ads -->
            <span class="AD_LastPA">
                <span class="lastpost-avatar"><img src="{catrow.forumrow.ads.IMG}" alt="{catrow.forumrow.ads.TITLE}" /></span>
                <span class="AD_LastInfos">
                    <b><a href="{catrow.forumrow.ads.LINK}">{catrow.forumrow.ads.TITLE}</a></b><br />
                    {catrow.forumrow.ads.DATE}<br />
                    {catrow.forumrow.ads.LOCATION}
                </span>
            </span>
            <!-- END ads -->
            <!-- BEGIN avatar -->
            <div style="width: 200px;"></div>
            <span class="lastpost-avatar">{catrow.forumrow.avatar.LAST_POST_AVATAR}</span>
            <!-- END avatar -->

         <span class="gensmall">{catrow.forumrow.LAST_POST}</span>
      </td>
   </tr>
   <!-- END forumrow -->
   <!-- BEGIN catfoot -->
   <tr>
      <!-- BEGIN inc -->
      <td class="{catrow.catfoot.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" /></td>
      <!-- END inc -->
      <td class="spaceRow" colspan="{catrow.catfoot.INC_SPAN}" height="1"><img src="{SPACER}" alt="" height="1" width="1" /></td>
   </tr>
   <!-- END catfoot -->
   <!-- BEGIN tablefoot -->
</table><img src="{SPACER}" alt="" height="5" width="1" /><!-- END tablefoot --><!-- END catrow -->
avatar
PlayToy
Forumember

Male Posts : 83
Reputation : 1
Language : English
Location : USA

http://bestwowaddons.forumotion.com/forum

Back to top Go down

Solved Re: Sub-Forums

Post by APE on August 11th 2017, 10:07 am

Yes in the code look for this part
Code:
var sep = '/', max_by_line = 3;

Now where it says ='/' just remove the / and put this in it's place
Code:
&nbsp;

so the new code should look like this
Code:
var sep = ' &nbsp; ', max_by_line = 3;


the more you put in the more space you will get Smile



avatar
APE
Manager
Manager

Male Posts : 10436
Reputation : 963
Language : fluent in dork / mumbojumbo & English haha
Location : STUCK IN FORUMOTIONS SERVERS HELP ME !!!!!!

http://chatworld.forumotion.co.uk/

Back to top Go down

Solved Re: Sub-Forums

Post by PlayToy on August 11th 2017, 2:40 pm

@APE wrote:Yes in the code look for this part
Code:
var sep = '/', max_by_line = 3;

Now where it says ='/' just remove the / and put this in it's place
Code:
&nbsp;

so the new code should look like this
Code:
var sep = ' &nbsp; ', max_by_line = 3;


the more you put in the more space you will get Smile
That code doesn't seem to be there.
Code:
var sep = '/', max_by_line = 3;
avatar
PlayToy
Forumember

Male Posts : 83
Reputation : 1
Language : English
Location : USA

http://bestwowaddons.forumotion.com/forum

Back to top Go down

Solved Re: Sub-Forums

Post by APE on August 11th 2017, 4:57 pm

it's not in templates it's in the code i linked you to that goes in the JavaScript.




avatar
APE
Manager
Manager

Male Posts : 10436
Reputation : 963
Language : fluent in dork / mumbojumbo & English haha
Location : STUCK IN FORUMOTIONS SERVERS HELP ME !!!!!!

http://chatworld.forumotion.co.uk/

Back to top Go down

Solved Re: Sub-Forums

Post by PlayToy on August 11th 2017, 8:02 pm

@APE wrote:it's not in templates it's in the code i linked you to that goes in the JavaScript.
Discovered a way to make it work....

I figured it out from a couple posts.
go to admin panel -> general -> categories and forums

1) Create a new category and name it what you want.
2) Under the Category add the subforum links as you want and save.
3)Move to the description box of the new forum... and click on this button
4) Copy and paste this code in the description box....
Code:
<table width="100%" border="1" cellspacing="2" cellpadding="2">
  <tr>
    <td width="4%">&nbsp;</td>
    <td width="46%">&nbsp;</td>
    <td width="4%">&nbsp;</td>
    <td width="46%">&nbsp;</td>
  </tr>
  <tr>
    <td>&nbsp;</td>
    <td>&nbsp;</td>
    <td>&nbsp;</td>
    <td>&nbsp;</td>
  </tr>
  <tr>
    <td>&nbsp;</td>
    <td>&nbsp;</td>
    <td>&nbsp;</td>
    <td>&nbsp;</td>
  </tr>
  <tr>
    <td>&nbsp;</td>
    <td>&nbsp;</td>
    <td>&nbsp;</td>
    <td>&nbsp;</td>
  </tr>
</table>
Change this part of the code from this...
Code:
<table width="100%" border="1" cellspacing="2" cellpadding="2">

to this to make 4 columns without a picture additive...
Code:
<table border="0" cellspacing="2" cellpadding="2" style="width: 70%;">

And removed this code...
Code:
<tr>
    <td width="4%">&nbsp;</td>
    <td width="46%">&nbsp;</td>
    <td width="4%">&nbsp;</td>
    <td width="46%">&nbsp;</td>
  </tr>

And added a few more of this to the code...
Code:
  <tr>
    <td>&nbsp;</td>
    <td>&nbsp;</td>
    <td>&nbsp;</td>
    <td>&nbsp;</td>
  </tr>
click the and the end result is this plus a few more boxes added removing the picture part of it....


I than went to the forum site itself and highlighted the text of each topic i made in the subforum and pasted it into each box finding out it also added the link as well to the subforum topics.....


The downside of this is if you have your text change colors when you mouse over the link in your finished forum, the color that highlights the link will be copied and pasted as well. And the black background of each link will be their as well, which i dont mind do to its a dark color forum anyways. If there is a way to remove the black background and the link color change will be really appreciated.

The end result looks like this...


I did not mess with the CSS, Javascript and HTML at all!





avatar
PlayToy
Forumember

Male Posts : 83
Reputation : 1
Language : English
Location : USA

http://bestwowaddons.forumotion.com/forum

Back to top Go down

Solved Re: Sub-Forums

Post by SLGray on August 11th 2017, 8:50 pm

In the tutorial, you had to modify a template and add a JavaScript.


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.

avatar
SLGray
Administrator
Administrator

Male Posts : 39639
Reputation : 2666
Language : English
Location : United States

https://fmthemes.forumotion.com/

Back to top Go down

Solved Re: Sub-Forums

Post by PlayToy on August 12th 2017, 2:42 am

Found even a better way than i posted above, and works great, no probs and still didn't have to mess with the Javascript, HTML, or the CSS.....
go to admin panel -> general -> categories and forums

1) Create a new category and name it what you want.
2) Under the Category add the subforum links as you want and save.
3)Move to the description box of the new forum, and click on this button
4) Copy and paste this code in the description box....
Code:
<table width="100%" border="1" cellspacing="2" cellpadding="2">
  <tr>
    <td width="4%">&nbsp;</td>
    <td width="46%">&nbsp;</td>
    <td width="4%">&nbsp;</td>
    <td width="46%">&nbsp;</td>
  </tr>
  <tr>
    <td>&nbsp;</td>
    <td>&nbsp;</td>
    <td>&nbsp;</td>
    <td>&nbsp;</td>
  </tr>
  <tr>
    <td>&nbsp;</td>
    <td>&nbsp;</td>
    <td>&nbsp;</td>
    <td>&nbsp;</td>
  </tr>
  <tr>
    <td>&nbsp;</td>
    <td>&nbsp;</td>
    <td>&nbsp;</td>
    <td>&nbsp;</td>
  </tr>
</table>

Change this part of the code from this...
Code:
<table width="100%" border="1" cellspacing="2" cellpadding="2">

to this to make 4 columns without a picture additive (only used 3 though)...
Code:
<table border="0" cellspacing="2" cellpadding="2" style="width: 70%;">

And removed this code...
Code:
<tr>
    <td width="4%">&nbsp;</td>
    <td width="46%">&nbsp;</td>
    <td width="4%">&nbsp;</td>
    <td width="46%">&nbsp;</td>
  </tr>

click the and the end result is this plus a few more boxes added removing the picture part of it....
DO NOT SAVE THIS keep it open at this point!


Open the forum in a new window and scroll to the subforums you added, right click the link of one of the posts and "copy link address"..


Go back to the boxes that i said not to save keep open, pick one of the boxes and pick the "Insert Link" tool in the post box and put the shortcut you copied and a title.


Finish with the rest of the boxes as you please and than save.
Go to Administration Panel > Display > Homepage > Structure and hierarchy and set it to one of these four settings.....


Thanks for the help and sorry for the headaches and frustration i may have caused. Very good lol! rock :party:
avatar
PlayToy
Forumember

Male Posts : 83
Reputation : 1
Language : English
Location : USA

http://bestwowaddons.forumotion.com/forum

Back to top Go down

Solved Re: Sub-Forums

Post by APE on August 12th 2017, 3:04 pm

Problem solved & topic archived.
Please read our forum rules: ESF General Rules



avatar
APE
Manager
Manager

Male Posts : 10436
Reputation : 963
Language : fluent in dork / mumbojumbo & English haha
Location : STUCK IN FORUMOTIONS SERVERS HELP ME !!!!!!

http://chatworld.forumotion.co.uk/

Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum