The forum of the forums
Welcome to the Official Support Forum of Forumotion!

To take full advantage of everything offered by our forum, please log in if you are already a member, or join our community if you've not yet.



Create a free forum like this one.

Please Fix The Text Editor bugs! Especially WYSIWYG Mode!

Page 1 of 2 1, 2  Next

View previous topic View next topic Go down

Please Fix The Text Editor bugs! Especially WYSIWYG Mode!

Post by Guest on January 5th 2011, 1:12 am

What's a forum without a good text editor? A forum relies on great coding working correctly for the text editor. I believe that the main focus of a forum should first be focused on the text editor because the text editor is how a forum becomes a forum and grows with original content.

WYSIWYG (What You See Is What You Get) mode is a great feature. It means what it says. While you are in the text editor, if you post an image, you'll see the image. If you create a table, you'll see it, if you highlight a certain area of text you want to bold or italic or colorize, it will be done.

So... whats the point? Forumotion has an incredible amount of bugs with the text editor in both standard and in WYSIWYG Modes. I have made a short list of just a few bugs in both these modes below.

Text Editor Bugs with WYSIWYG Mode OFF:

  • Some coding tags must be done manually.
    (Example: Lets say you wrote a 4 paragraph article and you need to make some corrections, such as adding a few images. Well if you were to highlight the area you wanted to place the image and then click the "image" button to insert the image in the spot, the image code and image URL will end up at the very end of your article. Basically never placing the image where you wanted it. This bug forces you to manually put the code tags during certain adjustments because it doesn't detect where you placed your mouse cursor on. This bug occurs on all forum versions.)

  • This mode doesn't copy bold text, indents, line spaces, bullets, numbering, etc.. If you copy text from somewhere and paste it into the text editor while in this mode, it will only copy the text in a plain version. Kind of like copying text into notepad.

  • After using any buttons on the text editor, such as "B" to bold a portion of text, the text editor scrolls all the way to the top automatically. This makes you lose the spot you were on when making any adjustments or corrections, forcing you to scroll back down through the post finding where you left off.

  • When posting multiple videos - While using the text tools "video button", If you tried to post a Youtube video, then tried to post another Youtube video, the URL of the first video you posted will still be inside the "Insert video URL" box, forcing you to go through the hassle of deleting the URL in the box just to put the new one. If you are posting 5 videos, well, its obviously worse and you have to repeat the process continuously. This happens on Firefox, IE & Chrome. This problem does NOT occur while WYSIWYG Mode is ON.


Text Editor Bugs with WYSIWYG Mode ON:

  • If you copied a portion of text from another website (like wikipedia or a blog) and pasted it into your text editor, it looks fine. Now click "preview" and you will notice that your text is wrapped into a thin column of text instead of stretching across the entire body of the post as it should. (This bug occurs when using Firefox web browser.)

  • When you are making a portion of text bigger it shows tag codes without showing you how it would look if the font was larger.

  • The text editor box where you type inside of becomes smaller making it difficult to get a good look at the article you are typing up. (This bug is found on Invision forum version.)

  • Sometimes text doesn't align the way you want it to inside a table. For example, if you wanted to center one row or column of text, it would never center it, even if you manually inserted the [center] code tags.

  • If you are editing a post with "Line Break" codes while in this mode, after you finish editing the post, you will have all your "Line Break" codes removed from the topic.

  • The color of the text, background and font style is entirely different than your color and font settings with this mode off. (This bug is found on Invision and is extremely annoying because the font style and text doesn't seem possible to fix with your CSS.)

  • Google Chrome web browser doesn't even support this mode.

  • Sometimes when you try to right click the text and click "Select All" the text itself doesn't highlight but inside the forum itself (everything outside of the text editor box.)

  • While you are using internet explorer, if you add a hyperlink, it automatically places it at the top of the post. Same for images.

  • When you are using the "flash video" button on the text tools bar, when assigning the width and height of the video, the height that you wanted is ignored. Instead, the height is automatically adjusted to match the width you placed.

All of these bugs and I'm sure their are a few that I failed to mention. As I mentioned above, having a sufficiently stable working text editor will make providing the content to build the your forum better. Please, fix these bugs to enhance our posting experience with our forum!

*Note: You can all test these bugs with your own forum and even Forumotion's forum itself that has these bugs.


Last edited by SPADEZ on February 1st 2011, 3:09 am; edited 6 times in total

Guest
Guest


Back to top Go down

Re: Please Fix The Text Editor bugs! Especially WYSIWYG Mode!

Post by Darren1 on January 5th 2011, 1:20 am

Amen!

Voting yes, Mario/Sanket wanna pass this up Razz

Darren1
Helper
Helper

Male Posts : 11853
Reputation : 563
Language : English

Back to top Go down

Re: Please Fix The Text Editor bugs! Especially WYSIWYG Mode!

Post by Guest on January 5th 2011, 1:35 am

Yes from me too (:

Guest
Guest


Back to top Go down

Re: Please Fix The Text Editor bugs! Especially WYSIWYG Mode!

Post by hoodedwarbler12 on January 5th 2011, 1:50 am

What about us Chrome users? Razz We never get WYSIWYG. I'm used to it. You could always use Preview.

hoodedwarbler12
Forumember

Male Posts : 521
Reputation : 117
Language : English, Latin, HTML, JavaScript
Location : Tennessee, USA

http://www.webkinznation.com

Back to top Go down

Re: Please Fix The Text Editor bugs! Especially WYSIWYG Mode!

Post by Guest on January 5th 2011, 2:13 am

@hoodedwarbler12 wrote:What about us Chrome users? Razz We never get WYSIWYG. I'm used to it. You could always use Preview.

Ah yes, I forgot to mention that. Google Chrome users can't even use WYSIWYG mode. Thats another bug added to the list!

Guest
Guest


Back to top Go down

Re: Please Fix The Text Editor bugs! Especially WYSIWYG Mode!

Post by MrMario on January 5th 2011, 3:04 am

This is more a bug then a suggestion.

MrMario
Helper
Helper

Male Posts : 22186
Reputation : 1830
Language : test

http://test.com

Back to top Go down

Re: Please Fix The Text Editor bugs! Especially WYSIWYG Mode!

Post by Darren1 on January 5th 2011, 5:07 am

Hoodedwarbler12, it's NOT a bug, but a lack of HTML5 support on Chrome Razz
Sorry, nothing FM techs can do.

Mario, it took us how many topics about this to finally do something lol Rolling Eyes

Darren1
Helper
Helper

Male Posts : 11853
Reputation : 563
Language : English

Back to top Go down

Re: Please Fix The Text Editor bugs! Especially WYSIWYG Mode!

Post by Guest on January 5th 2011, 9:38 am

I can't edit the OP anymore. I think the poll needs to be deleted. It gave me this error:



^ That's a bug that appears for me when this topic was moved into this category. The permissions of this area doesn't allow polls I assume, which is why the options don't even appear for me and it doesn't allow me to edit the post anymore.




Exclamation This is another bug while WYSIWYG Mode is OFF:

After using any buttons on the text editor, such as "B" to bold a portion of text, the text editor scrolls all the way to the top automatically. This makes you lose the spot you were on when making any adjustments or corrections, forcing you to scroll back down through the post finding where you left off.

Guest
Guest


Back to top Go down

Re: Please Fix The Text Editor bugs! Especially WYSIWYG Mode!

Post by SophieDophs on January 5th 2011, 5:30 pm

Has this poll been closed? Unless I've already voted and can't remember lol, but I'm pretty sure I haven't!

In any case, I would vote YES to fix these wretched bugs!

Text Editor Bugs with WYSIWYG Mode OFF:
This one in particular is a real pain in the butt! Not for me, I know how to turn it on and off, but it's my members that don't and they get into all sorts of pickle because the default is set to OFF.

What FM have to remember is that a high percentage of forum users have no knowledge of BB code etc or even understand what WYSIWYG actually means!

If just this one bug was fixed, my life would be made easier lol.

SophieDophs
Forumember

Female Posts : 360
Reputation : 2
Language : English

Back to top Go down

Re: Please Fix The Text Editor bugs! Especially WYSIWYG Mode!

Post by Guest on January 6th 2011, 10:28 pm

The forumotion editor was licensed from vBulletin four years ago, and the vB_Editor scripts were last modified by forumotion around three years ago. The VB3.6 editor had numerous bugs in WYSIWYG mode, and the normal/WYSIWYG switching code is still broken in the VB4 editor. forumotion's modifications to the editor introduced all sorts of bugs...the most irritating being the BBcodes not being inserted in the proper location. (To those from eToxic reading this: I can fix every one of those bugs, and some I haven't mentioned. Let's talk.)

If I could only give one piece of advice to forumotion concerning the editor, it would be this: get rid of the button that switches between normal and WYSIWYG mode. The code to support the two editor types simultaneously is convoluted, and I'm being kind. It would be best if the Quick Reply were text-only, and the newtopic/reply/PM/signature editor mode was pre-set in the ACP, with a selection on the Profile Preferences page so the user could select the mode they wanted.

Well, two pieces of advice. Very Happy Get rid of the Preview button when WYSIWYG mode is active. The WYSIWYG editor does not know how to update itself properly when the Preview button is clicked, and its contents will be modified in ways the user probably didn't want it modified!


Last edited by Dion on February 22nd 2011, 10:22 pm; edited 1 time in total

Guest
Guest


Back to top Go down

Re: Please Fix The Text Editor bugs! Especially WYSIWYG Mode!

Post by Agenda on January 6th 2011, 10:55 pm

*high-fives Dion* Very Happy

Just to throw in: this actually is a suggestion more than a bug report as this same report/suggestion/valid complaint/nuessance/aggravation/irritation/rash/plague/itch/virus/etc. has been thrown up here several times before. The suggestion was that you guys fix what you broke. *cough*

Agenda
Forumember

Male Posts : 172
Reputation : 9
Language : English

Back to top Go down

Re: Please Fix The Text Editor bugs! Especially WYSIWYG Mode!

Post by MrMario on January 7th 2011, 4:41 am

Typlo passed this and said the techs are looking for a solution.

@Dion why not email Typlo about them?

MrMario
Helper
Helper

Male Posts : 22186
Reputation : 1830
Language : test

http://test.com

Back to top Go down

Re: Please Fix The Text Editor bugs! Especially WYSIWYG Mode!

Post by Guest on January 7th 2011, 8:38 am

@Dion - Thanks for providing that CSS code, worked like a charm. I think thats the only part of that problem we can fix with our CSS unfortunately.

@MrMario - Thanks for passing this on to the higher ups so we can hope for a solution to these issues once and for all.

Guest
Guest


Back to top Go down

Re: Please Fix The Text Editor bugs! Especially WYSIWYG Mode!

Post by ThomasCo on January 13th 2011, 12:41 am

Yeah please sort this please.

It would be great if you could.

I'm having problems where links/smilies etc are being posted at the bottom of what I've written regardless of where my cursor is at.

Very annoying because myself and members have to move where we want what.

I've tried this in both modes and still no solution.

thanks. Smile

ThomasCo
Forumember

Posts : 48
Reputation : 0
Language : English

Back to top Go down

Re: Please Fix The Text Editor bugs! Especially WYSIWYG Mode!

Post by Guest on January 13th 2011, 7:06 am

Another Bug while WYSIWYG Mode is ON:
Sometimes when you try to right click the text and click "Select All" the text itself doesn't highlight but inside the forum itself (everything outside of the text editor box.)

Guest
Guest


Back to top Go down

Re: Please Fix The Text Editor bugs! Especially WYSIWYG Mode!

Post by Guest on January 16th 2011, 4:06 am

Another Bug while WYSIWYG Mode is ON:
While you are using internet explorer, if you add a hyperlink, it automatically places it at the top of the post. Same for images.

Guest
Guest


Back to top Go down

Re: Please Fix The Text Editor bugs! Especially WYSIWYG Mode!

Post by Guest on January 29th 2011, 8:44 pm

Another Bug while WYSIWYG Mode is OFF:
When posting multiple videos - While using the text tools "video button", If you tried to post a Youtube video, then tried to post another Youtube video, the URL of the first video you posted will still be inside the "Insert video URL" box, forcing you to go through the hassle of deleting the URL in the box just to put the new one. If you are posting 5 videos, well, its obviously worse and you have to repeat the process continuously. This happens on Firefox, IE & Chrome. This problem does NOT occur while WYSIWYG Mode is ON.

Guest
Guest


Back to top Go down

"Administrators have forbidden any new members" help

Post by forumvietnam on January 31st 2011, 2:45 am

When newmember Register then it say "Administrators have forbidden any new members" help?( i'm admin off forum on vietnam )
[img][/img]
[img][/img]
Help me

forumvietnam
New Member

Posts : 2
Reputation : 0
Language : vietnam

Back to top Go down

Re: Please Fix The Text Editor bugs! Especially WYSIWYG Mode!

Post by Jophy on January 31st 2011, 11:05 am

@forumvietnam wrote:When newmember Register then it say "Administrators have forbidden any new members" help?( i'm admin off forum on vietnam )
[img][/img]
[img][/img]
Help me
Please create your own topic about your problem. Don't hi-jack someone else thread.

Jophy
ForumGuru

Male Posts : 17924
Reputation : 835
Language : English
Location : Somewhere

Back to top Go down

Re: Please Fix The Text Editor bugs! Especially WYSIWYG Mode!

Post by PureIndianTalent on January 31st 2011, 9:23 pm

Joph25 wrote:
@forumvietnam wrote:When newmember Register then it say "Administrators have forbidden any new members" help?( i'm admin off forum on vietnam )
[img][/img]
[img][/img]
Help me
Please create your own topic about your problem. Don't hi-jack someone else thread.


we cant create topics

PureIndianTalent
Forumember

Posts : 70
Reputation : 0
Language : Enlgish

Back to top Go down

Re: Please Fix The Text Editor bugs! Especially WYSIWYG Mode!

Post by MrMario on February 1st 2011, 1:45 am

You can't create topics here. Please don't reply to this message.

MrMario
Helper
Helper

Male Posts : 22186
Reputation : 1830
Language : test

http://test.com

Back to top Go down

Re: Please Fix The Text Editor bugs! Especially WYSIWYG Mode!

Post by Guest on February 1st 2011, 3:08 am

Another bug while WYSIWYG Mode is ON:
When you are using the "flash video" button on the text tools bar, when assigning the width and height of the video, the height that you wanted is ignored. Instead, the height is automatically adjusted to match the width you placed.




PS - Just a suggestion.. but the posts that has nothing to do with this thread can also be split into its own topic and placed into the appropriate forum so that he can receive help on his problem, and this topic can continue without disturbance of the off topic post.


Guest
Guest


Back to top Go down

Re: Please Fix The Text Editor bugs! Especially WYSIWYG Mode!

Post by kaokaomi on March 11th 2011, 4:50 am

Content Removed ~ Member Banned ~ MrMario

kaokaomi
New Member

Posts : 6
Reputation : 0
Language : chinese

Back to top Go down

Re: Please Fix The Text Editor bugs! Especially WYSIWYG Mode!

Post by Ezio on March 12th 2011, 9:26 am

yes, I use phpBB2 and indeed there are many bugs when making a post or thread, but I just know that the cause is WYSIWYG.
especially if we are copying articles from other sites, it would be a lot of bugs and should be repaired. Confused

Ezio
Forumember

Male Posts : 155
Reputation : 10
Language : Bahasa. Indonesia
Location : Request change my Age, I'm 13-14 years old.. :D

http://www.forumbargedoz.ce.ms

Back to top Go down

Re: Please Fix The Text Editor bugs! Especially WYSIWYG Mode!

Post by Nostradurus on April 18th 2011, 8:14 pm

Edit and insert a link does not work really well with Google Chrome. This can be solved. Example reforma.forumhr.com. [url=reforma.forumhr.com]Reforma[/url].

Also the structure and organization of the forum is strange and unpredictable.

Nostradurus
New Member

Posts : 1
Reputation : 0
Language : Hrvatska

http://reforma.forumhr.com

Back to top Go down

Re: Please Fix The Text Editor bugs! Especially WYSIWYG Mode!

Post by sgeorge on April 27th 2011, 8:32 pm

Yes from me too...!

sgeorge
Forumember

Male Posts : 556
Reputation : 15
Language : Greek - English
Location : Greece

Back to top Go down

Re: Please Fix The Text Editor bugs! Especially WYSIWYG Mode!

Post by Leviosa on April 28th 2011, 10:11 am

Hopefully this won't be an issue anymore in a near future. Wink


No help without your forum url
No support via private message



Leviosa
Administrator
Administrator

Female Posts : 15348
Reputation : 1563
Language : French, English

http://help.forumotion.com

Back to top Go down

Re: Please Fix The Text Editor bugs! Especially WYSIWYG Mode!

Post by Suuki on April 29th 2011, 2:40 am

If Forumotion fixed all it's bugs that would make many people happy. Smile

Suuki
Forumember

Posts : 419
Reputation : 25
Language : English, Japanese (learning lots) :3

Back to top Go down

Re: Please Fix The Text Editor bugs! Especially WYSIWYG Mode!

Post by Leviosa on April 29th 2011, 11:43 am

We would be happy too Smile But bugs are inevitable in this kind of services, our job is to prevent them as much as possible. Smile


No help without your forum url
No support via private message



Leviosa
Administrator
Administrator

Female Posts : 15348
Reputation : 1563
Language : French, English

http://help.forumotion.com

Back to top Go down

Re: Please Fix The Text Editor bugs! Especially WYSIWYG Mode!

Post by adukes_007 on April 30th 2011, 5:02 am

@Typlo wrote:We would be happy too Smile But bugs are inevitable in this kind of services, our job is to prevent them as much as possible. Smile

What kind of timeline are we looking at to get the bugs fixed? There has been talk of a fix for several months...when will it happen? Smile

adukes_007
Forumember

Male Posts : 229
Reputation : 1
Language : English
Location : Alabama- Forrest Gump Land

http://www.turbohkforums.com

Back to top Go down

Page 1 of 2 1, 2  Next

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum