The forum of the forums
Welcome to the Official Support Forum of Forumotion!

To take full advantage of everything offered by our forum, please log in if you are already a member, or join our community if you've not yet.



Create a free forum like this one.

Smilies, toolbar selections not appearing where my cursor is?!?!?

View previous topic View next topic Go down

Smilies, toolbar selections not appearing where my cursor is?!?!?

Post by ThomasCo on January 12th 2011, 11:22 pm

This is hard to explain.

All the options, like to insert a link or to insert a smiley etc do not appear where your cursor is and instead appear at the bottom of your post.

This is annoying because all my forum members, including myself, have to drag the smiley or link to where we want it positioned in the post.

Most forums I have known post the smiley or link where your cursor is at the same.

Despite me putting the cursor where I want the link it will still post it at the bottom of my text which is annoying.

Anyone know why this is and how I can resolve?

thank you.

ThomasCo
Forumember

Posts : 48
Reputation : 0
Language : English

Back to top Go down

Re: Smilies, toolbar selections not appearing where my cursor is?!?!?

Post by panterua on January 12th 2011, 11:52 pm

You need use the WYSIWYG editor for write the messages. Go to admin panel - general - messages and emails / configuration, find the option called 'Activate the WYSIWYG mode by default in the posts' and check this in 'Yes', and finally 'Save'. But, this mode isn't compatible with Google Chrome browser. greetings

panterua
Forumember

Male Posts : 90
Reputation : 110
Language : Spanish, English
Location : Uruguay

http://mudreadlocks.superforo.net/u8

Back to top Go down

Re: Smilies, toolbar selections not appearing where my cursor is?!?!?

Post by ThomasCo on January 13th 2011, 12:09 am

That is already selected so that can't be the problem.

Sad

It's very annoying.

Thanks anyway.

ThomasCo
Forumember

Posts : 48
Reputation : 0
Language : English

Back to top Go down

Re: Smilies, toolbar selections not appearing where my cursor is?!?!?

Post by Guest on January 13th 2011, 12:22 am

Despite the BBcode sometimes being inserted in the wrong place, forumotion's text editor is much less buggy than its WYSIWYG editor. The WYSIWYG editor doesn't display properly with Chrome, it will crash the page (losing all content typed in) when inserting certain table types with IE, and the content you've typed in can change on its own if you press the Preview button (which you must do to see quote and code boxes).

I disable access to the WYSIWYG editor on my two forums because I don't want people to lose any content they have typed, and that is a real possibility when using the WYSIWYG editor.

The text editor can also easy be fixed if you know advanced javascript and can think outside the box. The text editor in my tech forum here on forumotion inserts BBcode and smileys in the proper location, for example...

Guest
Guest


Back to top Go down

Re: Smilies, toolbar selections not appearing where my cursor is?!?!?

Post by Darren1 on January 13th 2011, 12:29 am

Hi,

I believe your issue may be similar to the one in our techie area.
=> http://help.forumotion.com/t84132-please-fix-the-text-editor-bugs-especially-wysiwyg-mode

Darren1
Helper
Helper

Male Posts : 11853
Reputation : 563
Language : English

Back to top Go down

Re: Smilies, toolbar selections not appearing where my cursor is?!?!?

Post by ThomasCo on January 13th 2011, 12:30 am

I disabled WYSIWYG and still the problem exists.

You know how when you put a smiley in you select it from the drop down list and it will appear where your cursor is, it doesn't - the smiley or link or whatever appears at the bottom of what you've written which means you have to move it. Sad

Someone please help me solve this. Sad

thank you.

ThomasCo
Forumember

Posts : 48
Reputation : 0
Language : English

Back to top Go down

Re: Smilies, toolbar selections not appearing where my cursor is?!?!?

Post by Darren1 on January 13th 2011, 12:37 am

Unfortunately, its up to the techs to make the required modifications for it to work properly, as we have sent a report via the link I have above TT

Darren1
Helper
Helper

Male Posts : 11853
Reputation : 563
Language : English

Back to top Go down

Re: Smilies, toolbar selections not appearing where my cursor is?!?!?

Post by ThomasCo on January 13th 2011, 12:55 am

@Darren1 wrote:Unfortunately, its up to the techs to make the required modifications for it to work properly, as we have sent a report via the link I have above TT

I really hope they sort these minor problems out.
I've just set up my own forum and I'm getting use to the whole admin panel and everything.

I want to grow my forum, but these are little obstacles in the way.

There's so many great features on the forums, but there just seems to be bugs after bugs at the minute. Minor ones, but still issues. Sad

ThomasCo
Forumember

Posts : 48
Reputation : 0
Language : English

Back to top Go down

Re: Smilies, toolbar selections not appearing where my cursor is?!?!?

Post by ThomasCo on January 13th 2011, 1:44 am

Also, another problem is that in my welcome message to people that have just singed up, the message is in between lots of symbols.

Does anyone know why?

I've deleted them, but when I go to save it again it just shows the symbols. ??

Smile

ThomasCo
Forumember

Posts : 48
Reputation : 0
Language : English

Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum