The forum of the forums
Welcome to the Official Support Forum of Forumotion!

To take full advantage of everything offered by our forum, please log in if you are already a member, or join our community if you've not yet.



Create a free forum like this one.

Why don't I have a footer?

View previous topic View next topic Go down

Solved Why don't I have a footer?

Post by lisa1302 on April 28th 2011, 3:03 am

Ive never paid to remove the footer, and just read elsewhere that by law the phb link needs to be there...but Ive not removed it - it went away when the update happened (the one that allowed us to remove them if we wanted)

http://www.babiesandall.com/forum you can see there is nothing on the footer..and no its not under the toolbar as it wasn't there before!

I didn't remove anything from my footer template, wouldn't have a clue what to, as I say it just happened after that update and tbh I didn't think about why or whatever til reading that at least the phbb one should remain

Here are some screen shots, I tried saying Yes and NO to activate footer links, it made no difference

As you can see they are active, I haven't paid for them to be taken off. All I pay to remove is ads for members.


Can you let me know if I need to do anything?! I don't want you to tell me off for it not being there! flower


Last edited by lisa1302 on April 28th 2011, 1:50 pm; edited 1 time in total

lisa1302
Forumember

Female Posts : 305
Reputation : 40
Language : Enlish
Location : UK

http://www.babiesandall.com

Back to top Go down

Solved Re: Why don't I have a footer?

Post by Darren1 on April 28th 2011, 3:33 am

Hi,

This is strange for sure!

Could you please check your overall_footer template for this code
Code:
<!-- BEGIN switch_footer_fa_copyrights -->
                                <div align="center">
                                        <div class="gen">
                                                <!-- BEGIN footer_fa_copyright_link -->
********** Something here, generally thr copyright stuff *************
<!-- END footer_fa_copyright_link -->
/div>
                                </div>
                                <!-- END switch_footer_fa_copyrights -->
If thats there, can you remove the code for the toolbar, and see if ti re-appears, and if it does, thats the issue Wink

Footer links are links that you personally put there, for example, the ToS, free skins, & utility buttons on our footer here Smile

Darren1
Helper
Helper

Male Posts : 11853
Reputation : 563
Language : English

Back to top Go down

Solved Re: Why don't I have a footer?

Post by lisa1302 on April 28th 2011, 4:03 am

It is odd! This is what was on my footer when the links did not show:
Spoiler:
<div id="page-footer">
<div align="center">
<div class="gen">
<strong>{ADMIN_LINK}</strong>{U_VERSION_RTL}{U_CREATE_A_FORUM}{U_VERSION} {U_SUPPORT}
<!-- BEGIN switch_view_stats -->
 | <a name="bottom" href="{switch_view_stats.S_STATS}" class="copyright" rel="nofollow">{switch_view_stats.L_STATS}</a>
<!-- END switch_view_stats -->
<!-- BEGIN switch_view_donation -->
 | <a name="bottom" href="{switch_view_donation.U_DONATION}" class="copyright" rel="nofollow">{switch_view_donation.L_MAKE_DONATION}</a>
<!-- END switch_view_donation -->


<!-- BEGIN switch_view_contact -->
 | <a name="bottom" href="{switch_view_contact.U_CONTACT}" class="copyright" rel="nofollow">{switch_view_contact.L_CONTACT}</a>
<!-- END switch_view_contact -->




{U_ABUSE} {U_BLOG}
</div>
</div>
</div>
{PROTECT_FOOTER}

I checked the default, which shows this:
Spoiler:

<div id="page-footer">
<!-- BEGIN switch_footer_fa_copyrights -->
<div align="center">
<div class="gen">
<!-- BEGIN footer_fa_copyright_link -->
<!-- BEGIN switch_separator --> | <!-- END switch_separator -->
{switch_footer_fa_copyrights.footer_fa_copyright_link.FOOTER_FA_LINK}
<!-- END footer_fa_copyright_link -->
</div>
</div>
<!-- END switch_footer_fa_copyrights -->
<!-- BEGIN switch_footer_links -->
<div align="center">
<div class="gen">
<!-- BEGIN footer_link -->
<!-- BEGIN switch_separator --> | <!-- END switch_separator -->
<a name="bottom" class="copyright" href="{switch_footer_links.footer_link.U_FOOTER_LINK_HREF}" rel="{switch_footer_links.footer_link.FOOTER_LINK_REL}" target="{switch_footer_links.footer_link.FOOTER_LINK_TARGET}" title="{switch_footer_links.footer_link.L_FOOTER_LINK_TITLE}">{switch_footer_links.footer_link.L_FOOTER_LINK_TEXT}</a>
<!-- END footer_link -->
</div>
</div>
<!-- END switch_footer_links -->
</div>
{PROTECT_FOOTER}

I've certainly never edited it - and its nothing like the default Confused Anyway I copied what was on the default, starting with what you posted...and the links are all there now......except....Slight problem that my toolber covers 99.9% them when not minimised, is that a problem or do I need to add some code to shift the links up a bit?


ETA: I have now paid to remove the links, but still need to know how I can move it up?

ETA 2: odder still http://help.forumotion.com/t86470-new-update-mobile-forums-footer-edit-and-more-inside that link , where it says what to do in the template...I might be being dumb, but the code it says to change is what mine was when the links were not showing ... and what it says to change it to is what the default was (and now that mine has been changed to that it worked correctly) .. OMG does that make sense? its too late for me! It looks to me like I did have the correct code, as per the one they say to replace... but surely only people who are paying are supposed to make those changes?

I've paid now so yeh I needed to make the change ... but had I not paid I shouldn't have needed to change it, and the code I had should have worked, right? Confused

lisa1302
Forumember

Female Posts : 305
Reputation : 40
Language : Enlish
Location : UK

http://www.babiesandall.com

Back to top Go down

Solved Re: Why don't I have a footer?

Post by Darren1 on April 28th 2011, 8:51 am

A slight mis understanding there.
Before the update we had a completely different code, which we were required to change, which we had to change to the new code, which is the code that you currently have as the default content.

For example, if I had edited my footer back in say 2007, I would be required to update my template in order to remove the links legally.

So the default code is the correct code for now.
If you weren't to have paid, you wouldn't of been required to update your template, however, it's always best to work on the most modern coding Smile
If you didn't pay, the links wouldn't of been removed via the purchase option.

Darren1
Helper
Helper

Male Posts : 11853
Reputation : 563
Language : English

Back to top Go down

Solved Re: Why don't I have a footer?

Post by lisa1302 on April 28th 2011, 1:50 pm

OK, Well its all sorted now, I just need to get the links a bit higher as they aren't visible behind my toolbar, I'll have a look later and if I cant work it out myself I will post a more relevant thread

Thank you!!!

lisa1302
Forumember

Female Posts : 305
Reputation : 40
Language : Enlish
Location : UK

http://www.babiesandall.com

Back to top Go down

Solved Re: Why don't I have a footer?

Post by Base on April 28th 2011, 6:00 pm

Since this problem has been solved, I will now lock this topic.

>> Locked


Base

Base
Forumaster

Male Posts : 10386
Reputation : 1687
Language : English and French
Location : United Kingdom, England

http://forumotionhub.net

Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum