The forum of the forums
Welcome to the Official Support Forum of Forumotion!

To take full advantage of everything offered by our forum, please log in if you are already a member, or join our community if you've not yet.



Create a free forum like this one.

Adding YouTube

View previous topic View next topic Go down

Adding YouTube

Post by itoh on June 7th 2011, 1:57 am

I tried to add the YouTube "Share" code in the body of a post and it didn't work.
I then added the "Embed" code and that also did not work.

I then added each code to the "YouTube" "Insert a Video" icon at top of page and that didn't work.

I then decided to take the html code at the top of the YouTube page (address bar I guess you would call it) where the video was playing and put that code in the YouTube Insert a Video and that appeared to work.

Is that the way it is supposed to be done? When I look at the video, it does not have the 'enlarge' ability that I have seen on other YouTube embeded videos, where you can enlarge to fit the screen. As it is now, the video can only be watched in the small screen from the posted thread.

itoh
Forumember

Posts : 207
Reputation : 0
Language : english
Location : Japan

Back to top Go down

Re: Adding YouTube

Post by kirk on June 7th 2011, 3:46 am

do you have your bbcode and html enabled?

be sure you html is enabled in the forums ACP and you also have it set in your profile preferences to always allow html.

then the embed codes will work.

and if you have the bbcode off for the post then none of the flash or yioutube bbcode features will work, so if you do it that way be sure to allow bbcode in your post

kirk
Forumaster

Male Posts : 11037
Reputation : 651
Language : English,Vulcan,Klingon, Romulan,& Gorn

Back to top Go down

Re: Adding YouTube

Post by itoh on June 7th 2011, 4:12 am

Thank you.
I looked in General / Messages & Emails / Configuration as follows:
Allow HTML - Yes
BBCode - Yes

But when someone wanted to post the following video, he put the code in the body of his message and when he Previewed it, all he saw was the code he had input - he didn't see the video.

Is he doing something wrong?

Codes he input in the body of message:

<iframe width="425" height="349" src="http://www.youtube.com/embed/pCavKL2zdjM" frameborder="0" allowfullscreen></iframe>


(I tried this one and it did appear to show video, but it didn't have any of the controls at the bottom to enlarge video to fit screen, etc.)

and, as I said, the video did not show, only the above codes.

Shouldn't everyone be allowed to post these codes, or only Admin?

itoh
Forumember

Posts : 207
Reputation : 0
Language : english
Location : Japan

Back to top Go down

Re: Adding YouTube

Post by Sanket on June 7th 2011, 6:12 am

The user needs to enable html.
Profile>Preferences
Always allow html:Yes
Save.

Also, the controls such as enlarge video to fit screen are not available when you use embed codes.

Sanket
ForumGuru

Male Posts : 48766
Reputation : 2819
Language : English
Location : Mumbai

http://webartzforum.com

Back to top Go down

Re: Adding YouTube

Post by itoh on June 7th 2011, 9:17 pm

@Sanket wrote:The user needs to enable html.
Profile>Preferences
Always allow html:Yes
Save.

Also, the controls such as enlarge video to fit screen are not available when you use embed codes.

I have embedded YouTube videos on other forums and the "enlarge" control at the bottom of video is always present. Or, is it just Forumotion that doesn't allow the "enlarge" feature for YouTube videos? Does anyone know? Is there a way we can put YouTube video on our forum with the "enlarge" feature?
Either directly in body of message or when the "Icon" icon is clicked at top of (thread) page?
Any help appreciated.

itoh
Forumember

Posts : 207
Reputation : 0
Language : english
Location : Japan

Back to top Go down

Re: Adding YouTube

Post by Sanket on June 8th 2011, 6:11 am

Yes possibly on forumotion it shows like this.

Sanket
ForumGuru

Male Posts : 48766
Reputation : 2819
Language : English
Location : Mumbai

http://webartzforum.com

Back to top Go down

Re: Adding YouTube

Post by itoh on June 8th 2011, 4:32 pm

@Sanket wrote:Yes possibly on forumotion it shows like this.


Sorry? Don't understand = "Yes possibly on forumotion it shows like this."

itoh
Forumember

Posts : 207
Reputation : 0
Language : english
Location : Japan

Back to top Go down

Re: Adding YouTube

Post by Irian on June 8th 2011, 5:46 pm

an example of code you posted? Smile

Irian
Forumember

Male Posts : 661
Reputation : 18
Language : English, Français, Spagnol, Latin, ecc.
Location : New york

http://www.puregroups.co.cc

Back to top Go down

Re: Adding YouTube

Post by kirk on June 10th 2011, 3:10 am

@Sanket wrote:

Also, the controls such as enlarge video to fit screen are not available when you use embed codes.

i think you have options to allow certain things when you upload to youtube,
So if the uploader did not select certain options in the process then they will not work.

i think... lol been a while since i uploaded something to youtube

kirk
Forumaster

Male Posts : 11037
Reputation : 651
Language : English,Vulcan,Klingon, Romulan,& Gorn

Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum