The forum of the forums
Welcome to the Official Support Forum of Forumotion!

To take full advantage of everything offered by our forum, please log in if you are already a member, or join our community if you've not yet.



Create a free forum like this one.

Problem with new Like button

View previous topic View next topic Go down

Problem with new Like button

Post by Ahmed.K on September 26th 2011, 12:03 am

Hi,
There is a problem with new Like button (PunBB version)
Sometimes I can not give "Like", Although i didn't give "Like" to this post before. and also i found Post with 3 Like but 0 in the profile:



any idea about this ? Thanks.

Ahmed

Ahmed.K
Forumember

Posts : 349
Reputation : 4
Language : English

Back to top Go down

Re: Problem with new Like button

Post by wolfo9 on September 26th 2011, 12:59 am

Im guessing that would need technical help... :/

wolfo9
New Member

Male Posts : 13
Reputation : 1
Language : English, HTML, Linux Shell, AHK

http://computer-tech.forumotion.com

Back to top Go down

Re: Problem with new Like button

Post by Guest on September 26th 2011, 1:44 am

The problem isn't the like button. The problem is that you removed the dislike/- button after you had both like/+ and dislike/- buttons. In your example image, no doubt that member had some dislikes that cancelled out the likes.

In fact, it's the same phenomenon as your post profile here, which shows a negative total for likes yet there isn't a dislike button. It means you had dislikes before this board went to like-only.

There isn't anything that can be done to correct discrepancies caused by your having both buttons active prior to using only one button.

Guest
Guest


Back to top Go down

Re: Problem with new Like button

Post by Ahmed.K on September 26th 2011, 2:18 am

No, i disabled the Negative vote (and dislike/- buttons) before using reputation system and install this feature.
by using CSS
Code:
.vote .vote-button, .vote-no-bar {
  display:none;
}
.vote .vote-button:first-child {
    display:block;
}
and using this in the code
' + vplus + plus + '<li>');

any idea about this problem ?

Ahmed.K
Forumember

Posts : 349
Reputation : 4
Language : English

Back to top Go down

Re: Problem with new Like button

Post by Guest on September 27th 2011, 1:20 am

The only explanation for what you're seeing is what I wrote above. People on your board were submitting negative votes before you disabled them. And for whatever reason, you weren't aware of it when you created this topic.

I am 100% certain that if you remove the like/dislike script and go back to the original vote system with the +/- and green-and-red bar, you will have the same discrepancies you do now. So, why don't you do that and let us know what you find. Also make sure to let us know the URL of your board so we can see it for ourselves. I eagerly await the results.

Guest
Guest


Back to top Go down

Re: Problem with new Like button

Post by Ahmed.K on September 27th 2011, 2:58 am

As i said before: i disabled the Negative vote (and dislike/- buttons) before using reputation system and install this feature.

and here the post with the original vote system (by Index preview)


is green bar.

And this is the link here

Ahmed.K
Forumember

Posts : 349
Reputation : 4
Language : English

Back to top Go down

Re: Problem with new Like button

Post by Guest on September 28th 2011, 4:01 am

I rest my case.

But if you still believe the like/dislike code is the problem, even though you just proved it wasn't, then remove the code and write your own like/dislike bar. Please.

I am done with this.



Guest
Guest


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum