Topic starter thanks problem

Go down

Solved Topic starter thanks problem

Post by Dr.vahid on Sat 28 Jan 2017 - 21:24

Technical Details


Forum version : #phpBB3
Position : Founder
Concerned browser(s) : Google Chrome
Screenshot of problem :
Who the problem concerns : All members
Forum link : http://avacschat.yforum.biz

Description of problem

Hello,

I used this java code
Code:
$(function() {
  var thanked = $('#main-content > .post[style*="background-color"]')[0];
 
  if (thanked) {
    thanked.className += ' thanked-post';
    thanked.style.backgroundColor = '';
 
    thanked.insertAdjacentHTML(
      'beforeend',
      '<div class="thanked-message"><i class="fa fa-thumbs-up"></i> {USERNAME} has been thanked by the topic starter !</div>'
      .replace('{USERNAME}', $(thanked).find('.username').text())
    );
 
    $('head').append('<style type="text/css">'+
      '.thanked-post .thanked-message { color:#FFF; font-size:13px; background:#8B5; margin:10px -1px -1px -1px; padding:0px 15px; height:45px; line-height:45px; white-space:nowrap; overflow:hidden; text-overflow:ellipsis; }'+
      '.thanked-message .fa-thumbs-up { font-size:20px; margin-right:5px; vertical-align:-2px; }'+
 
      '@media (min-width:0px) and (max-width:768px) {'+
        '.thanked-post { padding-bottom:116px; }'+
        '.thanked-post .thanked-message { position:absolute; bottom:0; left:0; right:0; }'+
        '.thanked-post .postbody .profile-icons { bottom:44px; }'+
      '}'+
    '</style>');
  }
});

But problem is that something missing. I think its username miissing when I click on thanks button.

It should be appeared like this this " MAX has been thanked by Topic starter" but instead of it showing " has been thanked byy topic starter"

What's wrong in it?
Any solution??


Last edited by Dr.vahid on Mon 30 Jan 2017 - 19:15; edited 1 time in total
avatar
Dr.vahid
Forumember

Posts : 59
Reputation : 1
Language : English

https://help.forumotion.com

Back to top Go down

Solved Re: Topic starter thanks problem

Post by Valoish on Sat 28 Jan 2017 - 21:53

Can you send me a link to the tutorial/thread you got the code from?
I thought it might have been a problem with the { USERNAME } bit, but I tested it on your forum and it works fine when simply making a reply in a topic..
avatar
Valoish
Forumember

Female Posts : 291
Reputation : 54
Language : English
Location : NYC

http://www.canvastutorials.org/

Back to top Go down

Solved Re: Topic starter thanks problem

Post by Dr.vahid on Sat 28 Jan 2017 - 21:58

No tutorial actually but I got it from my another forum. So I posted above. Can you do something by using test ac? 

I used this code in java script management.  But still a bit problem with the Usernane tag may be
avatar
Dr.vahid
Forumember

Posts : 59
Reputation : 1
Language : English

https://help.forumotion.com

Back to top Go down

Solved Re: Topic starter thanks problem

Post by Valoish on Sat 28 Jan 2017 - 22:37

Does the script work on your other forum without any issues? And are both forums the same version?
I may need a test account for this so could you PM me one?
avatar
Valoish
Forumember

Female Posts : 291
Reputation : 54
Language : English
Location : NYC

http://www.canvastutorials.org/

Back to top Go down

Solved Re: Topic starter thanks problem

Post by Dr.vahid on Sun 29 Jan 2017 - 1:47

@Valoish wrote:Does the script work on your other forum without any issues? And are both forums the same version?
I may need a test account for this so could you PM me one?
Yes that script works perfectly in my other forum http://avacs.fforum.biz and yes both version is phpbb3

And PM sent @Valoish
avatar
Dr.vahid
Forumember

Posts : 59
Reputation : 1
Language : English

https://help.forumotion.com

Back to top Go down

Solved Re: Topic starter thanks problem

Post by Dr.vahid on Mon 30 Jan 2017 - 3:41

Bump
avatar
Dr.vahid
Forumember

Posts : 59
Reputation : 1
Language : English

https://help.forumotion.com

Back to top Go down

Solved Re: Topic starter thanks problem

Post by APE on Mon 30 Jan 2017 - 3:57

Do you have the same skin on each forum ?



avatar
APE
Administrator
Administrator

Male Posts : 12458
Reputation : 1304
Language : fluent in dork / mumbojumbo & English haha

http://chatworld.forumotion.co.uk/

Back to top Go down

Solved Re: Topic starter thanks problem

Post by Dr.vahid on Mon 30 Jan 2017 - 4:02

No @APE check both of my forums http://avacschat.yforum.biz and http://avacs.fforum.biz

Both is phobb3 skin but different. The 1st is a free skin from hitskin but second one is EDGE theme by @" Ange Tuteur'
avatar
Dr.vahid
Forumember

Posts : 59
Reputation : 1
Language : English

https://help.forumotion.com

Back to top Go down

Solved Re: Topic starter thanks problem

Post by APE on Mon 30 Jan 2017 - 4:06

the problem is down to the EDGE theme The templates and other things have been changed to much to make this system work I think.



avatar
APE
Administrator
Administrator

Male Posts : 12458
Reputation : 1304
Language : fluent in dork / mumbojumbo & English haha

http://chatworld.forumotion.co.uk/

Back to top Go down

Solved Re: Topic starter thanks problem

Post by Dr.vahid on Mon 30 Jan 2017 - 4:11

But do you find any error on.above script for  topic starter thanks? This script.may running in all of other phpbb3 forums including this support forum too. If you can then please check the script and I just added above script for topic starter thanks but no css or template editing yet...
avatar
Dr.vahid
Forumember

Posts : 59
Reputation : 1
Language : English

https://help.forumotion.com

Back to top Go down

Solved Re: Topic starter thanks problem

Post by Valoish on Mon 30 Jan 2017 - 4:20

The reason your script works in your regular phpbb3 forum is because the templates weren't edited too much - just like on the support forum. Ange's Edge is a heavily modified version of phpbb3. Meaning Ange edited the templates of the original phpbb3 version to create his Edge version. Even though YOU didn't edit the templates, Ange did, which is why the script isn't working on the forum that is using Edge. 
Since Ange is the one that created the theme, it'd be best to ask him for help - or ask someone who knows a lot about the templates and Javascript.
avatar
Valoish
Forumember

Female Posts : 291
Reputation : 54
Language : English
Location : NYC

http://www.canvastutorials.org/

Back to top Go down

Solved Re: Topic starter thanks problem

Post by Dr.vahid on Mon 30 Jan 2017 - 4:25

@Valoish since Ange is not giving any support so it is not possible from him but I can have some hopes on @Luffy or any othher staffs or members who can do something for me about this issue?

But which tamplate part is responsible for topic starter thanks?
avatar
Dr.vahid
Forumember

Posts : 59
Reputation : 1
Language : English

https://help.forumotion.com

Back to top Go down

Solved Re: Topic starter thanks problem

Post by Luffy on Mon 30 Jan 2017 - 11:31

FAE is a theme that has this system already. You didn't have to add this code in order for it to work. The theme by default has a system like that.
avatar
Luffy
Manager
Manager

Male Posts : 5553
Reputation : 616
Language : Greek, English
Location : Greece

https://help.forumotion.com

Back to top Go down

Solved Re: Topic starter thanks problem

Post by Dr.vahid on Mon 30 Jan 2017 - 12:05

So in this time what should I do to run this? Do you have code for it which will bee running on normal phpbb3? Or any way to active system to run it?
avatar
Dr.vahid
Forumember

Posts : 59
Reputation : 1
Language : English

https://help.forumotion.com

Back to top Go down

Solved Re: Topic starter thanks problem

Post by Luffy on Mon 30 Jan 2017 - 12:17

The theme of FAE has the system with it. All you have to do is activate the thanks button and remove the custom code you added.
avatar
Luffy
Manager
Manager

Male Posts : 5553
Reputation : 616
Language : Greek, English
Location : Greece

https://help.forumotion.com

Back to top Go down

Solved Re: Topic starter thanks problem

Post by Dr.vahid on Mon 30 Jan 2017 - 12:27

No, this is my forum http://avacschat.yforum.biz it is not FAE forum. It has regular theme. So i wanted thanks starter in this forum like FAE forum. So how to make it?
avatar
Dr.vahid
Forumember

Posts : 59
Reputation : 1
Language : English

https://help.forumotion.com

Back to top Go down

Solved Re: Topic starter thanks problem

Post by Guest on Mon 30 Jan 2017 - 13:14

Dr vahid, please do not send me private messages for your problems.

I did help you out a few times but as you do not seem willing to learn or listen, I no longer are willing to help with your issues.

Guest
Guest


Back to top Go down

Solved Re: Topic starter thanks problem

Post by Dr.vahid on Mon 30 Jan 2017 - 16:11

Meesleepbeest wrote:Dr vahid, please do not send me private messages for your problems.

I did help you out a few times but as you do not seem willing to learn or listen, I no longer are willing to help with your issues.
I don't need your support. There are a lot of stuffs for supports. 

Anyway,  I did some works in css by using tutorial of Ange here https://help.forumotion.com/t142451-add-a-message-to-thanked-posts#969782

Now it seems to me ok for me. So I did with my own try.
avatar
Dr.vahid
Forumember

Posts : 59
Reputation : 1
Language : English

https://help.forumotion.com

Back to top Go down

Solved Re: Topic starter thanks problem

Post by SLGray on Mon 30 Jan 2017 - 22:17

Is this solved?


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.

avatar
SLGray
Administrator
Administrator

Male Posts : 43665
Reputation : 3104
Language : English
Location : United States

http://fmthemesdesignteam.forumotion.com/

Back to top Go down

Solved Re: Topic starter thanks problem

Post by Dr.vahid on Mon 30 Jan 2017 - 23:26

Yes, solved
avatar
Dr.vahid
Forumember

Posts : 59
Reputation : 1
Language : English

https://help.forumotion.com

Back to top Go down

Solved Re: Topic starter thanks problem

Post by Luffy on Tue 31 Jan 2017 - 0:10

Meesleepbeest wrote:Dr vahid, please do not send me private messages for your problems.

I did help you out a few times but as you do not seem willing to learn or listen, I no longer are willing to help with your issues.
I agree on this. Support via pms are not allowed and we told you tones of times.. Therefore you lost your chance.

Problem solved & topic archived.
Please read our forum rules: ESF General Rules
avatar
Luffy
Manager
Manager

Male Posts : 5553
Reputation : 616
Language : Greek, English
Location : Greece

https://help.forumotion.com

Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum