Online Staff Widget not working as intended

Go down

Solved Online Staff Widget not working as intended

Post by Leyjenah on March 23rd 2019, 1:36 pm

Technical Details


Forum version : #ModernBB
Position : Founder
Concerned browser(s) : Google Chrome
Screenshot of problem : https://gyazo.com/3dace925cd8dbdde2f29e8e830926805
Who the problem concerns : All members
When the problem appeared : When installing the witched and loggin into the Gamemaster account
Forum link : http://runeterra.forumotion.com

Description of problem

Hello guys,

I installed this tutorial widget and noticed an issue with it.
Here is my setup: I have three groups (Administrator, Moderator, Staff), of which two (Administrator, Moderator) are hidden groups (color code is set to #000000 and enabled).
Accounts that should show up: Administrator (owner of all groups), Gamemaster (Staff), NPC (Staff), Primrose (Admin, another group), hamdepaf (Moderator), Atgo (Moderator)
Now the problem is, that two Accounts (Administrator and Gamemaster) show up three times when they are online, once as Administrator, once as Moderator and once as Staff. All other accounts, however, are not shown at all.

Now what I want: First of course for the widget to work properly. So that it shows all accounts... once, refreshes properly, etc.

And last but not least I have a few questions that might help for a solution:
1. Does it matter if a group is hidden? If yes, it would explain why the accounts Primrose, Atgo and hamdepaf don't appear. Is there any way that hidden groups count too?
2. The color code that is changed in the script: has it to be identically to the color the group has or can I set any color that I like? Or does it have to be the color the displayed account currently has in order to make the account show up?

Thank you for your help!

Best regards,
L ~


Last edited by Leyjenah on March 24th 2019, 2:30 pm; edited 1 time in total
Leyjenah
Leyjenah
New Member

Posts : 7
Reputation : 1
Language : GER, EN

Back to top Go down

Solved Re: Online Staff Widget not working as intended

Post by APE on March 23rd 2019, 6:16 pm

To help here YES it dose matter you should only add the groups that can be seen in public.

Hidden staff members will show problems with the code.


000000 - Online Staff Widget not working as intended Left1212000000 - Online Staff Widget not working as intended Center11000000 - Online Staff Widget not working as intended Right112
000000 - Online Staff Widget not working as intended Ape_b110
000000 - Online Staff Widget not working as intended Ape1010
APE
APE
Administrator
Administrator

Male Posts : 14524
Reputation : 1587
Language : fluent in dork / mumbojumbo & English haha

http://chatworld.forumotion.co.uk/

Back to top Go down

Solved Re: Online Staff Widget not working as intended

Post by SLGray on March 23rd 2019, 6:35 pm

2.   It has to be the exact color code of the group.

See if this one works for you:  http://fmdesign.forumotion.com/t227-widget-staff-online?highlight=staff+widget%2A


000000 - Online Staff Widget not working as intended Slgray10

When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.
SLGray
SLGray
Administrator
Administrator

Male Posts : 45914
Reputation : 3241
Language : English
Location : United States

https://help.forumotion.com/

Back to top Go down

Solved Re: Online Staff Widget not working as intended

Post by Leyjenah on March 24th 2019, 1:54 pm

Hey!
Thank you for the feedback, the other tutorial is very helpful.

Best regards,
L ~
Leyjenah
Leyjenah
New Member

Posts : 7
Reputation : 1
Language : GER, EN

Back to top Go down

Solved Re: Online Staff Widget not working as intended

Post by skouliki on March 24th 2019, 3:36 pm

Problem solved & topic archived.
Please read our forum rules: ESF General Rules
skouliki
skouliki
Manager
Manager

Female Posts : 6364
Reputation : 970
Language : English,Greek
Location : Greece

http://iconskouliki.forumgreek.com

Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum