The forum of the forums
Welcome to the Official Support Forum of Forumotion!

To take full advantage of everything offered by our forum, please log in if you are already a member, or join our community if you've not yet.



Create a free forum like this one.

Mouse over code in widget no longer working

View previous topic View next topic Go down

Mouse over code in widget no longer working

Post by DustyBones on March 16th 2014, 5:06 pm

I have an affiliates widget on my site that is coded to stop scrolling when I hover my cursor over it (mouse over).
I just noticed that it no longer works, it just keeps scrolling when I put my cursor on it. It was working fine and I haven't added any affiliates or made any changes.
Has the coding for forumotion forums changed to where I need to code it different?
Code:

 <marquee behavior="scroll" direction="up" scrollamount="2" onmouseover="this.stop();" onmouseout="this.start();"></marquee>
<div style="" align="center">
   ---- FORUMS AFFILIATE BUTTONS CODING GOES HERE ----
</div><marquee behavior="scroll" direction="up" scrollamount="2" onmouseover="this.stop();" onmouseout="this.start();"></marquee>
<div style="text-align:center" align="center">
   
</div>
Thanks for any help anyone might be able to give me..

DustyBones
Active Poster

Male Posts : 1227
Reputation : 517
Language : English
Location : Washington, USA

http://raps-graphics.forumotion.com/

Back to top Go down

Re: Mouse over code in widget no longer working

Post by Luffy on March 16th 2014, 5:12 pm

Hello,

I tried it with both Firefox and Chrome Browsers and works fine to me.

If you want, you could try cleaning your browsers cashe and check it again.

Good Luck,
Marios.






Luffy
Manager
Manager

Male Posts : 4245
Reputation : 424
Language : Greek, English
Location : Greece

http://helpgr.forumgreek.com/forum

Back to top Go down

Re: Mouse over code in widget no longer working

Post by DustyBones on March 16th 2014, 5:21 pm

Marios94 wrote:Hello,

I tried it with both Firefox and Chrome Browsers and works fine to me.

If you want, you could try cleaning your browsers cashe and check it again.

Good Luck,
Marios.
Thanks Marios,
I cleared the cache, nothing changed. If it works for you I must have a coding conflict somewhere. That answered that.. Thanks again..

DustyBones
Active Poster

Male Posts : 1227
Reputation : 517
Language : English
Location : Washington, USA

http://raps-graphics.forumotion.com/

Back to top Go down

Re: Mouse over code in widget no longer working

Post by Luffy on March 16th 2014, 5:23 pm

It seems that you have something wrong up there in the code. Can you paste me the whole code please? Because if it is just that it has somethings that are not necessary and maybe that is why it doesn't work for you.






Luffy
Manager
Manager

Male Posts : 4245
Reputation : 424
Language : Greek, English
Location : Greece

http://helpgr.forumgreek.com/forum

Back to top Go down

Re: Mouse over code in widget no longer working

Post by Pizza Boi on March 16th 2014, 5:27 pm

Hi Very Happy

Well, I didn't see anything wrong with your console that would relate to your problem and it works fine with me like what Marios said. Try checking your own error console by checking it in Inspect Element and since you're the one who coded it, you're able to identify which has errors easier than we can Smile .

Regards,
Pizza Boi

Pizza Boi
Hyperactive

Male Posts : 2016
Reputation : 160
Language : French
Location : Pizza Hut!

http://redlustempire.forumtl.com/

Back to top Go down

Re: Mouse over code in widget no longer working

Post by Ange Tuteur on March 16th 2014, 7:16 pm

Hello DustyBones,

I have in fact noticed that things using marquee are not working correct. To be more specific the recent topics scrolling will not stop on mouseover; it throws the following errors :

document.getElementById(...).stop is not a function
document.getElementById(...).start is not a function

for your code :
this.stop is not a function
this.start is not a function

this may be an issue related to Firefox 27, it was around the time I noticed it I believe.

try this :
I have patched it with some jQuery.
Code:
<marquee behavior="scroll" direction="up" scrollamount="2" onmouseover="$(this).attr('scrollamount','0');" onmouseout="$(this).attr('scrollamount','2');">
<div style="" align="center">
 <img src="http://i1042.photobucket.com/albums/b430/RapsGraphics/forumotionbutton3.png" /><img src="http://i1042.photobucket.com/albums/b430/RapsGraphics/forumotionsupport.png" />
</div></marquee>

Ange Tuteur
Forumaster

Male Posts : 13028
Reputation : 2704
Language : EN10, FR5
Location : Pennsylvania

http://fmdesign.forumotion.com

Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum