The forum of the forums
Welcome to the Official Support Forum of Forumotion!

To take full advantage of everything offered by our forum, please log in if you are already a member, or join our community if you've not yet.



Create a free forum like this one.

#1375 Chatbox issues

Page 1 of 2 1, 2  Next

View previous topic View next topic Go down

Solved #1375 Chatbox issues

Post by Shadow on February 10th 2015, 9:59 am

Dear members

Our technicians are still working on the chatbox issues. Here, the list of problems solved or in progress. Thanks for providing the following information if you have a new problem:

1- Url of your forum
2- Description of the problem
3- Who get the problem ( founder, admins, moderators, users, all)
4- A screenshot if possible



Warning: Without those information, we won't take into account your request! Thanks for your understanding :rose:



Add Remove the new color picker = solved
Add Posts missing = solved
Add Error in function write_msg(). Can not insert message = solved
Add Chatbox empty = solved
Add After logging out, the drag bar looks same = solved
Add Some messages are missing after posting = solved
Add Alignment problem of the "help" button under chrome = solved
Add The chatbox doesn't refresh when a user is just kiched = solved
Add Auto-refresh = solve
Add Issues with archives = solved
Add Buttons are too white so invisible = solved
Add The color of the text is not the same as the color forum = solved
Add The color of members is black by default, so if the chatbox background is back members aren't visible = solved
Add Sort alphabetically username = solved
Add  Color picker not in pop-up but in JS as for the editor = solved
Add Even if we are deconnected, we appear like connected= solved
Add  Buttons are cut with PunBB forum = solved


Last edited by Buttercup on March 30th 2015, 9:22 am; edited 3 times in total


No help without your forum url
No support via private message


avatar
Shadow
Administrator
Administrator

Female Posts : 15863
Reputation : 1685
Language : French, English

http://help.forumotion.com

Back to top Go down

Solved Re: #1375 Chatbox issues

Post by Van-Helsing on February 10th 2015, 1:04 pm

Hello @Buttercup,

Forum URL: http://linux-team.forumgreek.com/
Description: The Chatbox buttons appearing empty, the auto-refresh option and button is missing, the css about the chatbox ignored for an unknown reason and the buttons are not justified vertically correctly in form/bar which is for message sending especially the button "Send" and the button help in relationship with other buttons. For some of the empty buttons I found the element and increase the font size. The color picker button and the smileys button are still appearing empty.
As it seems the technicians have modified some chatbox variables so this making the CSS and addons/pluging/3d party codes unusable.

Who get the problem: all
Screenshots:



avatar
Van-Helsing
Hyperactive

Male Posts : 2324
Reputation : 92
Language : English, Greek

http://helpgr.forumgreek.com/

Back to top Go down

Solved Re: #1375 Chatbox issues

Post by Shadow on February 10th 2015, 2:35 pm

Hello "Black-Shadow"

I have reported the problem to our technicians. I will let your know as soon as possible Smile

Thanks for your patience :rose:


No help without your forum url
No support via private message


avatar
Shadow
Administrator
Administrator

Female Posts : 15863
Reputation : 1685
Language : French, English

http://help.forumotion.com

Back to top Go down

Solved Re: #1375 Chatbox issues

Post by dcj91x on February 10th 2015, 3:06 pm

http://mhwiki.forumotion.net/

The names on the chatbox for (regular members) is staying black and I have not found any way to fix it. And since our background is black to match the forum.. well you get the point.

Also while the chat is auto refreshing for most forum members it is not for myself (forum founder) and some others admins.

Those are the only noticable problems at this time and it appeares you are working on both those issues already.

Thank you dcj91x

dcj91x
Forumember

Male Posts : 51
Reputation : 0
Language : English

http://mhwiki.forumotion.net/

Back to top Go down

Solved Re: #1375 Chatbox issues

Post by Shadow on February 10th 2015, 3:29 pm

Hello

@Black-shadow

When we remove your Css and JS, the problem desappear so we think there is sometimes with your css and the new Chatbox that don't fit


@dcj91x

The username and group color is still in progress. Normally, the technicians will send something online today to fix the bug ~1~


No help without your forum url
No support via private message


avatar
Shadow
Administrator
Administrator

Female Posts : 15863
Reputation : 1685
Language : French, English

http://help.forumotion.com

Back to top Go down

Solved Re: #1375 Chatbox issues

Post by Eugeo Igvalt on February 10th 2015, 3:36 pm

One issue thats been going on in many forums I have been into is that if I stay idle and away then I type something in the chat when I hit enter, it says I logged out and I have to log back in. I think it's been reported before, but it's still happening.
avatar
Eugeo Igvalt
Forumember

Male Posts : 289
Reputation : 17
Language : EN, SPA
Location : Puerto Rico

http://www.NewbForums.com

Back to top Go down

Solved Re: #1375 Chatbox issues

Post by Espectra on February 10th 2015, 11:05 pm

1- Url of your forum:

http://www.rivalsoftrust.com/#!apply/ctzo
rivals-of-trust.forumotion.com


2- Description of the problem:

The chat is cut off a short distance from its bottom border, which cuts the chatbox command buttons in half.  I am getting this problem in all browsers.

Additionally, the font in Firefox is Comic Sans MS, which... is very odd.  I do not use Comic Sans MS anywhere on my forum.  This is a very easy font to recognize.


The font in IE is different.  I can't tell what this font is, as it seems very generic.


The font was Courier New until I switched the forum body font to Kelly Slab via a Google font import.  It was immediately following this import and font change that the chatbox font changed to Comic Sans MS.


None of the CSS coding seems to have any effect on the chatbox font or background.  When changing Background 1 using the Display>Colors feature, the color changes along with it, but when using the same CSS elements that are changed by using that feature in my CSS stylesheet in an attempt to make them transparent, there is no change.  I'd like to figure out a way to make the background transparent on chat just like the rest of my forum.

Note:  I have deleted all of the CSS styling regarding the chatbox from my stylesheet until I have accurate information on how to make these adjustments.


3- Who get the problem ( founder, admins, moderators, users, all)


I (the founder and only administrator) am presently the only person using chat, since I just added it today, so I can't really answer this one.


4- A screenshot if possible

The below was taken from Firefox:


The below was taken from IE:


Last edited by Espectra on February 10th 2015, 11:15 pm; edited 1 time in total
avatar
Espectra
Forumember

Female Posts : 48
Reputation : 1
Language : English

http://rivals-of-trust.forumotion.com

Back to top Go down

Solved Re: #1375 Chatbox issues

Post by _Twisted_Mods_ on February 10th 2015, 11:14 pm

i notice the font options and the input box/send button both have the same class name "right" ... shoudnt one them be left?
avatar
_Twisted_Mods_
Helper
Helper

Male Posts : 2064
Reputation : 314
Language : English
Location : Ms

http://liquidcode.forumotion.com

Back to top Go down

Solved Re: #1375 Chatbox issues

Post by Shadow on February 11th 2015, 10:19 am

Espectra wrote:1- Url of your forum:

http://www.rivalsoftrust.com/#!apply/ctzo
rivals-of-trust.forumotion.com


2- Description of the problem:

The chat is cut off a short distance from its bottom border, which cuts the chatbox command buttons in half.  I am getting this problem in all browsers.

Additionally, the font in Firefox is Comic Sans MS, which... is very odd.  I do not use Comic Sans MS anywhere on my forum.  This is a very easy font to recognize.


The font in IE is different.  I can't tell what this font is, as it seems very generic.


The font was Courier New until I switched the forum body font to Kelly Slab via a Google font import.  It was immediately following this import and font change that the chatbox font changed to Comic Sans MS.


None of the CSS coding seems to have any effect on the chatbox font or background.  When changing Background 1 using the Display>Colors feature, the color changes along with it, but when using the same CSS elements that are changed by using that feature in my CSS stylesheet in an attempt to make them transparent, there is no change.  I'd like to figure out a way to make the background transparent on chat just like the rest of my forum.

Note:  I have deleted all of the CSS styling regarding the chatbox from my stylesheet until I have accurate information on how to make these adjustments.


3- Who get the problem ( founder, admins, moderators, users, all)


I (the founder and only administrator) am presently the only person using chat, since I just added it today, so I can't really answer this one.


4- A screenshot if possible

The below was taken from Firefox:


The below was taken from IE:
Hello

Thanks for the explanation. The problem of cut buttons has been reported to our technicians. The problem happens on PunBB, so they will correct it today.

For your fonts, the problem comes from browsers that don't recognize your font. On your CSS, you should add many fonts to be sure one of them will be taken into account:

Definition and Usage


The font-family property specifies the font for an element.
The font-family property can hold several font names as a "fallback" system. If the browser does not support the first font, it tries the next font.

p {
    font-family: "Times New Roman", Georgia, Serif;
}
More info here: http://www.w3schools.com/cssref/pr_font_font-family.asp

Thanks :rose:
avatar
Shadow
Administrator
Administrator

Female Posts : 15863
Reputation : 1685
Language : French, English

http://help.forumotion.com

Back to top Go down

Solved Re: #1375 Chatbox issues

Post by Van-Helsing on February 11th 2015, 11:26 am

Buttercup wrote:Hello

@Black-shadow

When we remove your Css and JS, the problem desappear so we think there is sometimes with your css and the new Chatbox that don't fit


Hello @Buttercup,
I have removed/modified some parts of css and now my chatbox looks ok



Thank you very much for the assistance.
avatar
Van-Helsing
Hyperactive

Male Posts : 2324
Reputation : 92
Language : English, Greek

http://helpgr.forumgreek.com/

Back to top Go down

Solved Re: #1375 Chatbox issues

Post by Espectra on February 11th 2015, 3:05 pm

Buttercup wrote:
Espectra wrote:1- Url of your forum:

http://www.rivalsoftrust.com/#!apply/ctzo
rivals-of-trust.forumotion.com


2- Description of the problem:

Additionally, the font in Firefox is Comic Sans MS, which... is very odd.  I do not use Comic Sans MS anywhere on my forum.  This is a very easy font to recognize.

The font in IE is different.  I can't tell what this font is, as it seems very generic.


The font was Courier New until I switched the forum body font to Kelly Slab via a Google font import.  It was immediately following this import and font change that the chatbox font changed to Comic Sans MS.


None of the CSS coding seems to have any effect on the chatbox font or background.  When changing Background 1 using the Display>Colors feature, the color changes along with it, but when using the same CSS elements that are changed by using that feature in my CSS stylesheet in an attempt to make them transparent, there is no change.  I'd like to figure out a way to make the background transparent on chat just like the rest of my forum.

Note:  I have deleted all of the CSS styling regarding the chatbox from my stylesheet until I have accurate information on how to make these adjustments.


3- Who get the problem ( founder, admins, moderators, users, all)


I (the founder and only administrator) am presently the only person using chat, since I just added it today, so I can't really answer this one.


4- A screenshot if possible

The below was taken from Firefox:


The below was taken from IE:

For your fonts, the problem comes from browsers that don't recognize your font. On your CSS, you should add many fonts to be sure one of them will be taken into account:

Definition and Usage



The font-family property specifies the font for an element.
The font-family property can hold several font names as a "fallback" system. If the browser does not support the first font, it tries the next font.

p {
    font-family: "Times New Roman", Georgia, Serif;
}
More info here: http://www.w3schools.com/cssref/pr_font_font-family.asp

Thanks :rose:

This would not explain why the font properly works on the rest of the forum but does not properly work in the chatbox.  My forum uses Kelly Slab perfectly fine.  It's only the chatbox which can't.  Does the chatbox not draw from the same data as the forum?  If not, is there any way for me to add the same font data that my forum uses to the data that the chatbox draws from?  If I can't get the fonts to work properly, I'll not be able to use the chatbox at all.

I appreciate your assistance very much, Buttercup.  I will be grateful for any additional information you can provide.
avatar
Espectra
Forumember

Female Posts : 48
Reputation : 1
Language : English

http://rivals-of-trust.forumotion.com

Back to top Go down

Solved Re: #1375 Chatbox issues

Post by Shadow on February 11th 2015, 3:25 pm

Hello

It is not a big but a forum personalization. You should ask it into the Design Section: http://help.forumotion.com/f45-forum-design-appearance-help


No help without your forum url
No support via private message


avatar
Shadow
Administrator
Administrator

Female Posts : 15863
Reputation : 1685
Language : French, English

http://help.forumotion.com

Back to top Go down

Solved Re: #1375 Chatbox issues

Post by Shadow on February 11th 2015, 5:19 pm

hello dear members,

Normally all problems are solved! Thanks for your feedbacks Wink


No help without your forum url
No support via private message


avatar
Shadow
Administrator
Administrator

Female Posts : 15863
Reputation : 1685
Language : French, English

http://help.forumotion.com

Back to top Go down

Solved Re: #1375 Chatbox issues

Post by Guest on February 11th 2015, 5:28 pm

@Buttercup: Thanks for the update! YAY! We can finally use the chatbox!

Guest
Guest


Back to top Go down

Solved Re: #1375 Chatbox issues

Post by JScript on February 11th 2015, 6:31 pm

@Buttercup
Thanks for the info!

However, I realized that depending on the amount of messages and computer speed, it takes some time to show messages on the screen!

This is due to the non-optimization of some functions, the most important is:
Chatbox.prototype.refresh

Where manipulates the DOM within a "for loop" with the function $('#chatbox').append(html)

A brief explanation to avoid this:
Keep DOM access to a minimum

Accessing the DOM in browsers is an expensive thing to do. The DOM is a very complex API and rendering in browsers can take up a lot of time. You can see this when running complex web applications when your computer is already maxed out with other work — changes take longer or get shown half way through and so on.

To make sure that your code is fast and doesn’t slow down the browser to a halt try to keep DOM access to a bare minimum. Instead of constantly creating and applying elements, have a tool function that turns a string into DOM elements and call this function at the end of your generation process to disturb the browser rendering once rather than continually.
Reference: http://www.w3.org/wiki/JavaScript_best_practices#Keep_DOM_access_to_a_minimum

Finally, below is part of the code in Chatbox.prototype.refresh function where it should not manipulate the DOM inside a loop:
Code:

      if (data.messages) {
         var scroll = !this.messages || this.messages.length != data.messages.length;
         this.messages = data.messages;
         $('#chatbox').empty();
         if (this.messages) {
            for (var j = 0; j < this.messages.length; j++) {
               var message = this.messages[j];
               var html = '<p class=\'chatbox_row_' + (j % 2 == 1 ? 2 : 1) + ' clearfix\'>' + '<span class=\'date-and-time\' title=\'' + message.date + '\'>[' + message.datetime + ']</span>';
               if (message.userId == -10) {
                  html += '<span class=\'msg\'>' + '<span style=\'color:' + message.msgColor + '\'>' + '<strong> ' + message.msg + '</strong>' + '</span>' + '</span>'
               } else {
                  html += '<span class=\'user-msg\'>' + '<span class=\'user\' style=\'color:' + message.user.color + '\'>' + '<strong> ' + (message.user.admin ? '@ ' : '') + '<span class=\'chatbox-username chatbox-message-username\'  data-user=\'' + message.userId + '\' >' + message.username + '</span>&nbsp;:&nbsp;' + '</strong>' + '</span>' + '<span class=\'msg\'>' + message.msg + '</span>' + '</span>'
               }
               html += '</p>';
               $('#chatbox').append(html)
            }
            if (scroll) {
               $('#chatbox')[0].scrollTop = $('#chatbox').prop('scrollHeight') * 2
            }
         }
      }

The correct way would be:
Code:

      if (data.messages) {
         var scroll = !this.messages || this.messages.length != data.messages.length;
         this.messages = data.messages;
         $('#chatbox').empty();
         var cb_content = "";
         if (this.messages) {
            for (var j = 0; j < this.messages.length; j++) {
               var message = this.messages[j];
               var html = '<p class=\'chatbox_row_' + (j % 2 == 1 ? 2 : 1) + ' clearfix\'>' + '<span class=\'date-and-time\' title=\'' + message.date + '\'>[' + message.datetime + ']</span>';
               if (message.userId == -10) {
                  html += '<span class=\'msg\'>' + '<span style=\'color:' + message.msgColor + '\'>' + '<strong> ' + message.msg + '</strong>' + '</span>' + '</span>'
               } else {
                  html += '<span class=\'user-msg\'>' + '<span class=\'user\' style=\'color:' + message.user.color + '\'>' + '<strong> ' + (message.user.admin ? '@ ' : '') + '<span class=\'chatbox-username chatbox-message-username\'  data-user=\'' + message.userId + '\' >' + message.username + '</span>&nbsp;:&nbsp;' + '</strong>' + '</span>' + '<span class=\'msg\'>' + message.msg + '</span>' + '</span>'
               }
               html += '</p>';
               cb_content += html;
            }
            $("#chatbox").append(cb_content);
            if (scroll) {
               $('#chatbox')[0].scrollTop = $('#chatbox').prop('scrollHeight') * 2
            }
         }
      }
Thus the speed with which messages are processed locally increases to 80%.

JS
avatar
JScript
Forumember

Male Posts : 741
Reputation : 172
Language : PT-BR, EN
Location : Brazil

http://jscript.forumeiros.com/

Back to top Go down

Solved Re: #1375 Chatbox issues

Post by chandoi on February 11th 2015, 6:46 pm

The "archives" in my chatbox is gone!


chandoi
Forumember

Posts : 39
Reputation : 2
Language : English

http://4everfriends.forumvi.com

Back to top Go down

Solved Re: #1375 Chatbox issues

Post by smurfavr on February 11th 2015, 7:29 pm

By pressing a button Archives all buttons below the chat disappear. Another problem is the Send button is not visible well, very pale.
The problems are for all users.

http://smurfa.bulgarianforum.net/portal
avatar
smurfavr
Active Poster

Male Posts : 1586
Reputation : 13
Language : Bulgarian

http://smurfa.bulgarianforum.net/

Back to top Go down

Solved Re: #1375 Chatbox issues

Post by KandiMan on February 11th 2015, 11:02 pm

So I've just noticed that none of our javascripts will work in the chatbox anymore. Is there anyway you can either add the template of the chatbox to the list  so we can add our own javascript for cool effects. or make it so that JS In All Pages works in the chatbox as well? It's for everyones pages so I don't need to give the URL or a screenshot. Please and hurry on this issue as some of the features I used to have don't work anymore and members are complaining.

KandiMan
New Member

Posts : 3
Reputation : 1
Language : English

Back to top Go down

Solved Re: #1375 Chatbox issues

Post by chandoi on February 11th 2015, 11:05 pm

Anybody home? My forum has a chatbox without "archives" nor "auto refresh" buttons all day now.

chandoi
Forumember

Posts : 39
Reputation : 2
Language : English

http://4everfriends.forumvi.com

Back to top Go down

Solved Re: #1375 Chatbox issues

Post by Eugeo Igvalt on February 11th 2015, 11:08 pm

There's no Archives in my Chat which is Phpbb3. http://prntscr.com/63yojt However, it's still there for Phpbb2 Forums
avatar
Eugeo Igvalt
Forumember

Male Posts : 289
Reputation : 17
Language : EN, SPA
Location : Puerto Rico

http://www.NewbForums.com

Back to top Go down

Solved Re: #1375 Chatbox issues

Post by brandon_g on February 11th 2015, 11:18 pm

chandoi wrote:Anybody home? My forum has a chatbox without "archives" nor "auto refresh" buttons all day now.

I am sure Buttercup will inform the techs of this issue when she gets in tommorow morning. In the meantime just be patient. Looks like not all the problems were solved after all. Sad I hate it when that happens! You think finally got them all and bang another one reveals itself. I hope the rest will be sorted soon.
avatar
brandon_g
Support Moderator
Support Moderator

Male Posts : 5992
Reputation : 549
Language : English
Location : USA

http://broadcastingduo.forumotion.com/

Back to top Go down

Solved Re: #1375 Chatbox issues

Post by Zeedief on February 12th 2015, 3:20 am

My forum's chatbox also no longer has the "archives" button, despite having it just yesterday. Not sure what's going on with that...
avatar
Zeedief
Forumember

Male Posts : 40
Reputation : 2
Language : English
Location : Some place

http://thenforumsite.forumotion.com

Back to top Go down

Solved Re: #1375 Chatbox issues

Post by Eugeo Igvalt on February 12th 2015, 4:43 am

Zeedief wrote:My forum's chatbox also no longer has the "archives" button, despite having it just yesterday. Not sure what's going on with that...
Yes. I believe Buttercup is already aware and the Technicians too. It affected my forum too. But I'm sure it will be solved eventually ^^  Little by little this Chatbox will soon be fully stable with a little patience.
avatar
Eugeo Igvalt
Forumember

Male Posts : 289
Reputation : 17
Language : EN, SPA
Location : Puerto Rico

http://www.NewbForums.com

Back to top Go down

Solved Re: #1375 Chatbox issues

Post by Shadow on February 12th 2015, 9:50 am

Hello dear members

Your problems have been reported to the technicians Smile
For the archives button, it is a cache issue. Thanks for clear your cache thumleft

@smurfavr

1- It is normal buttons disappear while connected to the archive.
2- "Send button" very pale. You customized your forum a lot. So make sure it also happens when you remove your personal CSS, JS and Templates.

Thanks :rose:


No help without your forum url
No support via private message


avatar
Shadow
Administrator
Administrator

Female Posts : 15863
Reputation : 1685
Language : French, English

http://help.forumotion.com

Back to top Go down

Solved Re: #1375 Chatbox issues

Post by Eugeo Igvalt on February 12th 2015, 2:55 pm

Buttercup wrote:Hello dear members

Your problems have been reported to the technicians Smile
For the archives button, it is a cache issue. Thanks for clear your cache thumleft

@smurfavr

1- It is normal buttons disappear while connected to the archive.
2- "Send button" very pale. You customized your forum a lot. So make sure it also happens when you remove your personal CSS, JS and Templates.

Thanks :rose:
Thanks Buttercup! I have the archives back in my Forum now
avatar
Eugeo Igvalt
Forumember

Male Posts : 289
Reputation : 17
Language : EN, SPA
Location : Puerto Rico

http://www.NewbForums.com

Back to top Go down

Solved Re: #1375 Chatbox issues

Post by Agent Ward on February 12th 2015, 4:16 pm

My archive was gone yesterday, but now it's back today. Huh.
avatar
Agent Ward
Forumember

Male Posts : 38
Reputation : 2
Language : English.
Location : California.

http://spamheaven.cakeforum.biz/

Back to top Go down

Solved Re: #1375 Chatbox issues

Post by seadevil on February 12th 2015, 6:24 pm

http://whona.realtvboard.com/

I am still having trouble personally with new posts from other members not showing up unless I make a new post after theirs, refresh the page, toggle back and forth from Archives, or navigate away to another page and come back.  So I guess its a matter of not autorefreshing after new posts - other than after my own.  This only happens at my computer at my place of business, which uses an older version of Windows and IE...if that makes a difference.  At home on my laptop using Windows 8, its fine.
avatar
seadevil
New Member

Posts : 14
Reputation : 1
Language : English

http://whona.realtvboard.com/

Back to top Go down

Solved Re: #1375 Chatbox issues

Post by SLGray on February 12th 2015, 10:40 pm

seadevil wrote:http://whona.realtvboard.com/

I am still having trouble personally with new posts from other members not showing up unless I make a new post after theirs, refresh the page, toggle back and forth from Archives, or navigate away to another page and come back.  So I guess its a matter of not autorefreshing after new posts - other than after my own.  This only happens at my computer at my place of business, which uses an older version of Windows and IE...if that makes a difference.  At home on my laptop using Windows 8, its fine.
Clear the browser's cache and history.


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.

avatar
SLGray
Administrator
Administrator

Male Posts : 40509
Reputation : 2733
Language : English
Location : United States

https://fmthemes.forumotion.com/

Back to top Go down

Solved Re: #1375 Chatbox issues

Post by seadevil on February 13th 2015, 3:46 pm

I clear that stuff all the time, plus I auto delete when i exit IE. 

That doesn't help.
avatar
seadevil
New Member

Posts : 14
Reputation : 1
Language : English

http://whona.realtvboard.com/

Back to top Go down

Solved Re: #1375 Chatbox issues

Post by Eugeo Igvalt on February 13th 2015, 4:10 pm

seadevil wrote:I clear that stuff all the time, plus I auto delete when i exit IE. 

That doesn't help.

Have you tried another Browser that is not IE?
avatar
Eugeo Igvalt
Forumember

Male Posts : 289
Reputation : 17
Language : EN, SPA
Location : Puerto Rico

http://www.NewbForums.com

Back to top Go down

Page 1 of 2 1, 2  Next

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum