The forum of the forums
Welcome to the Official Support Forum of Forumotion!

To take full advantage of everything offered by our forum, please log in if you are already a member, or join our community if you've not yet.



Create a free forum like this one.

Problem with the "HTML allowed" option for forum posts

View previous topic View next topic Go down

In progress Problem with the "HTML allowed" option for forum posts

Post by Acsama on February 29th 2012, 3:24 am

I have set the "allow HTML" in the administration panel of my forum to: "YES", but in spite of it when I post a new message in the forum, the HTML code in the post doesn't work. It works in the Preview, but once I post the message, it is not displayed, only the bare code is visible. When I click Edit then, I can see under the post that the "deactivate HTML for this post" is ticked, but no matter if I untick it and save the message, it becomes ticked every time and only the bare code is visible. How can this be solved? This way the HTML codes doen't work for the forum posts.

Acsama
New Member

Posts : 18
Reputation : 1
Language : English

Back to top Go down

In progress Re: Problem with the "HTML allowed" option for forum posts

Post by SLGray on February 29th 2012, 3:45 am

Do you have it check to allow HTML in your profile?


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 35613
Reputation : 2372
Language : English
Location : United States

http://fmthemes.forumotion.com/

Back to top Go down

In progress Re: Problem with the "HTML allowed" option for forum posts

Post by Acsama on February 29th 2012, 4:26 am

You mean in the Administration Control Panel? There I switched it on.

Acsama
New Member

Posts : 18
Reputation : 1
Language : English

Back to top Go down

In progress Re: Problem with the "HTML allowed" option for forum posts

Post by SLGray on February 29th 2012, 4:29 am

No in your profile on the forum.


When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.


SLGray
Administrator
Administrator

Male Posts : 35613
Reputation : 2372
Language : English
Location : United States

http://fmthemes.forumotion.com/

Back to top Go down

In progress Re: Problem with the "HTML allowed" option for forum posts

Post by xGraphicGodx on February 29th 2012, 4:29 am

No, go to your profile,
and then click on Preferences, then scroll down to "Allows allow HTML" and make sure thats yes, then save.


Hope I helped! Wink

xGraphicGodx
Forumember

Male Posts : 125
Reputation : 12
Language : English

http://computerspeech.forumotion.com

Back to top Go down

In progress Re: Problem with the "HTML allowed" option for forum posts

Post by Acsama on February 29th 2012, 7:24 pm

Thank you!

It works, but I don't understand how a profile setting can have effect on what is happening in the system when its handling the threads. I thought these procedures are defined in the Admin panel.

By the way if users want the html codes work, they also need to allow this option in their profile?

Acsama
New Member

Posts : 18
Reputation : 1
Language : English

Back to top Go down

In progress Re: Problem with the "HTML allowed" option for forum posts

Post by Sanket on February 29th 2012, 7:25 pm

Yes, it needs to be activated in the profile as well.

Sanket
ForumGuru

Male Posts : 48766
Reputation : 2819
Language : English
Location : Mumbai

http://webartzforum.com

Back to top Go down

In progress Re: Problem with the "HTML allowed" option for forum posts

Post by Acsama on March 2nd 2012, 1:07 am

I have noticed that even if I set show HTMLs in my profile, those users who doesn't have it set 'ON' won't see the HTML, only the bare code. This is quite unpractical, because if I post a HTML code, I do that so that others can see the graphic or any other things the code creates, I want them to see. Users who don't know that they have to allow HTMLs by themselves in their profile might think that I am doing mistakes all the time when posting HTML codes, as the codes appear as bare codes for them. I am using internet for 14 years but up to now I never met this solution that you have to set in your profile to allow HTMLs in case you want to see them. In the forums I am present at it is never the case, so I guess many users don't know about it.

Isn't there a way I can set that every user who signs up would have this HTML visible feature 'ON' by default? If you are only a guest, HTMLs are visible, so why not allow it for members? I don't see the logic why it is on NO by default.

Acsama
New Member

Posts : 18
Reputation : 1
Language : English

Back to top Go down

In progress Re: Problem with the "HTML allowed" option for forum posts

Post by Sanket on March 2nd 2012, 6:20 am

Sorry, its currently not possible.

I don't see anything wrong with the current system wherein users have the option not to see the html.

Sanket
ForumGuru

Male Posts : 48766
Reputation : 2819
Language : English
Location : Mumbai

http://webartzforum.com

Back to top Go down

In progress Re: Problem with the "HTML allowed" option for forum posts

Post by Acsama on March 2nd 2012, 6:35 am

Well, once you allow HTML in the forum, why setting it off by default? It is against common sense. It is okay until the point you can switch them OFF by yourself, but to set it to OFF by default is quite an annoying feature. Moreover it is also odd that for guests it is visible, but once you sign in, they won't be, as by default the visibility is turned off. And if there are others like me, they won't even know why. Your forums are the only place where I met this solution. That once you log on, only if HTML is allowed in your profile, you can use it and see it. This way a useful feature becomes useless. And all because of the lack of a simple solution that you simply cannot define to have it on by default. I think it is a quite simple and logical feature that is missing from your forums.

And there is an other annoying thing that if there is a member who doesn't know like me that in the profile you have to turn on the visibility, he posts a message, tick the "HTML allowed" option under the message box when posting, yet, no visible HTML. And as a result every of them crying to me in the forum and sending PMs about why the feature doesn't work.

So until you have the option to turn this thing on and off, there is no problem. The problem comes with that there are inconsistencies in your system: if you allow them, why are they OFF by default, and if you can allow it under the message box when starting a thread or posting, why isn't it enough to turn it on there? This is messing up things very much.

Acsama
New Member

Posts : 18
Reputation : 1
Language : English

Back to top Go down

In progress Re: Problem with the "HTML allowed" option for forum posts

Post by Sanket on March 2nd 2012, 7:04 am

I will explain, guests see it because it is enabled on your forum.

Members don't see it, because they have a choice/preference on what they want to see.

Giving the flexibility to a user to choose his option, infact is the best thing in my opinion. You don't want to force your users to do a certain thing.

Anyways, thats how things are at the moment in relation to this feature. Nothing can be done to change it. You can inform the users of the same.

Also, you can make suggestion if you like if its not already suggested.
Thanks.

Sanket
ForumGuru

Male Posts : 48766
Reputation : 2819
Language : English
Location : Mumbai

http://webartzforum.com

Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum