The forum of the forums
Would you like to react to this message? Create an account in a few clicks or log in to continue.

SSL Certificate problem

+2
SLGray
KneelB4Zod!
6 posters

Go down

Solved SSL Certificate problem

Post by KneelB4Zod! 23rd May 2019, 20:15

Hello, my current problem is as following:

I bought customized domain yesterday or the day before. I already have forum under my customized domain. In AP->Misc->Summary & Management there was a message regarding istalation of SSL certificate for a while (maybe for 24 hours).

Now the SSL certificate is installed, is active and there's a message that it will expire in 29 days. However, every time I try to turn on HTTPS the forum becomes "unsecure" and in the address bar there's message that the certificate is nod valid. So I had to turn off HTTPS and, right now, I'm not sure if I should wait little bit more because the certificate is not fully updated yet or there is some issue that was caused by me or by some kind of system error.

Thanks in advance for your help. Smile


Last edited by KneelB4Zod! on 24th May 2019, 14:30; edited 1 time in total
KneelB4Zod!
KneelB4Zod!
Forumember

Posts : 36
Reputation : 1
Language : English

http://zodlikeproductions.forumotion.eu/

Back to top Go down

Solved Re: SSL Certificate problem

Post by SLGray 23rd May 2019, 20:30

The topic was posted in the wrong section, so I have moved it to the correct section.
Please read our forum rules:  ESF General Rules


SSL Certificate problem Slgray10

When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.
SLGray
SLGray
Administrator
Administrator

Male Posts : 51528
Reputation : 3519
Language : English
Location : United States

https://forumsclub.com/gc/128-link-directory/

Back to top Go down

Solved Re: SSL Certificate problem

Post by SarkZKalie 23rd May 2019, 21:12

Try to deactivate HTTPS and remove your custom domain from database. Let's it refresh after few days before you re-activating a new one.


SSL Certificate problem Sarkzk10
SarkZKalie
SarkZKalie
Support Moderator
Support Moderator

Male Posts : 1433
Reputation : 220
Language : English

https://rotavn.forumotion.com/

Back to top Go down

Solved Re: SSL Certificate problem

Post by KneelB4Zod! 23rd May 2019, 21:24

SarkZKalie wrote:Try to deactivate HTTPS and remove your custom domain from database. Let's it refresh after few days before you re-activating a new one.

Well, HTTPS is now deactivated. By "remove your custom domain from database" do you mean to delete it Mis->Sumary & Management->Domain name?
KneelB4Zod!
KneelB4Zod!
Forumember

Posts : 36
Reputation : 1
Language : English

http://zodlikeproductions.forumotion.eu/

Back to top Go down

Solved Re: SSL Certificate problem

Post by brandon_g 23rd May 2019, 22:22

I would not remove your domain name. You have to make sure that all images and links on the site are also in https or else you will still get the insecure label.

-Brandon


SSL Certificate problem Brando10
Remember to mark your topic SSL Certificate problem Solved15 when a solution is found.
General Rules | Tips & Tricks | FAQ | Forgot Founder Password?

SSL Certificate problem Scre1476
Team Leader
Review Section Rules | Request A Review | Sticker Points
brandon_g
brandon_g
Manager
Manager

Male Posts : 10112
Reputation : 923
Language : English
Location : USA

https://www.broadcastingduo.com

Back to top Go down

Solved Re: SSL Certificate problem

Post by KneelB4Zod! 23rd May 2019, 22:33

Well, it all started after the domain name change. Till then everything worked well. I had HTTPS enabled and there was no problem at all. I have it for months already, as a part of my Premium package. It is impossible to check all the images and links now, there is almost 42 thousand messages.
KneelB4Zod!
KneelB4Zod!
Forumember

Posts : 36
Reputation : 1
Language : English

http://zodlikeproductions.forumotion.eu/

Back to top Go down

Solved Re: SSL Certificate problem

Post by brandon_g 24th May 2019, 00:59

Oh thats why, cause now the domain isnt registered under the certificate. That would be why your having the issues you are. Always buy the domain first, then activate the certificate. Now we might have to make a ticket for head office to correct this issue on their end.


SSL Certificate problem Brando10
Remember to mark your topic SSL Certificate problem Solved15 when a solution is found.
General Rules | Tips & Tricks | FAQ | Forgot Founder Password?

SSL Certificate problem Scre1476
Team Leader
Review Section Rules | Request A Review | Sticker Points
brandon_g
brandon_g
Manager
Manager

Male Posts : 10112
Reputation : 923
Language : English
Location : USA

https://www.broadcastingduo.com

Back to top Go down

Solved Re: SSL Certificate problem

Post by SLGray 24th May 2019, 04:37

Since you deactivated, turn it back on again.  It should correct itself now.

If you are buying a domain name, you need to activate the SSL certificate after the domain name has been added and working correctly.


SSL Certificate problem Slgray10

When your topic has been solved, ensure you mark the topic solved.
Never post your email in public.
SLGray
SLGray
Administrator
Administrator

Male Posts : 51528
Reputation : 3519
Language : English
Location : United States

https://forumsclub.com/gc/128-link-directory/

Back to top Go down

Solved Re: SSL Certificate problem

Post by KneelB4Zod! 24th May 2019, 07:39

Well, I buy Premium packaage every month via PayPal recurred payments for about one year. I have HTTPS turned on for a long time as well. Every month, with a new reccured payment, SSL expiration is postponed for another 31 days or so. This month I decided to buy cutomized domain. I chose one, which was available, and roughly after 24 hours it was activated. For a while both domains, my origina one and the new, customized one, were available. As there was security warning under the new one I checked AP and in Misc - > Sumary & Management -> Enabling the SSL Certificate (HTTPS) there was an information saying that the SSL certificate being installed. Now, in the same section, is written following:

SSL Certificate problem Captur28

Currently the setup is following:

SSL Certificate problem Captur29


Only the customized domain is available and I can run it either as HTTP, which warns users about that the web is not secure, or as HTTPS with even stricter warning that the certificate is not valid and my adress bar looks like this:

SSL Certificate problem Vzstie24

I tried to turn off and on HTTPS but it still claim the web is not secure. During the night I had HTTPS turned off and people wrote me this:

"Not the relevant place to post this but I want to bring it to your attention Zod. When I go to www.zodlikeproductions.net it is giving a security certificate error and won't give access to the website. It wasn't like this earlier when you first switched to www.zodlikeproductions.net, only now. Website can still be accessed - but only by avoiding the homepage, but of course others who try to access the site might not know this."

Now I turned HTTPS back on and I have warning about that the certificate is not valid.
KneelB4Zod!
KneelB4Zod!
Forumember

Posts : 36
Reputation : 1
Language : English

http://zodlikeproductions.forumotion.eu/

Back to top Go down

Solved Re: SSL Certificate problem

Post by The Godfather 24th May 2019, 12:24

hello @KneelB4Zod!

there is no problem in what you describe so don't do anything and wait!

indeed, an SSL certificate is generated for a specific url. In your case, the one in place has been generated for the basic forum url. Once you have acquired the domain name, it is quite normal that the certificate issued for the basic url gives an alert on the personalized domain.

on our side, as soon as the personalized domain is active, a new SSL certificate is generated for it and as soon as it is ready, it's again installed on the personalized domain for it's security. thus, both forum urls will be secured.

To do this, it takes time, usually a few hours and the admin has absolutely no need to do anything on his side except wait.

as soon as the certificate is ready, the personalized domain will automatically respond in HTTPS Wink
The Godfather
The Godfather
Administrator
Administrator

Posts : 5149
Reputation : 833

Back to top Go down

Solved Re: SSL Certificate problem

Post by KneelB4Zod! 24th May 2019, 14:30

Understood. Now it seems to be okay. Thanks for your efforts and time! Great support from the staff as usually.

Very good
KneelB4Zod!
KneelB4Zod!
Forumember

Posts : 36
Reputation : 1
Language : English

http://zodlikeproductions.forumotion.eu/

Back to top Go down

Solved Re: SSL Certificate problem

Post by skouliki 24th May 2019, 14:48

Problem solved & topic archived.
Please read our forum rules: ESF General Rules
skouliki
skouliki
Manager
Manager

Female Posts : 15243
Reputation : 1700
Language : English,Greek
Location : Greece

http://iconskouliki.forumgreek.com

Back to top Go down

Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum